aboutsummaryrefslogtreecommitdiff
path: root/4.1.0
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-23 04:20:15 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-23 04:20:15 +0000
commite20ca1baa42456376442aea0430e4fff33958e27 (patch)
tree6493d1ef0b2917c2250026e917c0c778decae7e4 /4.1.0
parentfix new make handling of SHELL #130010 (diff)
downloadgcc-patches-e20ca1baa42456376442aea0430e4fff33958e27.tar.gz
gcc-patches-e20ca1baa42456376442aea0430e4fff33958e27.tar.bz2
gcc-patches-e20ca1baa42456376442aea0430e4fff33958e27.zip
fix POSIX errors in makefiles
Diffstat (limited to '4.1.0')
-rw-r--r--4.1.0/gentoo/88_all_gcc-make-POSIX-syntax-updates.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/4.1.0/gentoo/88_all_gcc-make-POSIX-syntax-updates.patch b/4.1.0/gentoo/88_all_gcc-make-POSIX-syntax-updates.patch
new file mode 100644
index 0000000..a7fb68a
--- /dev/null
+++ b/4.1.0/gentoo/88_all_gcc-make-POSIX-syntax-updates.patch
@@ -0,0 +1,13 @@
+--- gcc-4_1-branch/gcc/Makefile.in
++++ gcc-4_1-branch/gcc/Makefile.in
+@@ -3146,8 +3146,8 @@ install-gcc-tooldir:
+ macro_list: s-macro_list; @true
+ s-macro_list : $(GCC_PASSES)
+ echo | $(GCC_FOR_TARGET) -E -dM - | \
+- sed -n 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p ; \
+- s/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
++ sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
++ -e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
+ sort -u > tmp-macro_list
+ $(SHELL) $(srcdir)/../move-if-change tmp-macro_list macro_list
+ $(STAMP) s-macro_list