aboutsummaryrefslogtreecommitdiff
path: root/4.8.4
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2016-12-28 21:18:58 +0000
committerMagnus Granberg <zorry@gentoo.org>2016-12-28 21:18:58 +0000
commitbf4bee3bf91539a3c9db53af677bae61f95494d6 (patch)
tree5499f1c27b2add785e42b96ad48c8d07a4d31603 /4.8.4
parentadd gcc-6.3 patchset (diff)
downloadgcc-patches-bf4bee3bf91539a3c9db53af677bae61f95494d6.tar.gz
gcc-patches-bf4bee3bf91539a3c9db53af677bae61f95494d6.tar.bz2
gcc-patches-bf4bee3bf91539a3c9db53af677bae61f95494d6.zip
bump gcc 5.4 gentoo patchset to 1.2
Diffstat (limited to '4.8.4')
-rw-r--r--4.8.4/pie/40_all_gcc48_config_esp.patch14
-rw-r--r--4.8.4/pie/README.Changelog7
-rw-r--r--4.8.4/pie/README.history4
3 files changed, 18 insertions, 7 deletions
diff --git a/4.8.4/pie/40_all_gcc48_config_esp.patch b/4.8.4/pie/40_all_gcc48_config_esp.patch
index 535b638..e90f65c 100644
--- a/4.8.4/pie/40_all_gcc48_config_esp.patch
+++ b/4.8.4/pie/40_all_gcc48_config_esp.patch
@@ -1,13 +1,13 @@
-2014-01-04 Magnus Granberg <zorry@gentoo.org>
+2015-05-12 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20140104.1
+ Version 20150512.1
--- gcc/config/esp.h 2010-04-09 16:14:00.000000000 +0200
+++ gcc/config/esp.h 2012-06-23 01:00:31.248348491 +0200
-@@ -0,0 +1,128 @@
+@@ -0,0 +1,132 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20140104.1
++ * Version 201500512.1
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
@@ -51,11 +51,15 @@
+
+ /* This will add -fstack-protector-all if we don't have -nostdlib -nodefaultlibs -fno-stack-protector -fstack-protector
+ -fstack-protector-all and we have EFAULT_SSP or EFAULT_PIE_SSP defined. */
-+ #if defined ( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )
++ #if defined (( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )) && !defined (__arm__)
+ #define ESP_OPTIONS_SSP_SPEC \
+ "%{nostdlib|nodefaultlibs|ffreestanding|fno-stack-protector| \
+ fstack-protector|fstack-protector-all:;:-fstack-protector-all} \
+ %{fstack-check|fstack-check=*:;: -fstack-check}"
++ #elif defined (( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )) && defined (__arm__)
++ #define ESP_OPTIONS_SSP_SPEC \
++ "%{nostdlib|nodefaultlibs|ffreestanding|fno-stack-protector| \
++ fstack-protector|fstack-protector-all:;:-fstack-protector-all}"
+ #else
+ #define ESP_OPTIONS_SSP_SPEC ""
+ #endif
diff --git a/4.8.4/pie/README.Changelog b/4.8.4/pie/README.Changelog
index 7a55349..4c1b30e 100644
--- a/4.8.4/pie/README.Changelog
+++ b/4.8.4/pie/README.Changelog
@@ -1,5 +1,10 @@
+0.6.2 Magnus Granberg <zorry@gentoo.org>
+
+ #518598
+ * gcc/config/esp.h don't use -fstack-check for arm
+
0.6.1 Magnus Granberg <zorry@gentoo.org>
-
+
#528690
* libgcc/Makefile Disable -fstack-check
diff --git a/4.8.4/pie/README.history b/4.8.4/pie/README.history
index ca6a77a..eaedefc 100644
--- a/4.8.4/pie/README.history
+++ b/4.8.4/pie/README.history
@@ -1,3 +1,5 @@
+0.6.2 12 May 2015
+ U 40_all_gcc48_config_esp.h.patch
0.6.1 3 Dec 2014
U 03_all_gcc48_Makefile.in.patch
0.6.0 7 jun 2014
@@ -34,7 +36,7 @@
+ 36_all_gcc48_config_mips.patch
+ 37_all_gcc48_config_ia64.patch
- 35_all_gcc47_config_esp.h.patch
- - 35_all_gcc48_config_esp.h.patch
+ + 40_all_gcc48_config_esp.h.patch
U README
0.5.4 02 Oct 2012
U 01_all_gcc47_configure.patch