aboutsummaryrefslogtreecommitdiff
path: root/4.8.4
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-02-10 00:39:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-02-10 00:39:38 +0000
commitfd6a6d5785cd9a41795b260ba7c203b5ee1b6684 (patch)
tree065242b10847531706f5b1a2553a0df6f3e13e5d /4.8.4
parentFix typo in piepatchset 0.6.2 for gcc 4.9.2 (diff)
downloadgcc-patches-fd6a6d5785cd9a41795b260ba7c203b5ee1b6684.tar.gz
gcc-patches-fd6a6d5785cd9a41795b260ba7c203b5ee1b6684.tar.bz2
gcc-patches-fd6a6d5785cd9a41795b260ba7c203b5ee1b6684.zip
Add 20_all_msgfmt-libstdc++-link.patch from 4.7.4 to 4.8.4 and 4.9.2
Diffstat (limited to '4.8.4')
-rw-r--r--4.8.4/gentoo/20_all_msgfmt-libstdc++-link.patch39
-rw-r--r--4.8.4/gentoo/README.history3
2 files changed, 42 insertions, 0 deletions
diff --git a/4.8.4/gentoo/20_all_msgfmt-libstdc++-link.patch b/4.8.4/gentoo/20_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 0000000..a70ea50
--- /dev/null
+++ b/4.8.4/gentoo/20_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.am
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.in
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
diff --git a/4.8.4/gentoo/README.history b/4.8.4/gentoo/README.history
index 5e76f56..ecfe96e 100644
--- a/4.8.4/gentoo/README.history
+++ b/4.8.4/gentoo/README.history
@@ -1,3 +1,6 @@
+1.1 09 Feb 2015
+ + 20_all_msgfmt-libstdc++-link.patch
+
1.0 26 Dec 2014
+ 09_all_default-ssp.patch
+ 10_all_default-fortify-source.patch