aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-03-26 12:03:46 +0800
committerSam James <sam@gentoo.org>2022-03-31 11:07:31 +0100
commit1e3e5d055fe83557f3d861e2277a98885df4b93e (patch)
tree09038a45862cd9d8273473f6c3f54c97fb1b4709
parent12.0.0: cut patchset 3 (diff)
downloadgcc-patches-1e3e5d05.tar.gz
gcc-patches-1e3e5d05.tar.bz2
gcc-patches-1e3e5d05.zip
12.0.0: cut patchset 4
- Drop the upstreamed patch (13) - Rebase to avoid fuzz (on top of upstream commit 81faedaa8e2819fc) Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--12.0.0/gentoo/01_all_default-fortify-source.patch2
-rw-r--r--12.0.0/gentoo/03_all_default-warn-trampolines.patch4
-rw-r--r--12.0.0/gentoo/05_all_alpha-mieee-default.patch2
-rw-r--r--12.0.0/gentoo/06_all_ia64_note.GNU-stack.patch8
-rw-r--r--12.0.0/gentoo/08_all_libiberty-pic.patch2
-rw-r--r--12.0.0/gentoo/09_all_nopie-all-flags.patch2
-rw-r--r--12.0.0/gentoo/10_all_sh-drop-sysroot-suffix.patch2
-rw-r--r--12.0.0/gentoo/11_all_ia64-TEXTREL.patch2
-rw-r--r--12.0.0/gentoo/12_all_disable-systemtap-switch.patch8
-rw-r--r--12.0.0/gentoo/13_all_m68k-textrel-on-libgcc.patch93
-rw-r--r--12.0.0/gentoo/14_all_respect-build-cxxflags.patch6
-rw-r--r--12.0.0/gentoo/20_all_libstdcxx-no-vtv.patch12
-rw-r--r--12.0.0/gentoo/22_all_default_ssp-buffer-size.patch2
-rw-r--r--12.0.0/gentoo/23_all_EXTRA_OPTIONS-z-now.patch4
-rw-r--r--12.0.0/gentoo/24_all_EXTRA_OPTIONS-fstack-clash-protection.patch10
-rw-r--r--12.0.0/gentoo/26_all_plugin-objdump.patch4
-rw-r--r--12.0.0/gentoo/README.history19
17 files changed, 54 insertions, 128 deletions
diff --git a/12.0.0/gentoo/01_all_default-fortify-source.patch b/12.0.0/gentoo/01_all_default-fortify-source.patch
index 5bfec1d..d9f001a 100644
--- a/12.0.0/gentoo/01_all_default-fortify-source.patch
+++ b/12.0.0/gentoo/01_all_default-fortify-source.patch
@@ -7,7 +7,7 @@ initially Gentoo used too complicated macro.
# DP: if the optimization level is > 0
--- a/gcc/c-family/c-cppbuiltin.cc
+++ b/gcc/c-family/c-cppbuiltin.cc
-@@ -951,6 +951,12 @@ c_cpp_builtins (cpp_reader *pfile)
+@@ -1510,6 +1510,12 @@ c_cpp_builtins (cpp_reader *pfile)
builtin_define_with_value ("__REGISTER_PREFIX__", REGISTER_PREFIX, 0);
builtin_define_with_value ("__USER_LABEL_PREFIX__", user_label_prefix, 0);
diff --git a/12.0.0/gentoo/03_all_default-warn-trampolines.patch b/12.0.0/gentoo/03_all_default-warn-trampolines.patch
index 7a644cb..fb6d8bc 100644
--- a/12.0.0/gentoo/03_all_default-warn-trampolines.patch
+++ b/12.0.0/gentoo/03_all_default-warn-trampolines.patch
@@ -2,7 +2,7 @@ Enable -Wtrampolines by default.
--- a/gcc/common.opt
+++ b/gcc/common.opt
-@@ -712,7 +712,7 @@ Common Var(warn_system_headers) Warning
+@@ -798,7 +798,7 @@ Common Var(warn_system_headers) Warning
Do not suppress warnings from system headers.
Wtrampolines
@@ -10,4 +10,4 @@ Enable -Wtrampolines by default.
+Common Var(warn_trampolines) Init(1) Warning
Warn whenever a trampoline is generated.
- Wtype-limits
+ Wtrivial-auto-var-init
diff --git a/12.0.0/gentoo/05_all_alpha-mieee-default.patch b/12.0.0/gentoo/05_all_alpha-mieee-default.patch
index cf33f14..fd1de71 100644
--- a/12.0.0/gentoo/05_all_alpha-mieee-default.patch
+++ b/12.0.0/gentoo/05_all_alpha-mieee-default.patch
@@ -16,7 +16,7 @@ behaving the same across arches under Linux.
--- a/gcc/config/alpha/alpha.h
+++ b/gcc/config/alpha/alpha.h
-@@ -96,6 +96,8 @@ along with GCC; see the file COPYING3. If not see
+@@ -94,6 +94,8 @@ along with GCC; see the file COPYING3. If not see
while (0)
#endif
diff --git a/12.0.0/gentoo/06_all_ia64_note.GNU-stack.patch b/12.0.0/gentoo/06_all_ia64_note.GNU-stack.patch
index 66a787e..7a1d4c6 100644
--- a/12.0.0/gentoo/06_all_ia64_note.GNU-stack.patch
+++ b/12.0.0/gentoo/06_all_ia64_note.GNU-stack.patch
@@ -20,7 +20,7 @@ http://gcc.gnu.org/PR21098
--- a/gcc/config/ia64/linux.h
+++ b/gcc/config/ia64/linux.h
-@@ -24,6 +24,8 @@ a copy of the GCC Runtime Library Exception along with this program;
+@@ -23,6 +23,8 @@ a copy of the GCC Runtime Library Exception along with this program;
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
<http://www.gnu.org/licenses/>. */
@@ -31,7 +31,7 @@ http://gcc.gnu.org/PR21098
#define CC1_SPEC "%{profile:-p} %{G*}"
--- a/gcc/config/rs6000/ppc-asm.h
+++ b/gcc/config/rs6000/ppc-asm.h
-@@ -352,7 +352,7 @@ GLUE(.L,name): \
+@@ -384,7 +384,7 @@ GLUE(.L,name): \
#endif
#endif
@@ -42,7 +42,7 @@ http://gcc.gnu.org/PR21098
#endif
--- a/libgcc/config/ia64/crtbegin.S
+++ b/libgcc/config/ia64/crtbegin.S
-@@ -252,3 +252,7 @@ __do_jv_register_classes:
+@@ -185,3 +185,7 @@ __do_jv_register_classes:
.weak __cxa_finalize
#endif
.weak _Jv_RegisterClasses
@@ -52,7 +52,7 @@ http://gcc.gnu.org/PR21098
+#endif
--- a/libgcc/config/ia64/crtend.S
+++ b/libgcc/config/ia64/crtend.S
-@@ -119,3 +119,6 @@ __do_global_ctors_aux:
+@@ -114,3 +114,6 @@ __do_global_ctors_aux:
br.ret.sptk.many rp
.endp __do_global_ctors_aux
diff --git a/12.0.0/gentoo/08_all_libiberty-pic.patch b/12.0.0/gentoo/08_all_libiberty-pic.patch
index b6160a7..3f0bae1 100644
--- a/12.0.0/gentoo/08_all_libiberty-pic.patch
+++ b/12.0.0/gentoo/08_all_libiberty-pic.patch
@@ -1,6 +1,6 @@
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
-@@ -246,6 +246,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
+@@ -265,6 +265,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
diff --git a/12.0.0/gentoo/09_all_nopie-all-flags.patch b/12.0.0/gentoo/09_all_nopie-all-flags.patch
index 48536e6..0f7c769 100644
--- a/12.0.0/gentoo/09_all_nopie-all-flags.patch
+++ b/12.0.0/gentoo/09_all_nopie-all-flags.patch
@@ -3,7 +3,7 @@ we compile it with older gcc and pie.
--- a/gcc/Makefile.in 2015-06-25 19:18:12.000000000 +0200
+++ b/gcc/Makefile.in 2016-04-22 00:12:54.029178860 +0200
-@@ -991,10 +991,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
+@@ -1054,10 +1054,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
# This is the variable to use when using $(COMPILER).
diff --git a/12.0.0/gentoo/10_all_sh-drop-sysroot-suffix.patch b/12.0.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
index 3dadd4c..fd3bda5 100644
--- a/12.0.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
+++ b/12.0.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
@@ -18,7 +18,7 @@ diff --git a/gcc/config.gcc b/gcc/config.gcc
index 55c314afdbd..c320f24f123 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -2866,8 +2866,6 @@ sh-*-elf* | sh[12346l]*-*-elf* | \
+@@ -3328,8 +3328,6 @@ sh-*-elf* | sh[12346l]*-*-elf* | \
if test x${enable_incomplete_targets} = xyes ; then
tm_defines="$tm_defines SUPPORT_SH1=1 SUPPORT_SH2E=1 SUPPORT_SH4=1 SUPPORT_SH4_SINGLE=1 SUPPORT_SH2A=1 SUPPORT_SH2A_SINGLE=1"
fi
diff --git a/12.0.0/gentoo/11_all_ia64-TEXTREL.patch b/12.0.0/gentoo/11_all_ia64-TEXTREL.patch
index d9d0ae8..69347f5 100644
--- a/12.0.0/gentoo/11_all_ia64-TEXTREL.patch
+++ b/12.0.0/gentoo/11_all_ia64-TEXTREL.patch
@@ -3,7 +3,7 @@ Bug: https://gcc.gnu.org/PR84553
Bug: https://bugs.gentoo.org/566118
--- a/gcc/config/ia64/ia64.cc
+++ a/gcc/config/ia64/ia64.cc
-@@ -10838,12 +10838,14 @@ ia64_hpux_reloc_rw_mask (void)
+@@ -10840,12 +10840,14 @@ ia64_hpux_reloc_rw_mask (void)
/* For others, relax this so that relocations to local data goes in
read-only segments, but we still cannot allow global relocations
diff --git a/12.0.0/gentoo/12_all_disable-systemtap-switch.patch b/12.0.0/gentoo/12_all_disable-systemtap-switch.patch
index d5ae8d0..4d69141 100644
--- a/12.0.0/gentoo/12_all_disable-systemtap-switch.patch
+++ b/12.0.0/gentoo/12_all_disable-systemtap-switch.patch
@@ -22,7 +22,7 @@ diff --git a/gcc/configure b/gcc/configure
index 3dcf7752b..c2049f117 100755
--- a/gcc/configure
+++ b/gcc/configure
-@@ -988,6 +988,7 @@ enable_gnu_unique_object
+@@ -1015,6 +1015,7 @@ enable_gnu_unique_object
enable_linker_build_id
enable_libssp
enable_default_ssp
@@ -30,7 +30,7 @@ index 3dcf7752b..c2049f117 100755
with_long_double_128
with_long_double_format
with_gc
-@@ -1740,6 +1741,7 @@ Optional Features:
+@@ -1773,6 +1774,7 @@ Optional Features:
compiler will always pass --build-id to linker
--enable-libssp enable linking against libssp
--enable-default-ssp enable Stack Smashing Protection as default
@@ -38,7 +38,7 @@ index 3dcf7752b..c2049f117 100755
--enable-maintainer-mode
enable make rules and dependencies not useful (and
sometimes confusing) to the casual installer
-@@ -29330,17 +29332,33 @@ fi
+@@ -31387,17 +31389,33 @@ fi
# Test for <sys/sdt.h> on the target.
@@ -80,7 +80,7 @@ index 3dcf7752b..c2049f117 100755
# Some glibc targets used DFmode long double, but with glibc 2.4
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -6000,14 +6000,28 @@ AC_SUBST([enable_default_ssp])
+@@ -6904,14 +6904,28 @@ AC_SUBST([enable_default_ssp])
# Test for <sys/sdt.h> on the target.
GCC_TARGET_TEMPLATE([HAVE_SYS_SDT_H])
diff --git a/12.0.0/gentoo/13_all_m68k-textrel-on-libgcc.patch b/12.0.0/gentoo/13_all_m68k-textrel-on-libgcc.patch
deleted file mode 100644
index a2aa100..0000000
--- a/12.0.0/gentoo/13_all_m68k-textrel-on-libgcc.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-https://gcc.gnu.org/PR86224
-
-From 1d89df42bdaf0745fd2a0d294471ac16f0553707 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Sat, 28 Jul 2018 11:33:27 +0100
-Subject: [PATCH] libgcc: m68k: avoid absolute relocation in shared library
-
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- libgcc/config/m68k/lb1sf68.S | 19 ++++++++++++++-----
- 1 file changed, 14 insertions(+), 5 deletions(-)
-
-diff --git a/libgcc/config/m68k/lb1sf68.S b/libgcc/config/m68k/lb1sf68.S
-index 325a7c17d9b..16c6dc3f5a7 100644
---- a/libgcc/config/m68k/lb1sf68.S
-+++ b/libgcc/config/m68k/lb1sf68.S
-@@ -435,7 +435,10 @@ $_exception_handler:
- .text
- FUNC(__mulsi3)
- .globl SYM (__mulsi3)
-+ .globl SYM (__mulsi3_internal)
-+ .hidden SYM (__mulsi3_internal)
- SYM (__mulsi3):
-+SYM (__mulsi3_internal):
- movew sp@(4), d0 /* x0 -> d0 */
- muluw sp@(10), d0 /* x0*y1 */
- movew sp@(6), d1 /* x1 -> d1 */
-@@ -458,7 +461,10 @@ SYM (__mulsi3):
- .text
- FUNC(__udivsi3)
- .globl SYM (__udivsi3)
-+ .globl SYM (__udivsi3_internal)
-+ .hidden SYM (__udivsi3_internal)
- SYM (__udivsi3):
-+SYM (__udivsi3_internal):
- #ifndef __mcoldfire__
- movel d2, sp@-
- movel sp@(12), d1 /* d1 = divisor */
-@@ -534,7 +540,10 @@ L2: subql IMM (1),d4
- .text
- FUNC(__divsi3)
- .globl SYM (__divsi3)
-+ .globl SYM (__divsi3_internal)
-+ .hidden SYM (__divsi3_internal)
- SYM (__divsi3):
-+SYM (__divsi3_internal):
- movel d2, sp@-
-
- moveq IMM (1), d2 /* sign of result stored in d2 (=1 or =-1) */
-@@ -557,7 +566,7 @@ L1: movel sp@(8), d0 /* d0 = dividend */
-
- L2: movel d1, sp@-
- movel d0, sp@-
-- PICCALL SYM (__udivsi3) /* divide abs(dividend) by abs(divisor) */
-+ PICCALL SYM (__udivsi3_internal) /* divide abs(dividend) by abs(divisor) */
- addql IMM (8), sp
-
- tstb d2
-@@ -577,13 +586,13 @@ SYM (__umodsi3):
- movel sp@(4), d0 /* d0 = dividend */
- movel d1, sp@-
- movel d0, sp@-
-- PICCALL SYM (__udivsi3)
-+ PICCALL SYM (__udivsi3_internal)
- addql IMM (8), sp
- movel sp@(8), d1 /* d1 = divisor */
- #ifndef __mcoldfire__
- movel d1, sp@-
- movel d0, sp@-
-- PICCALL SYM (__mulsi3) /* d0 = (a/b)*b */
-+ PICCALL SYM (__mulsi3_internal) /* d0 = (a/b)*b */
- addql IMM (8), sp
- #else
- mulsl d1,d0
-@@ -603,13 +612,13 @@ SYM (__modsi3):
- movel sp@(4), d0 /* d0 = dividend */
- movel d1, sp@-
- movel d0, sp@-
-- PICCALL SYM (__divsi3)
-+ PICCALL SYM (__divsi3_internal)
- addql IMM (8), sp
- movel sp@(8), d1 /* d1 = divisor */
- #ifndef __mcoldfire__
- movel d1, sp@-
- movel d0, sp@-
-- PICCALL SYM (__mulsi3) /* d0 = (a/b)*b */
-+ PICCALL SYM (__mulsi3_internal) /* d0 = (a/b)*b */
- addql IMM (8), sp
- #else
- mulsl d1,d0
---
-2.18.0
-
diff --git a/12.0.0/gentoo/14_all_respect-build-cxxflags.patch b/12.0.0/gentoo/14_all_respect-build-cxxflags.patch
index 14139ea..1f9a774 100644
--- a/12.0.0/gentoo/14_all_respect-build-cxxflags.patch
+++ b/12.0.0/gentoo/14_all_respect-build-cxxflags.patch
@@ -11,7 +11,7 @@ Fix by Peter Levine.
https://bugs.gentoo.org/581406
--- a/Makefile.in
+++ b/Makefile.in
-@@ -170,6 +170,7 @@
+@@ -176,6 +176,7 @@
# built for the build system to override those in BASE_FLAGS_TO_PASS.
EXTRA_BUILD_FLAGS = \
CFLAGS="$(CFLAGS_FOR_BUILD)" \
@@ -19,7 +19,7 @@ https://bugs.gentoo.org/581406
LDFLAGS="$(LDFLAGS_FOR_BUILD)"
# This is the list of directories to built for the host system.
-@@ -710,6 +711,7 @@
+@@ -842,6 +843,7 @@
"CC_FOR_BUILD=$(CC_FOR_BUILD)" \
"CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
"CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
@@ -29,7 +29,7 @@ https://bugs.gentoo.org/581406
"INSTALL=$(INSTALL)" \
--- a/Makefile.tpl
+++ b/Makefile.tpl
-@@ -172,6 +172,7 @@
+@@ -179,6 +179,7 @@
# built for the build system to override those in BASE_FLAGS_TO_PASS.
EXTRA_BUILD_FLAGS = \
CFLAGS="$(CFLAGS_FOR_BUILD)" \
diff --git a/12.0.0/gentoo/20_all_libstdcxx-no-vtv.patch b/12.0.0/gentoo/20_all_libstdcxx-no-vtv.patch
index 68508bd..e557b35 100644
--- a/12.0.0/gentoo/20_all_libstdcxx-no-vtv.patch
+++ b/12.0.0/gentoo/20_all_libstdcxx-no-vtv.patch
@@ -5,7 +5,7 @@ Bug: https://bugs.gentoo.org/582524
Bug: https://gcc.gnu.org/PR85884
--- a/libstdc++-v3/src/Makefile.am
+++ b/libstdc++-v3/src/Makefile.am
-@@ -217,7 +217,6 @@ CXXLINK = \
+@@ -277,7 +277,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -15,7 +15,7 @@ Bug: https://gcc.gnu.org/PR85884
# Symbol versioning for shared libraries.
--- a/libstdc++-v3/src/Makefile.in
+++ b/libstdc++-v3/src/Makefile.in
-@@ -511,7 +511,6 @@ CXXLINK = \
+@@ -642,7 +642,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -25,7 +25,7 @@ Bug: https://gcc.gnu.org/PR85884
@ENABLE_SYMVERS_TRUE@CLEANFILES = libstdc++-symbols.ver $(version_dep)
--- a/libstdc++-v3/src/c++11/Makefile.am
+++ b/libstdc++-v3/src/c++11/Makefile.am
-@@ -204,5 +204,4 @@ CXXLINK = \
+@@ -214,5 +214,4 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -33,7 +33,7 @@ Bug: https://gcc.gnu.org/PR85884
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
--- a/libstdc++-v3/src/c++11/Makefile.in
+++ b/libstdc++-v3/src/c++11/Makefile.in
-@@ -496,7 +496,6 @@ CXXLINK = \
+@@ -588,7 +588,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -43,7 +43,7 @@ Bug: https://gcc.gnu.org/PR85884
all: all-am
--- a/libstdc++-v3/src/c++98/Makefile.am
+++ b/libstdc++-v3/src/c++98/Makefile.am
-@@ -273,5 +273,4 @@ CXXLINK = \
+@@ -268,5 +268,4 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
@@ -51,7 +51,7 @@ Bug: https://gcc.gnu.org/PR85884
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
--- a/libstdc++-v3/src/c++98/Makefile.in
+++ b/libstdc++-v3/src/c++98/Makefile.in
-@@ -500,7 +500,6 @@ CXXLINK = \
+@@ -590,7 +590,6 @@ CXXLINK = \
$(LIBTOOL) --tag CXX --tag disable-shared \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXX) \
diff --git a/12.0.0/gentoo/22_all_default_ssp-buffer-size.patch b/12.0.0/gentoo/22_all_default_ssp-buffer-size.patch
index ae5a707..0e0dd42 100644
--- a/12.0.0/gentoo/22_all_default_ssp-buffer-size.patch
+++ b/12.0.0/gentoo/22_all_default_ssp-buffer-size.patch
@@ -3,7 +3,7 @@ Change the minimal SSP buffer size.
https://bugs.gentoo.org/484714
--- a/gcc/params.opt
+++ b/gcc/params.opt
-@@ -849,7 +849,7 @@ Common Joined UInteger Var(param_ssa_name_def_chain_limit) Init(512) Param Optim
+@@ -1012,7 +1012,7 @@ Common Joined UInteger Var(param_ssa_name_def_chain_limit) Init(512) Param Optim
The maximum number of SSA_NAME assignments to follow in determining a value.
-param=ssp-buffer-size=
diff --git a/12.0.0/gentoo/23_all_EXTRA_OPTIONS-z-now.patch b/12.0.0/gentoo/23_all_EXTRA_OPTIONS-z-now.patch
index b244690..8874b32 100644
--- a/12.0.0/gentoo/23_all_EXTRA_OPTIONS-z-now.patch
+++ b/12.0.0/gentoo/23_all_EXTRA_OPTIONS-z-now.patch
@@ -2,7 +2,7 @@ On Hardened we add some options like -z now
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -995,6 +995,12 @@ proper position among the other output files. */
+@@ -1001,6 +1001,12 @@ proper position among the other output files. */
#endif
#endif
@@ -15,7 +15,7 @@ On Hardened we add some options like -z now
#ifdef ENABLE_DEFAULT_PIE
#define PIE_SPEC "!no-pie"
#define NO_FPIE1_SPEC "fno-pie"
-@@ -1155,7 +1161,7 @@ proper position among the other output files. */
+@@ -1161,7 +1167,7 @@ proper position among the other output files. */
%(linker) " \
LINK_PLUGIN_SPEC \
"%{flto|flto=*:%<fcompare-debug*} \
diff --git a/12.0.0/gentoo/24_all_EXTRA_OPTIONS-fstack-clash-protection.patch b/12.0.0/gentoo/24_all_EXTRA_OPTIONS-fstack-clash-protection.patch
index 5481721..e1b3c54 100644
--- a/12.0.0/gentoo/24_all_EXTRA_OPTIONS-fstack-clash-protection.patch
+++ b/12.0.0/gentoo/24_all_EXTRA_OPTIONS-fstack-clash-protection.patch
@@ -2,7 +2,7 @@ On Hardened we add some options like -fstack-clash-protection.
--- a/gcc/common.opt
+++ a/gcc/common.opt
-@@ -2367,7 +2367,7 @@ Common Alias(fstack-check=, specific, no
+@@ -2698,7 +2698,7 @@ Common Alias(fstack-check=, specific, no
Insert stack checking code into the program. Same as -fstack-check=specific.
fstack-clash-protection
@@ -13,7 +13,7 @@ On Hardened we add some options like -fstack-clash-protection.
--- a/gcc/defaults.h
+++ b/gcc/defaults.h
-@@ -1435,6 +1435,15 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -1425,6 +1425,15 @@ see the files COPYING3 and COPYING.RUNTI
#define STACK_CHECK_MAX_VAR_SIZE (STACK_CHECK_MAX_FRAME_SIZE / 100)
#endif
@@ -31,7 +31,7 @@ On Hardened we add some options like -fstack-clash-protection.
function descriptors instead. The value of this macro says how
--- a/gcc/toplev.cc
+++ b/gcc/toplev.cc
-@@ -1682,6 +1682,10 @@ process_options (void)
+@@ -1610,6 +1610,10 @@ process_options (void)
/* -fstack-clash-protection is not currently supported on targets
where the stack grows up. */
@@ -45,7 +45,7 @@ On Hardened we add some options like -fstack-clash-protection.
--- a/libgcc/Makefile.in
+++ b/libgcc/Makefile.in
-@@ -225,7 +225,7 @@ endif
+@@ -246,7 +246,7 @@ endif
LIBGCC2_DEBUG_CFLAGS = -g
LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(HOST_LIBGCC2_CFLAGS) \
$(LIBGCC2_DEBUG_CFLAGS) -DIN_LIBGCC2 \
@@ -54,7 +54,7 @@ On Hardened we add some options like -fstack-clash-protection.
$(INHIBIT_LIBC_CFLAGS)
# Additional options to use when compiling libgcc2.a.
-@@ -279,7 +290,7 @@ INTERNAL_CFLAGS = $(CFLAGS) $(LIBGCC2_CF
+@@ -302,7 +302,7 @@ INTERNAL_CFLAGS = $(CFLAGS) $(LIBGCC2_CF
$(NO_PIE_CFLAGS) -finhibit-size-directive -fno-inline -fno-exceptions \
-fno-zero-initialized-in-bss -fno-toplevel-reorder -fno-tree-vectorize \
-fbuilding-libgcc -fno-stack-protector $(FORCE_EXPLICIT_EH_REGISTRY) \
diff --git a/12.0.0/gentoo/26_all_plugin-objdump.patch b/12.0.0/gentoo/26_all_plugin-objdump.patch
index a9c33fd..059bca5 100644
--- a/12.0.0/gentoo/26_all_plugin-objdump.patch
+++ b/12.0.0/gentoo/26_all_plugin-objdump.patch
@@ -12,7 +12,7 @@ https://gcc.gnu.org/PR95648
else
--- a/gcc/configure
+++ b/gcc/configure
-@@ -30386,7 +30386,7 @@ fi
+@@ -32075,7 +32075,7 @@ fi
;;
*)
if test x$build = x$host; then
@@ -23,7 +23,7 @@ https://gcc.gnu.org/PR95648
else
--- a/libcc1/configure
+++ b/libcc1/configure
-@@ -14819,7 +14819,7 @@ fi
+@@ -15034,7 +15034,7 @@ fi
;;
*)
if test x$build = x$host; then
diff --git a/12.0.0/gentoo/README.history b/12.0.0/gentoo/README.history
index 99f4801..8d046ab 100644
--- a/12.0.0/gentoo/README.history
+++ b/12.0.0/gentoo/README.history
@@ -1,3 +1,22 @@
+4 26 Mar 2022
+
+ U 01_all_default-fortify-source.patch
+ U 03_all_default-warn-trampolines.patch
+ U 05_all_alpha-mieee-default.patch
+ U 06_all_ia64_note.GNU-stack.patch
+ U 08_all_libiberty-pic.patch
+ U 09_all_nopie-all-flags.patch
+ U 10_all_sh-drop-sysroot-suffix.patch
+ U 11_all_ia64-TEXTREL.patch
+ U 12_all_disable-systemtap-switch.patch
+ - 13_all_m68k-textrel-on-libgcc.patch
+ U 14_all_respect-build-cxxflags.patch
+ U 20_all_libstdcxx-no-vtv.patch
+ U 22_all_default_ssp-buffer-size.patch
+ U 23_all_EXTRA_OPTIONS-z-now.patch
+ U 24_all_EXTRA_OPTIONS-fstack-clash-protection.patch
+ U 26_all_plugin-objdump.patch
+
3 5 Feb 2022
U 01_all_default-fortify-source.patch