aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoragaffney <agaffney@kagome.(none)>2008-11-13 11:08:37 -0600
committeragaffney <agaffney@kagome.(none)>2008-11-13 11:08:37 -0600
commitec05525959fda6949bdcb6c600db41573ede378c (patch)
tree48f022d00aa656a00f5ec2e5187dd6caed27f54e /gen_compile.sh
parentCompile unionfs-fuse statically (diff)
downloadgenkernel-ec05525959fda6949bdcb6c600db41573ede378c.tar.gz
genkernel-ec05525959fda6949bdcb6c600db41573ede378c.tar.bz2
genkernel-ec05525959fda6949bdcb6c600db41573ede378c.zip
change lib order
Diffstat (limited to 'gen_compile.sh')
-rw-r--r--gen_compile.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/gen_compile.sh b/gen_compile.sh
index 2c3787f..2550b07 100644
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -563,8 +563,8 @@ compile_unionfs_fuse() {
gen_die "unionfs-fuse directory ${UNIONFS_FUSE_DIR} invalid"
cd "${UNIONFS_FUSE_DIR}"
print_info 1 'unionfs-fuse: >> Compiling...'
- sed -i "/^\(CFLAGS\|CPPFLAGS\)/s:^\\(.*\\)$:\\1 -I${TEMP}/${FUSE_DIR}/include -L${TEMP}/${FUSE_DIR}/lib/.libs:" Makefile src/Makefile
- sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -static -ldl -lrt -L${TEMP}/${FUSE_DIR}/lib/.libs \1:" Makefile src/Makefile
+ sed -i "/^\(CFLAGS\|CPPFLAGS\)/s:^\\(.*\\)$:\\1 -static -I${TEMP}/${FUSE_DIR}/include -L${TEMP}/${FUSE_DIR}/lib/.libs:" Makefile src/Makefile
+ sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -static -L${TEMP}/${FUSE_DIR}/lib/.libs \1 -ldl -lrt:" Makefile src/Makefile
MAKE=${UTILS_MAKE} compile_generic "" ""
print_info 1 'unionfs-fuse: >> Copying to cache...'
[ -f "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ] ||