aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/busybox/1.7.4/1.7.4-static-error.diff')
-rw-r--r--patches/busybox/1.7.4/1.7.4-static-error.diff13
1 files changed, 13 insertions, 0 deletions
diff --git a/patches/busybox/1.7.4/1.7.4-static-error.diff b/patches/busybox/1.7.4/1.7.4-static-error.diff
index e3c5405b..1e3b59c1 100644
--- a/patches/busybox/1.7.4/1.7.4-static-error.diff
+++ b/patches/busybox/1.7.4/1.7.4-static-error.diff
@@ -1,3 +1,4 @@
+diff -ur busybox-1.7.4.orig/applets/applets.c busybox-1.7.4/applets/applets.c
--- busybox-1.7.4.orig/applets/applets.c 2007-09-16 13:48:10.000000000 -0500
+++ busybox-1.7.4/applets/applets.c 2008-03-11 13:53:18.000000000 -0500
@@ -23,7 +23,6 @@
@@ -8,3 +9,15 @@
#endif
+diff -ur busybox-1.7.4.orig/Makefile busybox-1.7.4/Makefile
+--- busybox-1.7.4.orig/Makefile 2007-11-23 22:34:41.000000000 -0600
++++ busybox-1.7.4/Makefile 2008-03-12 06:35:25.000000000 -0500
+@@ -570,7 +570,7 @@
+ quiet_cmd_busybox__ ?= LINK $@
+ cmd_busybox__ ?= $(srctree)/scripts/trylink $(CC) $(LDFLAGS) \
+ -o $@ -Wl,-Map -Wl,$@.map \
+- -Wl,--warn-common -Wl,--sort-common -Wl,--gc-sections \
++ -Wl,--warn-common -Wl,--sort-common \
+ -Wl,--start-group $(busybox-all) -Wl,--end-group \
+ $(LDLIBS)
+