summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-04-15 04:26:01 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-06-17 13:35:50 -0400
commit06b6022f3322d40171b4ef5063b933b4ea0fe7ce (patch)
tree4a27aec6ab5d2965242b49654e9a5b5423652906
parentapp-editors/pluma: Version bump to 1.12.2, add 9999, add gtk3 (diff)
downloadgentoo-mate-06b6022f.tar.gz
gentoo-mate-06b6022f.tar.bz2
gentoo-mate-06b6022f.zip
dev-python/python-caja: Version bump to 1.12.0, add 9999, add gtk3
Package-Manager: portage-2.2.26
-rw-r--r--dev-python/python-caja/Manifest1
-rw-r--r--dev-python/python-caja/metadata.xml3
-rw-r--r--dev-python/python-caja/python-caja-1.12.0.ebuild46
-rw-r--r--dev-python/python-caja/python-caja-9999.ebuild46
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
index 44b465c..79c9228 100644
--- a/dev-python/python-caja/Manifest
+++ b/dev-python/python-caja/Manifest
@@ -1 +1,2 @@
DIST python-caja-1.10.0.tar.xz 265836 SHA256 95a1b7b83cbc4ba9f822c80e56740e0d7972c964edac43fd070f445702bd3596 SHA512 98c3a163a7798c66b050b87076e83cd24afa7ffb0cb139333a075cb0283bb07a51f26e427bda6e1f15e6292f87f7b85e43cab09874fae756e07cbc2944d5f5ae WHIRLPOOL 50f4e51db36bd43819738c46c0a77850ef4fe25566b55a4ab30a7c26eaea68b32a6e14f5bae67670fc8270f89917ddb68d47eeb81200244272b5508e22e40986
+DIST python-caja-1.12.0.tar.xz 265720 SHA256 5418ffcc5c4a33c15348a0f10ded161d26fd1dfb46b3f68b2c6e3d2d1a7ba975 SHA512 fbec1a7f5e560cda2b3bba41dcd93c0484f2b7b7527577a2b2114c84019203df92c136fecbbe6c889785c610035a582f1912ad7da9bb1258ada661b56edf4be7 WHIRLPOOL fdf60f678762480f0a9e5532dad08fddead1f3551b2c74d82889b597389cdf37351f9b82bdcf0420dd0505167cb890a75dda3ae5268ba502717cf020a8b922fd
diff --git a/dev-python/python-caja/metadata.xml b/dev-python/python-caja/metadata.xml
index 1369fb0..27312a5 100644
--- a/dev-python/python-caja/metadata.xml
+++ b/dev-python/python-caja/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/python-caja</remote-id>
</upstream>
diff --git a/dev-python/python-caja/python-caja-1.12.0.ebuild b/dev-python/python-caja/python-caja-1.12.0.ebuild
new file mode 100644
index 0000000..43fc804
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc gtk3"
+
+RDEPEND="dev-libs/glib:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.8[gtk3(-)=,introspection]
+ !gtk3? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/python-caja/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}
diff --git a/dev-python/python-caja/python-caja-9999.ebuild b/dev-python/python-caja/python-caja-9999.ebuild
new file mode 100644
index 0000000..43fc804
--- /dev/null
+++ b/dev-python/python-caja/python-caja-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc gtk3"
+
+RDEPEND="dev-libs/glib:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.8[gtk3(-)=,introspection]
+ !gtk3? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/python-caja/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}