summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwraeth <wraeth@wraeth.id.au>2016-01-30 19:40:12 +1100
committerNP-Hardass <NP-Hardass@gentoo.org>2016-01-31 19:04:23 -0500
commit91f3c86af5dc59a1f23e654c5a53f89e8c14b17e (patch)
tree8ba65370dafb0e7c95634843fe52f97554a45298
parentmate-base/mate-applets: Fix bug #567468 (diff)
downloadgentoo-mate-91f3c86a.tar.gz
gentoo-mate-91f3c86a.tar.bz2
gentoo-mate-91f3c86a.zip
mate-extra/mate-system-monitor: Add support for c++11
Package-Manager: portage-2.2.27 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
-rw-r--r--mate-extra/mate-system-monitor/files/mate-system-monitor-1.10.1-cxxflags-cpp11.patch207
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.10.1.ebuild13
2 files changed, 218 insertions, 2 deletions
diff --git a/mate-extra/mate-system-monitor/files/mate-system-monitor-1.10.1-cxxflags-cpp11.patch b/mate-extra/mate-system-monitor/files/mate-system-monitor-1.10.1-cxxflags-cpp11.patch
new file mode 100644
index 0000000..825a04a
--- /dev/null
+++ b/mate-extra/mate-system-monitor/files/mate-system-monitor-1.10.1-cxxflags-cpp11.patch
@@ -0,0 +1,207 @@
+From 56594f6f10ba04aa51af976bc8339ea9ae54ea21 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Dejean?= <bdejean@gmail.com>
+Date: Sun, 2 Aug 2015 06:37:21 +0200
+Subject: [PATCH] Add a smart CXXFLAGS / std=c++11 switch.
+
+Code from glom and murrayc http://www.murrayc.com/permalink/2015/07/31/gtkmm-now-uses-c11/ .
+---
+ configure.ac | 3 +-
+ m4/ax_cxx_compile_stdcxx_11.m4 | 168 +++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 170 insertions(+), 1 deletion(-)
+ create mode 100644 m4/ax_cxx_compile_stdcxx_11.m4
+
+diff --git a/configure.ac b/configure.ac
+index 4afb816..b7759db 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,6 +20,7 @@ AC_PROG_CC
+ AC_PROG_CXX
+ AC_LANG([C++])
+ AC_LANG_COMPILER_REQUIRE
++AX_CXX_COMPILE_STDCXX_11([],[mandatory])
+ PKG_PROG_PKG_CONFIG([0.19])
+
+ # Initialize libtool
+@@ -103,7 +104,7 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
+ -Wnested-externs -Wpointer-arith \
+ -Wcast-align -Wsign-compare \
+ $CFLAGS"
+- CXXFLAGS="-Wall -std=c++98 $CXXFLAGS"
++ CXXFLAGS="-Wall $CXXFLAGS"
+ else
+ AC_MSG_RESULT(no)
+ fi
+diff --git a/m4/ax_cxx_compile_stdcxx_11.m4 b/m4/ax_cxx_compile_stdcxx_11.m4
+new file mode 100644
+index 0000000..b83fac4
+--- /dev/null
++++ b/m4/ax_cxx_compile_stdcxx_11.m4
+@@ -0,0 +1,168 @@
++# ============================================================================
++# http://www.gnu.org/software/autoconf-archive/ax_cxx_compile_stdcxx_11.html
++# ============================================================================
++#
++# SYNOPSIS
++#
++# AX_CXX_COMPILE_STDCXX_11([ext|noext],[mandatory|optional])
++#
++# DESCRIPTION
++#
++# Check for baseline language coverage in the compiler for the C++11
++# standard; if necessary, add switches to CXXFLAGS to enable support.
++#
++# The first argument, if specified, indicates whether you insist on an
++# extended mode (e.g. -std=gnu++11) or a strict conformance mode (e.g.
++# -std=c++11). If neither is specified, you get whatever works, with
++# preference for an extended mode.
++#
++# The second argument, if specified 'mandatory' or if left unspecified,
++# indicates that baseline C++11 support is required and that the macro
++# should error out if no mode with that support is found. If specified
++# 'optional', then configuration proceeds regardless, after defining
++# HAVE_CXX11 if and only if a supporting mode is found.
++#
++# LICENSE
++#
++# Copyright (c) 2008 Benjamin Kosnik <bkoz@redhat.com>
++# Copyright (c) 2012 Zack Weinberg <zackw@panix.com>
++# Copyright (c) 2013 Roy Stogner <roystgnr@ices.utexas.edu>
++# Copyright (c) 2014, 2015 Google Inc.; contributed by Alexey Sokolov <sokolov@google.com>
++#
++# Copying and distribution of this file, with or without modification, are
++# permitted in any medium without royalty provided the copyright notice
++# and this notice are preserved. This file is offered as-is, without any
++# warranty.
++
++#serial 11
++
++m4_define([_AX_CXX_COMPILE_STDCXX_11_testbody], [[
++ template <typename T>
++ struct check
++ {
++ static_assert(sizeof(int) <= sizeof(T), "not big enough");
++ };
++
++ struct Base {
++ virtual void f() {}
++ };
++ struct Child : public Base {
++ virtual void f() override {}
++ };
++
++ typedef check<check<bool>> right_angle_brackets;
++
++ int a;
++ decltype(a) b;
++
++ typedef check<int> check_type;
++ check_type c;
++ check_type&& cr = static_cast<check_type&&>(c);
++
++ auto d = a;
++ auto l = [](){};
++ // Prevent Clang error: unused variable 'l' [-Werror,-Wunused-variable]
++ struct use_l { use_l() { l(); } };
++
++ // http://stackoverflow.com/questions/13728184/template-aliases-and-sfinae
++ // Clang 3.1 fails with headers of libstd++ 4.8.3 when using std::function because of this
++ namespace test_template_alias_sfinae {
++ struct foo {};
++
++ template<typename T>
++ using member = typename T::member_type;
++
++ template<typename T>
++ void func(...) {}
++
++ template<typename T>
++ void func(member<T>*) {}
++
++ void test();
++
++ void test() {
++ func<foo>(0);
++ }
++ }
++]])
++
++AC_DEFUN([AX_CXX_COMPILE_STDCXX_11], [dnl
++ m4_if([$1], [], [],
++ [$1], [ext], [],
++ [$1], [noext], [],
++ [m4_fatal([invalid argument `$1' to AX_CXX_COMPILE_STDCXX_11])])dnl
++ m4_if([$2], [], [ax_cxx_compile_cxx11_required=true],
++ [$2], [mandatory], [ax_cxx_compile_cxx11_required=true],
++ [$2], [optional], [ax_cxx_compile_cxx11_required=false],
++ [m4_fatal([invalid second argument `$2' to AX_CXX_COMPILE_STDCXX_11])])
++ AC_LANG_PUSH([C++])dnl
++ ac_success=no
++ AC_CACHE_CHECK(whether $CXX supports C++11 features by default,
++ ax_cv_cxx_compile_cxx11,
++ [AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
++ [ax_cv_cxx_compile_cxx11=yes],
++ [ax_cv_cxx_compile_cxx11=no])])
++ if test x$ax_cv_cxx_compile_cxx11 = xyes; then
++ ac_success=yes
++ fi
++
++ m4_if([$1], [noext], [], [dnl
++ if test x$ac_success = xno; then
++ for switch in -std=gnu++11 -std=gnu++0x; do
++ cachevar=AS_TR_SH([ax_cv_cxx_compile_cxx11_$switch])
++ AC_CACHE_CHECK(whether $CXX supports C++11 features with $switch,
++ $cachevar,
++ [ac_save_CXXFLAGS="$CXXFLAGS"
++ CXXFLAGS="$CXXFLAGS $switch"
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
++ [eval $cachevar=yes],
++ [eval $cachevar=no])
++ CXXFLAGS="$ac_save_CXXFLAGS"])
++ if eval test x\$$cachevar = xyes; then
++ CXXFLAGS="$CXXFLAGS $switch"
++ ac_success=yes
++ break
++ fi
++ done
++ fi])
++
++ m4_if([$1], [ext], [], [dnl
++ if test x$ac_success = xno; then
++ dnl HP's aCC needs +std=c++11 according to:
++ dnl http://h21007.www2.hp.com/portal/download/files/unprot/aCxx/PDF_Release_Notes/769149-001.pdf
++ for switch in -std=c++11 -std=c++0x +std=c++11; do
++ cachevar=AS_TR_SH([ax_cv_cxx_compile_cxx11_$switch])
++ AC_CACHE_CHECK(whether $CXX supports C++11 features with $switch,
++ $cachevar,
++ [ac_save_CXXFLAGS="$CXXFLAGS"
++ CXXFLAGS="$CXXFLAGS $switch"
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
++ [eval $cachevar=yes],
++ [eval $cachevar=no])
++ CXXFLAGS="$ac_save_CXXFLAGS"])
++ if eval test x\$$cachevar = xyes; then
++ CXXFLAGS="$CXXFLAGS $switch"
++ ac_success=yes
++ break
++ fi
++ done
++ fi])
++ AC_LANG_POP([C++])
++ if test x$ax_cxx_compile_cxx11_required = xtrue; then
++ if test x$ac_success = xno; then
++ AC_MSG_ERROR([*** A compiler with support for C++11 language features is required.])
++ fi
++ else
++ if test x$ac_success = xno; then
++ HAVE_CXX11=0
++ AC_MSG_NOTICE([No compiler with C++11 support was found])
++ else
++ HAVE_CXX11=1
++ AC_DEFINE(HAVE_CXX11,1,
++ [define if the compiler supports basic C++11 syntax])
++ fi
++
++ AC_SUBST(HAVE_CXX11)
++ fi
++])
++
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.10.1.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.10.1.ebuild
index 3a6b1b8..5af3ce1 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.10.1.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
-inherit gnome2 versionator
+inherit autotools gnome2 versionator
MATE_BRANCH="$(get_version_component_range 1-2)"
@@ -41,8 +41,17 @@ RDEPEND="
DEPEND="${RDEPEND}
app-text/yelp-tools:0
>=dev-util/intltool-0.35:*
+ mate-base/mate-common
sys-devel/gettext:*
>=sys-devel/autoconf-2.63:*
virtual/pkgconfig:*"
DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ # Add support for "smart" CXXFLAGS and C++11 switch
+ # see https://github.com/mate-desktop/mate-system-monitor/commit/56594f
+ epatch "${FILESDIR}/${P}-cxxflags-cpp11.patch"
+ eautoreconf
+ default
+}