summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 15:34:31 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-16 15:34:31 +0100
commit9e8c98c04615217cbe5a70722c5ee7d16348dd4e (patch)
treec10cc240f4cc1e525842ff170880527f6a5338cd
parentmate-extra/mate-utils: sync live ebuild with upstream (diff)
downloadgentoo-mate-9e8c98c0.tar.gz
gentoo-mate-9e8c98c0.tar.bz2
gentoo-mate-9e8c98c0.zip
app-editors/pluma: sync live ebuild with upstream
* Add introspection useflag * Readd python dep. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-editors/pluma/pluma-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/app-editors/pluma/pluma-9999.ebuild b/app-editors/pluma/pluma-9999.ebuild
index 17826bb..65d4d2f 100644
--- a/app-editors/pluma/pluma-9999.ebuild
+++ b/app-editors/pluma/pluma-9999.ebuild
@@ -5,7 +5,9 @@ EAPI=6
MATE_LA_PUNT="yes"
-inherit mate multilib virtualx
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate multilib python-single-r1 virtualx
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
@@ -15,7 +17,9 @@ DESCRIPTION="Pluma text editor for the MATE desktop"
LICENSE="GPL-2"
SLOT="0"
-IUSE="spell"
+IUSE="+introspection spell"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
# https://github.com/mate-desktop/mate-text-editor/issues/33
@@ -23,24 +27,27 @@ RESTRICT="test"
COMMON_DEPEND="dev-libs/atk:0
>=dev-libs/glib-2.36:2
+ >=dev-libs/libpeas-1.2.0[gtk]
>=dev-libs/libxml2-2.5:2
x11-libs/cairo:0
x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14.0:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0
x11-libs/libICE:0
x11-libs/libX11:0
>=x11-libs/libSM-1.0
x11-libs/pango:0
virtual/libintl:0
- >=x11-libs/gtk+-3.14.0:3
- >=x11-libs/gtksourceview-3.0.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
spell? (
>=app-text/enchant-1.2:0
>=app-text/iso-codes-0.35:0
)
!!app-editors/mate-text-editor"
-RDEPEND="${COMMON_DEPEND}
- >=mate-base/mate-desktop-1.9"
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.9[introspection?]"
DEPEND="${COMMON_DEPEND}
~app-text/docbook-xml-dtd-4.1.2
@@ -56,6 +63,7 @@ DEPEND="${COMMON_DEPEND}
src_configure() {
mate_src_configure \
+ $(use_enable introspection) \
$(use_enable spell)
}