summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-09-22 17:17:37 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-09-22 17:17:37 -0400
commitec7e48d451844a3663272c0a2ba7dd83ec453593 (patch)
treecf55421546d393cd67fd43f4cd10ccf31eb4ed16
parentmate-base/mate-applets: Fix building with >cpupower-4.9 (diff)
downloadgentoo-mate-ec7e48d451844a3663272c0a2ba7dd83ec453593.tar.gz
gentoo-mate-ec7e48d451844a3663272c0a2ba7dd83ec453593.tar.bz2
gentoo-mate-ec7e48d451844a3663272c0a2ba7dd83ec453593.zip
mate-base/mate-applets: Fix cpupower patch for 1.16+
Upstream removed a space, rendering old patch broken Bug: https://bugs.gentoo.org/593470 Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch44
-rw-r--r--mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild2
-rw-r--r--mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild2
-rw-r--r--mate-base/mate-applets/mate-applets-9999.ebuild2
4 files changed, 47 insertions, 3 deletions
diff --git a/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
new file mode 100644
index 0000000..3f4f4fa
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index b49d127..6b87389 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -411,6 +411,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 4fa9d4c..ba52fde 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,12 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+
+@@ -111,7 +115,7 @@
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
+ #else
+ if (cpupower_is_cpu_online (cpu)) {
diff --git a/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild b/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild
index 3540d0a..d9c8b7e 100644
--- a/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.16.0-r1.ebuild
@@ -69,7 +69,7 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
-PATCHES=( "${FILESDIR}/${PN}-1.14.1-cpupower-4.7.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.16.0-cpupower-4.7.patch" )
src_configure() {
mate_src_configure \
diff --git a/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild b/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild
index b62a57f..4db7d9b 100644
--- a/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.18.1-r1.ebuild
@@ -61,7 +61,7 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
-PATCHES=( "${FILESDIR}/${PN}-1.14.1-cpupower-4.7.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.16.0-cpupower-4.7.patch" )
src_configure() {
mate_src_configure \
diff --git a/mate-base/mate-applets/mate-applets-9999.ebuild b/mate-base/mate-applets/mate-applets-9999.ebuild
index b62a57f..4db7d9b 100644
--- a/mate-base/mate-applets/mate-applets-9999.ebuild
+++ b/mate-base/mate-applets/mate-applets-9999.ebuild
@@ -61,7 +61,7 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
-PATCHES=( "${FILESDIR}/${PN}-1.14.1-cpupower-4.7.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.16.0-cpupower-4.7.patch" )
src_configure() {
mate_src_configure \