aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfuzzyray <fuzzyray@gentoo.org>2007-03-24 15:40:00 +0000
committerfuzzyray <fuzzyray@gentoo.org>2007-03-24 15:40:00 +0000
commit1e10b3e962ce49ebe31967f1b7747786afa899e7 (patch)
tree0acbd5f4afe27e7273b69e42b0dd3b127375e9e8
parentRe-apply subversion patch (diff)
downloadgentoolkit-1e10b3e962ce49ebe31967f1b7747786afa899e7.tar.gz
gentoolkit-1e10b3e962ce49ebe31967f1b7747786afa899e7.tar.bz2
gentoolkit-1e10b3e962ce49ebe31967f1b7747786afa899e7.zip
Fix broken processing of new ebuilds. (Bug #172017)
svn path=/; revision=363
-rw-r--r--trunk/src/echangelog/echangelog6
1 files changed, 3 insertions, 3 deletions
diff --git a/trunk/src/echangelog/echangelog b/trunk/src/echangelog/echangelog
index db0c8ec..06c526d 100644
--- a/trunk/src/echangelog/echangelog
+++ b/trunk/src/echangelog/echangelog
@@ -22,7 +22,7 @@ $Text::Wrap::unexpand = 0;
my (@files, @ebuilds, @conflicts, @trivial, @unknown, @new_versions, %actions);
my ($input, $editor, $entry, $user, $date, $text, $version, $year, $vcs);
-my %vcs = ( cvs => { diff => "cvs -f -U0 diff",
+my %vcs = ( cvs => { diff => "cvs -f diff -U0",
status => "cvs -fn up",
add => "cvs -f add",
skip => 6,
@@ -249,7 +249,7 @@ if (@ebuilds) {
if ($vcs eq "git") {
open C, $vcs{$vcs}{diff}." 2>&1 |" or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
} else {
- open C, $vcs{$vcs}{diff}."@ebuilds 2>&1 |" or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
+ open C, $vcs{$vcs}{diff}." @ebuilds 2>&1 |" or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
}
$_ = <C>;
while (defined $_) {
@@ -282,7 +282,7 @@ if (@ebuilds) {
# and we have the next line in $_ for processing
next;
}
- elsif (/^$vcs*?: (([^\/]*?)\.ebuild) is a new entry/) {
+ elsif (/^$vcs.*?: (([^\/]*?)\.ebuild) is a new entry/) {
push @files, $1;
push @new_versions, $2; # new ebuild, will create a new entry
}