aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-03 06:10:41 +0100
committerSam James <sam@gentoo.org>2024-05-03 06:10:41 +0100
commit7405fdccd73364662089f1001231bf8c24916ca3 (patch)
tree3f97103827cdc8843a6cf3c750e878218b17c354
parentmeson.build: prepare for gentoolkit-0.6.6 (diff)
downloadgentoolkit-7405fdccd73364662089f1001231bf8c24916ca3.tar.gz
gentoolkit-7405fdccd73364662089f1001231bf8c24916ca3.tar.bz2
gentoolkit-7405fdccd73364662089f1001231bf8c24916ca3.zip
eclean: dist: fix operating on an empty directory
Zac pointed out that not all return paths had been updated. Bug: https://bugs.gentoo.org/928138 Fixes: 87912b460c533f8b010617018fdad42246db85f0 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--pym/gentoolkit/eclean/search.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/pym/gentoolkit/eclean/search.py b/pym/gentoolkit/eclean/search.py
index b696b63..7f050ee 100644
--- a/pym/gentoolkit/eclean/search.py
+++ b/pym/gentoolkit/eclean/search.py
@@ -115,10 +115,11 @@ class DistfilesSearch:
pkgs = {}
saved = {}
deprecated = {}
+ vcs = {}
installed_included = False
# Check if DISTDIR is empty, return early
if not os.listdir(_distdir):
- return clean_me, saved, deprecated
+ return clean_me, saved, deprecated, vcs
# create a big CPV->SRC_URI dict of packages
# whose distfiles should be kept