aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kubaryk <greg.kubaryk@gmail.com>2024-03-12 21:41:48 +0000
committerSam James <sam@gentoo.org>2024-03-12 21:43:41 +0000
commitd00c9f8b80d8f6193810e7cb4b9175c498fc9c82 (patch)
tree95c44c4d973413ce27c2791cf0b30fb8c9c7797a
parentRevert "meson: make tests optional" (diff)
downloadgentoolkit-d00c9f8b80d8f6193810e7cb4b9175c498fc9c82.tar.gz
gentoolkit-d00c9f8b80d8f6193810e7cb4b9175c498fc9c82.tar.bz2
gentoolkit-d00c9f8b80d8f6193810e7cb4b9175c498fc9c82.zip
meson: make tests optional
Closes: https://bugs.gentoo.org/926427 Signed-off-by: Greg Kubaryk <greg.kubaryk@gmail.com> Signed-off-by: Sam James <sam@gentoo.org> (cherry picked from commit 988e47557368df49035eeba94beca893f7b267c1)
-rw-r--r--meson.build6
-rw-r--r--meson_options.txt4
2 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c3e83c5..b7b07c1 100644
--- a/meson.build
+++ b/meson.build
@@ -39,8 +39,10 @@ endif
subdir('bin')
subdir('pym')
-pytest = find_program('pytest')
-test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
+if get_option('tests')
+ pytest = find_program('pytest')
+ test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
+endif
if get_option('code-only')
subdir_done()
diff --git a/meson_options.txt b/meson_options.txt
index 265d572..9949cbf 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -13,3 +13,7 @@ option('eprefix', type : 'string',
option('docdir', type : 'string',
description : 'Documentation directory'
)
+
+option('tests', type : 'boolean', value: false,
+ description : 'Enable tests'
+)