aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-20 17:12:31 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-20 17:12:31 -0500
commitd21a2fa94f571100e30f5b755e5050246bcfbbdd (patch)
tree182c335eea3ec0daa71566d1cb765d82d34ff27c
parentmetadata.py: Fix duplicated use flag text bug 748129 (diff)
downloadgentoolkit-d21a2fa94f571100e30f5b755e5050246bcfbbdd.tar.gz
gentoolkit-d21a2fa94f571100e30f5b755e5050246bcfbbdd.tar.bz2
gentoolkit-d21a2fa94f571100e30f5b755e5050246bcfbbdd.zip
Remove imports from __future__
gentoolkit supports only Python 3.6+ now, so these are not used. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rwxr-xr-xbin/eclean3
-rwxr-xr-xbin/eclean-dist3
-rwxr-xr-xbin/eclean-pkg3
-rwxr-xr-xbin/ekeyword2
-rwxr-xr-xbin/enalyze2
-rwxr-xr-xbin/epkginfo2
-rwxr-xr-xbin/equery2
-rwxr-xr-xbin/euse8
-rwxr-xr-xbin/imlate2
-rwxr-xr-xbin/revdep-rebuild2
-rw-r--r--pym/gentoolkit/base.py2
-rw-r--r--pym/gentoolkit/dbapi.py2
-rw-r--r--pym/gentoolkit/eclean/clean.py3
-rw-r--r--pym/gentoolkit/eclean/cli.py3
-rw-r--r--pym/gentoolkit/eclean/exclude.py3
-rw-r--r--pym/gentoolkit/eclean/output.py3
-rw-r--r--pym/gentoolkit/eclean/pkgindex.py3
-rw-r--r--pym/gentoolkit/eclean/search.py3
-rwxr-xr-xpym/gentoolkit/ekeyword/ekeyword.py2
-rwxr-xr-xpym/gentoolkit/ekeyword/ekeyword_unittest.py2
-rw-r--r--pym/gentoolkit/enalyze/analyze.py2
-rw-r--r--pym/gentoolkit/enalyze/output.py2
-rw-r--r--pym/gentoolkit/enalyze/rebuild.py3
-rw-r--r--pym/gentoolkit/eprefix.py2
-rw-r--r--pym/gentoolkit/equery/__init__.py2
-rw-r--r--pym/gentoolkit/equery/belongs.py2
-rw-r--r--pym/gentoolkit/equery/changes.py2
-rw-r--r--pym/gentoolkit/equery/check.py2
-rw-r--r--pym/gentoolkit/equery/depends.py2
-rw-r--r--pym/gentoolkit/equery/depgraph.py2
-rw-r--r--pym/gentoolkit/equery/files.py2
-rw-r--r--pym/gentoolkit/equery/has.py2
-rw-r--r--pym/gentoolkit/equery/hasuse.py2
-rw-r--r--pym/gentoolkit/equery/list_.py2
-rw-r--r--pym/gentoolkit/equery/meta.py2
-rw-r--r--pym/gentoolkit/equery/size.py2
-rw-r--r--pym/gentoolkit/equery/uses.py2
-rw-r--r--pym/gentoolkit/equery/which.py2
-rw-r--r--pym/gentoolkit/eshowkw/keywords_header.py2
-rwxr-xr-xpym/gentoolkit/imlate/imlate.py3
-rw-r--r--pym/gentoolkit/module_base.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/analyse.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/assign.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/cache.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/collect.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/rebuild.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/settings.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/stuff.py2
-rw-r--r--pym/gentoolkit/test/eclean/creator.py3
-rw-r--r--pym/gentoolkit/test/eclean/distsupport.py2
-rwxr-xr-xpym/gentoolkit/test/eclean/test_clean.py2
-rwxr-xr-xpym/gentoolkit/test/eclean/test_search.py3
-rwxr-xr-xsetup.py3
53 files changed, 4 insertions, 122 deletions
diff --git a/bin/eclean b/bin/eclean
index 715787b..90f9e55 100755
--- a/bin/eclean
+++ b/bin/eclean
@@ -4,9 +4,6 @@
Distributed under the terms of the GNU General Public License v2
"""
-from __future__ import print_function
-
-
# Meta:
__author__ = "Thomas de Grenier de Latour (tgl), " + \
"modular re-write by: Brian Dolbec (dol-sen)"
diff --git a/bin/eclean-dist b/bin/eclean-dist
index 715787b..90f9e55 100755
--- a/bin/eclean-dist
+++ b/bin/eclean-dist
@@ -4,9 +4,6 @@
Distributed under the terms of the GNU General Public License v2
"""
-from __future__ import print_function
-
-
# Meta:
__author__ = "Thomas de Grenier de Latour (tgl), " + \
"modular re-write by: Brian Dolbec (dol-sen)"
diff --git a/bin/eclean-pkg b/bin/eclean-pkg
index 715787b..90f9e55 100755
--- a/bin/eclean-pkg
+++ b/bin/eclean-pkg
@@ -4,9 +4,6 @@
Distributed under the terms of the GNU General Public License v2
"""
-from __future__ import print_function
-
-
# Meta:
__author__ = "Thomas de Grenier de Latour (tgl), " + \
"modular re-write by: Brian Dolbec (dol-sen)"
diff --git a/bin/ekeyword b/bin/ekeyword
index 72b3f95..2e3c78e 100755
--- a/bin/ekeyword
+++ b/bin/ekeyword
@@ -13,8 +13,6 @@ the current list as they appear, and ebuilds are processed as they appear.
"""
-from __future__ import print_function
-
import os
import sys
# This block ensures that ^C interrupts are handled quietly.
diff --git a/bin/enalyze b/bin/enalyze
index 5991f60..a0bb29a 100755
--- a/bin/enalyze
+++ b/bin/enalyze
@@ -12,8 +12,6 @@ packages that use them. It can also be used to help rebuild /etc/portage/packag
files in the event of corruption, and possibly more.
"""
-from __future__ import print_function
-
import sys
# This block ensures that ^C interrupts are handled quietly.
try:
diff --git a/bin/epkginfo b/bin/epkginfo
index 75a2f3f..4f87176 100755
--- a/bin/epkginfo
+++ b/bin/epkginfo
@@ -7,8 +7,6 @@
"""Shortcut to equery meta"""
-from __future__ import print_function
-
__authors__ = (
'Douglas Anderson <douglasjanderson@gmail.com>: equery meta',
'Ned Ludd <solar@gentoo.org>: first full implimentation'
diff --git a/bin/equery b/bin/equery
index 292321e..77371d1 100755
--- a/bin/equery
+++ b/bin/equery
@@ -10,8 +10,6 @@ information about packages, such as the files they own, their USE flags,
the MD5 sum of each file owned by a given package, and many other things.
"""
-from __future__ import print_function
-
import os
import sys
# This block ensures that ^C interrupts are handled quietly.
diff --git a/bin/euse b/bin/euse
index 15a2a6e..263d0f2 100755
--- a/bin/euse
+++ b/bin/euse
@@ -184,7 +184,7 @@ VER
# worth another look to avoid calling python unnecessariy. Or we could
# just write the whole thing in python. ;)
reduce_incrementals() {
- echo $@ | python -c "from __future__ import print_function;import sys
+ echo $@ | python -c "import sys
r=[]
for x in sys.stdin.read().split():
if x[0] == '-' and x[1:] in r:
@@ -202,7 +202,7 @@ print(' '.join(r))"
# Similar to reduce_incrementals but negative flags trump positive
# flags, regardless of which follows which
reduce_incrementals_trump() {
- echo $@ | python -c "from __future__ import print_function;import sys
+ echo $@ | python -c "import sys
r=[]
for x in sys.stdin.read().split():
if x[0] == '-' and x[1:] in r:
@@ -221,7 +221,7 @@ print(' '.join(r))"
# * - Lines of package atom followed by flags
# (app-editors/vim flag1 flag2 -flag3)
reduce_package_use() {
- echo "${@}" | python -c "from __future__ import print_function;import sys,re
+ echo "${@}" | python -c "import sys,re
h={}; getflags=re.compile(r'(-?[\w*-]+)')
for x in sys.stdin.read().split('\n'):
if not x: continue
@@ -541,7 +541,7 @@ get_flagstatus_helper_pkg() {
if [[ -z "${atoms[@]/[<>=]*/}" ]]; then
atoms=($(
echo "${atoms[@]}" | python -c "
-from __future__ import print_function;import portage.dep as dep, sys
+import portage.dep as dep, sys
print(' '.join(dep.match_to_list('$5-$6',sys.stdin.read().split())))"))
fi
flags=$(for atom in ${atoms[@]}; do
diff --git a/bin/imlate b/bin/imlate
index d186f0d..040d19e 100755
--- a/bin/imlate
+++ b/bin/imlate
@@ -13,8 +13,6 @@ the current list as they appear, and ebuilds are processed as they appear.
"""
-from __future__ import print_function
-
import os
import sys
# This block ensures that ^C interrupts are handled quietly.
diff --git a/bin/revdep-rebuild b/bin/revdep-rebuild
index b77ebe9..24d349e 100755
--- a/bin/revdep-rebuild
+++ b/bin/revdep-rebuild
@@ -11,8 +11,6 @@ those broken binaries and shared libraries. It is useful when an upgraded packag
dependent upon the upgraded package.
"""
-from __future__ import print_function
-
import sys
# This block ensures that ^C interrupts are handled quietly.
try:
diff --git a/pym/gentoolkit/base.py b/pym/gentoolkit/base.py
index bc08561..aabccea 100644
--- a/pym/gentoolkit/base.py
+++ b/pym/gentoolkit/base.py
@@ -8,8 +8,6 @@
"""Gentoolkit Base Module class to hold common module operation functions
"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
diff --git a/pym/gentoolkit/dbapi.py b/pym/gentoolkit/dbapi.py
index 113545d..4768078 100644
--- a/pym/gentoolkit/dbapi.py
+++ b/pym/gentoolkit/dbapi.py
@@ -11,8 +11,6 @@
take advantage of them being lazy-loaded.
"""
-from __future__ import print_function
-
print("gentoolkit.dbapi is deprecated.\n",
"Please migrate to using the assigned calls directly")
diff --git a/pym/gentoolkit/eclean/clean.py b/pym/gentoolkit/eclean/clean.py
index c62abb9..2b750e3 100644
--- a/pym/gentoolkit/eclean/clean.py
+++ b/pym/gentoolkit/eclean/clean.py
@@ -4,9 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
import os
import sys
diff --git a/pym/gentoolkit/eclean/cli.py b/pym/gentoolkit/eclean/cli.py
index 39aafd3..e31fde9 100644
--- a/pym/gentoolkit/eclean/cli.py
+++ b/pym/gentoolkit/eclean/cli.py
@@ -4,9 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
__author__ = "Thomas de Grenier de Latour (tgl), " + \
"modular re-write by: Brian Dolbec (dol-sen)"
__email__ = "degrenier@easyconnect.fr, " + \
diff --git a/pym/gentoolkit/eclean/exclude.py b/pym/gentoolkit/eclean/exclude.py
index c734493..ee5e1e1 100644
--- a/pym/gentoolkit/eclean/exclude.py
+++ b/pym/gentoolkit/eclean/exclude.py
@@ -4,9 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
import os
import sys
if sys.hexversion < 0x3000000:
diff --git a/pym/gentoolkit/eclean/output.py b/pym/gentoolkit/eclean/output.py
index 93662d6..122d550 100644
--- a/pym/gentoolkit/eclean/output.py
+++ b/pym/gentoolkit/eclean/output.py
@@ -4,9 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
import sys
from portage.output import blue, yellow, teal, green, red
from gentoolkit.pprinter import cpv, number
diff --git a/pym/gentoolkit/eclean/pkgindex.py b/pym/gentoolkit/eclean/pkgindex.py
index c1f5f9d..6cf9000 100644
--- a/pym/gentoolkit/eclean/pkgindex.py
+++ b/pym/gentoolkit/eclean/pkgindex.py
@@ -3,9 +3,6 @@
# Copyright 2003-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
import subprocess
import os
import sys
diff --git a/pym/gentoolkit/eclean/search.py b/pym/gentoolkit/eclean/search.py
index f68aacf..992949c 100644
--- a/pym/gentoolkit/eclean/search.py
+++ b/pym/gentoolkit/eclean/search.py
@@ -4,9 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
-
import os
import stat
import sys
diff --git a/pym/gentoolkit/ekeyword/ekeyword.py b/pym/gentoolkit/ekeyword/ekeyword.py
index a86a9c2..4e57c09 100755
--- a/pym/gentoolkit/ekeyword/ekeyword.py
+++ b/pym/gentoolkit/ekeyword/ekeyword.py
@@ -36,8 +36,6 @@ Examples:
$ %(prog)s s390=amd64 foo-1.ebuild
"""
-from __future__ import print_function
-
import argparse
import collections
import difflib
diff --git a/pym/gentoolkit/ekeyword/ekeyword_unittest.py b/pym/gentoolkit/ekeyword/ekeyword_unittest.py
index 7446914..ef2e256 100755
--- a/pym/gentoolkit/ekeyword/ekeyword_unittest.py
+++ b/pym/gentoolkit/ekeyword/ekeyword_unittest.py
@@ -5,8 +5,6 @@
"""Unittests for ekeyword"""
-from __future__ import print_function
-
import os
import subprocess
import tempfile
diff --git a/pym/gentoolkit/enalyze/analyze.py b/pym/gentoolkit/enalyze/analyze.py
index 1d3d9c0..30ffa93 100644
--- a/pym/gentoolkit/enalyze/analyze.py
+++ b/pym/gentoolkit/enalyze/analyze.py
@@ -8,8 +8,6 @@
"""Provides a breakdown list of USE flags or keywords used and by
what packages according to the Installed package database"""
-from __future__ import print_function
-
import gentoolkit
from gentoolkit.module_base import ModuleBase
from gentoolkit import pprinter as pp
diff --git a/pym/gentoolkit/enalyze/output.py b/pym/gentoolkit/enalyze/output.py
index 3d63394..993565a 100644
--- a/pym/gentoolkit/enalyze/output.py
+++ b/pym/gentoolkit/enalyze/output.py
@@ -8,8 +8,6 @@
both screen and file output
"""
-from __future__ import print_function
-
import time
from gentoolkit import pprinter as pp
diff --git a/pym/gentoolkit/enalyze/rebuild.py b/pym/gentoolkit/enalyze/rebuild.py
index d6ccef9..4ad571f 100644
--- a/pym/gentoolkit/enalyze/rebuild.py
+++ b/pym/gentoolkit/enalyze/rebuild.py
@@ -10,9 +10,6 @@
what packages according to the Installed package database"""
-from __future__ import print_function
-
-
import os
import sys
if sys.hexversion < 0x3000000:
diff --git a/pym/gentoolkit/eprefix.py b/pym/gentoolkit/eprefix.py
index 48bd140..5acaa79 100644
--- a/pym/gentoolkit/eprefix.py
+++ b/pym/gentoolkit/eprefix.py
@@ -4,8 +4,6 @@
# Distributed under the terms of the GNU General Public License v2
-#from __future__ import print_function
-
"""Eprefix support module to set the EPREFIX variable
used in all gentoolkit modules
diff --git a/pym/gentoolkit/equery/__init__.py b/pym/gentoolkit/equery/__init__.py
index f33cca5..6167710 100644
--- a/pym/gentoolkit/equery/__init__.py
+++ b/pym/gentoolkit/equery/__init__.py
@@ -6,8 +6,6 @@
"""Gentoo package query tool"""
-from __future__ import print_function
-
__all__ = (
'format_options',
'format_package_names',
diff --git a/pym/gentoolkit/equery/belongs.py b/pym/gentoolkit/equery/belongs.py
index 8c16b89..cf53916 100644
--- a/pym/gentoolkit/equery/belongs.py
+++ b/pym/gentoolkit/equery/belongs.py
@@ -10,8 +10,6 @@ Note: Normally, only one package will own a file. If multiple packages own
the same file, it usually constitutes a problem, and should be reported.
"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/changes.py b/pym/gentoolkit/equery/changes.py
index 92e81b5..f86edf6 100644
--- a/pym/gentoolkit/equery/changes.py
+++ b/pym/gentoolkit/equery/changes.py
@@ -6,8 +6,6 @@
"""Displays the ChangeLog entry for the latest installable version of an atom"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/check.py b/pym/gentoolkit/equery/check.py
index d5a22a3..c00789b 100644
--- a/pym/gentoolkit/equery/check.py
+++ b/pym/gentoolkit/equery/check.py
@@ -6,8 +6,6 @@
"""Checks timestamps and MD5 sums for files owned by a given installed package"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/depends.py b/pym/gentoolkit/equery/depends.py
index 8ffc745..e654e84 100644
--- a/pym/gentoolkit/equery/depends.py
+++ b/pym/gentoolkit/equery/depends.py
@@ -6,8 +6,6 @@
"""List all packages that depend on a atom given query"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/depgraph.py b/pym/gentoolkit/equery/depgraph.py
index 9fbdd42..9ad21c2 100644
--- a/pym/gentoolkit/equery/depgraph.py
+++ b/pym/gentoolkit/equery/depgraph.py
@@ -6,8 +6,6 @@
"""Display a direct dependency graph for a given package"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/files.py b/pym/gentoolkit/equery/files.py
index 10c7fde..05c2235 100644
--- a/pym/gentoolkit/equery/files.py
+++ b/pym/gentoolkit/equery/files.py
@@ -6,8 +6,6 @@
"""List files owned by a given package."""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/has.py b/pym/gentoolkit/equery/has.py
index 37e4d3f..dddaab3 100644
--- a/pym/gentoolkit/equery/has.py
+++ b/pym/gentoolkit/equery/has.py
@@ -6,8 +6,6 @@
"""List all installed packages that match for a given ENVIRONMENT variable"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/hasuse.py b/pym/gentoolkit/equery/hasuse.py
index aa47974..5ec8244 100644
--- a/pym/gentoolkit/equery/hasuse.py
+++ b/pym/gentoolkit/equery/hasuse.py
@@ -6,8 +6,6 @@
"""List all installed packages that have a given USE flag"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/list_.py b/pym/gentoolkit/equery/list_.py
index c547ac3..dca14b1 100644
--- a/pym/gentoolkit/equery/list_.py
+++ b/pym/gentoolkit/equery/list_.py
@@ -6,8 +6,6 @@
"""List installed packages matching the query pattern"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/meta.py b/pym/gentoolkit/equery/meta.py
index 2e8f91e..aa1de6a 100644
--- a/pym/gentoolkit/equery/meta.py
+++ b/pym/gentoolkit/equery/meta.py
@@ -6,8 +6,6 @@
"""Display metadata about a given package."""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/size.py b/pym/gentoolkit/equery/size.py
index 4151767..ee63c0b 100644
--- a/pym/gentoolkit/equery/size.py
+++ b/pym/gentoolkit/equery/size.py
@@ -6,8 +6,6 @@
"""Print total size of files contained in a given package"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/uses.py b/pym/gentoolkit/equery/uses.py
index e565b0d..e344e62 100644
--- a/pym/gentoolkit/equery/uses.py
+++ b/pym/gentoolkit/equery/uses.py
@@ -6,8 +6,6 @@
"""Display USE flags for a given package"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/equery/which.py b/pym/gentoolkit/equery/which.py
index a071801..ba3547c 100644
--- a/pym/gentoolkit/equery/which.py
+++ b/pym/gentoolkit/equery/which.py
@@ -8,8 +8,6 @@
configuration
"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
# =======
diff --git a/pym/gentoolkit/eshowkw/keywords_header.py b/pym/gentoolkit/eshowkw/keywords_header.py
index 31261dc..00ecb27 100644
--- a/pym/gentoolkit/eshowkw/keywords_header.py
+++ b/pym/gentoolkit/eshowkw/keywords_header.py
@@ -2,8 +2,6 @@
# Copyright 2001-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-from __future__ import print_function
-
__all__ = ['keywords_header']
from portage import settings as ports
diff --git a/pym/gentoolkit/imlate/imlate.py b/pym/gentoolkit/imlate/imlate.py
index 40e2914..3e22791 100755
--- a/pym/gentoolkit/imlate/imlate.py
+++ b/pym/gentoolkit/imlate/imlate.py
@@ -4,9 +4,6 @@
# $Id$
# Author: Christian Ruppert <idl0r@gentoo.org>
-# Python 2.6 compatibility
-from __future__ import print_function
-
__version__ = "git"
# works just with stable keywords!
diff --git a/pym/gentoolkit/module_base.py b/pym/gentoolkit/module_base.py
index e5d79e4..9f6ad91 100644
--- a/pym/gentoolkit/module_base.py
+++ b/pym/gentoolkit/module_base.py
@@ -9,8 +9,6 @@
"""General Base Module class to hold common module operation functions
"""
-from __future__ import print_function
-
__docformat__ = 'epytext'
diff --git a/pym/gentoolkit/revdep_rebuild/analyse.py b/pym/gentoolkit/revdep_rebuild/analyse.py
index 6ca3f10..4269ade 100644
--- a/pym/gentoolkit/revdep_rebuild/analyse.py
+++ b/pym/gentoolkit/revdep_rebuild/analyse.py
@@ -2,8 +2,6 @@
"""Analysis module"""
-from __future__ import print_function
-
import os
import re
import time
diff --git a/pym/gentoolkit/revdep_rebuild/assign.py b/pym/gentoolkit/revdep_rebuild/assign.py
index 48c8c93..1e5f3e9 100644
--- a/pym/gentoolkit/revdep_rebuild/assign.py
+++ b/pym/gentoolkit/revdep_rebuild/assign.py
@@ -4,8 +4,6 @@
Functions used for determining the package the broken lib belongs to.
"""
-from __future__ import print_function
-
import errno
import os
import io
diff --git a/pym/gentoolkit/revdep_rebuild/cache.py b/pym/gentoolkit/revdep_rebuild/cache.py
index ec9f168..66fbd9d 100644
--- a/pym/gentoolkit/revdep_rebuild/cache.py
+++ b/pym/gentoolkit/revdep_rebuild/cache.py
@@ -3,8 +3,6 @@
Functions for reading, saving and verifying the data caches
"""
-from __future__ import print_function
-
from portage import os
import time
import sys
diff --git a/pym/gentoolkit/revdep_rebuild/collect.py b/pym/gentoolkit/revdep_rebuild/collect.py
index cbac878..9f7d301 100644
--- a/pym/gentoolkit/revdep_rebuild/collect.py
+++ b/pym/gentoolkit/revdep_rebuild/collect.py
@@ -2,8 +2,6 @@
"""Data collection module"""
-from __future__ import print_function
-
import re
from portage import os
import glob
diff --git a/pym/gentoolkit/revdep_rebuild/rebuild.py b/pym/gentoolkit/revdep_rebuild/rebuild.py
index 3f152e7..4109c4f 100644
--- a/pym/gentoolkit/revdep_rebuild/rebuild.py
+++ b/pym/gentoolkit/revdep_rebuild/rebuild.py
@@ -14,8 +14,6 @@ Creation date: 2010/10/17
License: BSD
"""
-from __future__ import print_function
-
import os
import sys
import logging
diff --git a/pym/gentoolkit/revdep_rebuild/settings.py b/pym/gentoolkit/revdep_rebuild/settings.py
index 718fee7..efdb975 100644
--- a/pym/gentoolkit/revdep_rebuild/settings.py
+++ b/pym/gentoolkit/revdep_rebuild/settings.py
@@ -2,8 +2,6 @@
"""Default settings"""
-from __future__ import print_function
-
import argparse
import os
import sys
diff --git a/pym/gentoolkit/revdep_rebuild/stuff.py b/pym/gentoolkit/revdep_rebuild/stuff.py
index 002eb4b..432dc8f 100644
--- a/pym/gentoolkit/revdep_rebuild/stuff.py
+++ b/pym/gentoolkit/revdep_rebuild/stuff.py
@@ -3,8 +3,6 @@
"""Utilities submodule"""
-from __future__ import print_function
-
import subprocess
import portage
diff --git a/pym/gentoolkit/test/eclean/creator.py b/pym/gentoolkit/test/eclean/creator.py
index de50426..1c46b2d 100644
--- a/pym/gentoolkit/test/eclean/creator.py
+++ b/pym/gentoolkit/test/eclean/creator.py
@@ -6,9 +6,6 @@
#
# $Header$
-from __future__ import with_statement
-from __future__ import print_function
-
import os
import sys
if sys.hexversion < 0x3000000:
diff --git a/pym/gentoolkit/test/eclean/distsupport.py b/pym/gentoolkit/test/eclean/distsupport.py
index 78016ba..0f52238 100644
--- a/pym/gentoolkit/test/eclean/distsupport.py
+++ b/pym/gentoolkit/test/eclean/distsupport.py
@@ -6,8 +6,6 @@
# $Header$
-from __future__ import print_function
-
import re
import os
from tempfile import mkdtemp
diff --git a/pym/gentoolkit/test/eclean/test_clean.py b/pym/gentoolkit/test/eclean/test_clean.py
index 0fc9469..08c1be8 100755
--- a/pym/gentoolkit/test/eclean/test_clean.py
+++ b/pym/gentoolkit/test/eclean/test_clean.py
@@ -6,8 +6,6 @@
#
# $Header$
-from __future__ import print_function
-
__version__= "0.0.1"
__author__ = "Brian Dolbec"
__email__ = "brian.dolbec@gmail.com"
diff --git a/pym/gentoolkit/test/eclean/test_search.py b/pym/gentoolkit/test/eclean/test_search.py
index 6dc26a2..ac6a886 100755
--- a/pym/gentoolkit/test/eclean/test_search.py
+++ b/pym/gentoolkit/test/eclean/test_search.py
@@ -9,9 +9,6 @@
# $Header$
-from __future__ import print_function
-
-
import unittest
import re
import os
diff --git a/setup.py b/setup.py
index 777b7f3..a9cd80c 100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,5 @@
#!/usr/bin/env python
-from __future__ import print_function
-
-
import re
import sys
import subprocess