aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2018-08-14 09:41:21 -0400
committerVirgil Dupras <hsoft@hardcoded.net>2018-08-14 09:41:21 -0400
commitfdd23db536034e4e13fe2121ff155d9151744b45 (patch)
tree396a30092d938967ff3c4317793523ec34e15cd2
parentFix broken test suite (diff)
downloadgentoolkit-fdd23db5.tar.gz
gentoolkit-fdd23db5.tar.bz2
gentoolkit-fdd23db5.zip
Add tox.ini
The goal is for the `tox` command to be the only command to run to verify the quality of the code before a commit.
-rw-r--r--.gitignore1
-rw-r--r--tox.ini15
2 files changed, 16 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 3b6d6ef..63ee53f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ build
__pycache__
*.py[c,o]
dist
+/.tox
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..b7bcbdb
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,15 @@
+[tox]
+envlist = py27,py35,py36,py37,pyflakes
+skip_missing_interpreters = True
+
+[testenv]
+commands =
+ python setup.py test
+sitepackages = True
+
+[testenv:pyflakes]
+deps =
+ pyflakes
+commands =
+ pyflakes pym
+sitepackages = False