aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2012-11-11 21:05:13 -0500
committerW. Trevor King <wking@tremily.us>2012-11-11 21:05:13 -0500
commitcfe01271c3c64f290acf3ce3ae42eb55887e295d (patch)
tree3db85e61372c59204feebe1d9bd37580dceae2e1 /pym/gentoolkit/helpers.py
parentkeyword: define keyword_list in compare_strs doctest (diff)
downloadgentoolkit-cfe01271c3c64f290acf3ce3ae42eb55887e295d.tar.gz
gentoolkit-cfe01271c3c64f290acf3ce3ae42eb55887e295d.tar.bz2
gentoolkit-cfe01271c3c64f290acf3ce3ae42eb55887e295d.zip
helpers: use print() in ChangeLog doctest for Python 3 compatibility
Also update the expected portage.latest.
Diffstat (limited to 'pym/gentoolkit/helpers.py')
-rw-r--r--pym/gentoolkit/helpers.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/pym/gentoolkit/helpers.py b/pym/gentoolkit/helpers.py
index 90e0939..706b526 100644
--- a/pym/gentoolkit/helpers.py
+++ b/pym/gentoolkit/helpers.py
@@ -51,11 +51,12 @@ class ChangeLog(object):
Example usage:
>>> from gentoolkit.helpers import ChangeLog
>>> portage = ChangeLog('/usr/portage/sys-apps/portage/ChangeLog')
- >>> print portage.latest.strip()
- *portage-2.2_rc50 (15 Nov 2009)
-
- 15 Nov 2009; Zac Medico <zmedico@gentoo.org> +portage-2.2_rc50.ebuild:
- 2.2_rc50 bump. This includes all fixes in 2.1.7.5.
+ >>> print(portage.latest.strip())
+ *portage-2.2.0_alpha142 (26 Oct 2012)
+ <BLANKLINE>
+ 26 Oct 2012; Zac Medico <zmedico@gentoo.org> +portage-2.2.0_alpha142.ebuild:
+ 2.2.0_alpha142 version bump. This includes all of the fixes in 2.1.11.31. Bug
+ #210077 tracks all bugs fixed since portage-2.1.x.
>>> len(portage.full)
75
>>> len(portage.entries_matching_range(