aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2018-08-14 09:09:13 -0400
committerVirgil Dupras <hsoft@hardcoded.net>2018-08-14 09:09:13 -0400
commit31706fd222edc7e75cb051012dab644e88537ea9 (patch)
tree7f2a8eff9241a50396415c917d9a85c5cff39af6 /pym/gentoolkit/test
parentepkginfo: Add 'reverse' display option for equery (diff)
downloadgentoolkit-31706fd222edc7e75cb051012dab644e88537ea9.tar.gz
gentoolkit-31706fd222edc7e75cb051012dab644e88537ea9.tar.bz2
gentoolkit-31706fd222edc7e75cb051012dab644e88537ea9.zip
Fix broken test suite
The test suite (python setup.py test) was depending on a broken interface from dev-python/snakeoil. This indicates that tests weren't run in a while. We don't actually need snakeoil to run tests. Replaced the test command with a plain distutils Command. Moreover, one of test Query tests wasn't in sync with the code. Changed it to reflect current code.
Diffstat (limited to 'pym/gentoolkit/test')
-rw-r--r--pym/gentoolkit/test/test_query.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/pym/gentoolkit/test/test_query.py b/pym/gentoolkit/test/test_query.py
index 1513b5b..24880de 100644
--- a/pym/gentoolkit/test/test_query.py
+++ b/pym/gentoolkit/test/test_query.py
@@ -1,6 +1,4 @@
import unittest
-import warnings
-from tempfile import NamedTemporaryFile, mktemp
from gentoolkit import query
from gentoolkit import errors
@@ -15,13 +13,11 @@ class TestQuery(unittest.TestCase):
pass
def test_init(self):
- # valid queries must have at least one ascii letter or '*'
+ # valid queries must have at least one ascii letter or digit or
+ # '*'
invalid_queries = [
'',
- '1',
'/',
- '-1',
- '1/1',
]
for q in invalid_queries:
self.failUnlessRaises(errors.GentoolkitInvalidPackage,