aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/echangelog/echangelog')
-rwxr-xr-xsrc/echangelog/echangelog8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/echangelog/echangelog b/src/echangelog/echangelog
index 6f1178c..d6cb205 100755
--- a/src/echangelog/echangelog
+++ b/src/echangelog/echangelog
@@ -296,7 +296,7 @@ if (glob("*.ebuild")) {
}
# Figure out what has changed around here
-open(my $ph_status, "-|", $vcs{$vcs}{status}.' 2>&1 |') or die "Can't run ".$vcs{$vcs}{status}.": $!\n";
+open(my $ph_status, "-|", $vcs{$vcs}{status}.' 2>&1') or die "Can't run ".$vcs{$vcs}{status}.": $!\n";
while (<$ph_status>) {
# I don't want mess our existing stuff with the horrible bazaar stuff.
# TODO: add stuff for untracked/conflicting files.
@@ -523,9 +523,9 @@ sub sortfunc($$) {
my $ph_diff;
if (@ebuilds) {
if ($vcs eq "git") {
- open($ph_diff, "-|", $vcs{$vcs}{diff}." HEAD -- @ebuilds 2>&1 |") or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
+ open($ph_diff, "-|", $vcs{$vcs}{diff}." HEAD -- @ebuilds 2>&1") or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
} else {
- open($ph_diff, "-|", $vcs{$vcs}{diff}." @ebuilds 2>&1 |") or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
+ open($ph_diff, "-|", $vcs{$vcs}{diff}." @ebuilds 2>&1") or die "Can't run: ".$vcs{$vcs}{diff}."$!\n";
}
while (defined(my $line = <$ph_diff>)) {
@@ -598,7 +598,7 @@ close($ph_diff) if $ph_diff;
# Subversion diff doesn't identify new versions. So use the status command
if (($vcs eq "svn" or $vcs eq "hg") and (@ebuilds)) {
- open(my $ph_status, "-|", $vcs{$vcs}{status}." @ebuilds 2>&1 |") or die "Can't run: ".$vcs{$vcs}{status}."$!\n";
+ open(my $ph_status, "-|", $vcs{$vcs}{status}." @ebuilds 2>&1") or die "Can't run: ".$vcs{$vcs}{status}."$!\n";
while (defined(my $line = <$ph_status>)) {
if ($line =~ m/^A\s+\+?\s*(([^\s]*)\.ebuild)/) {