summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-06-04 11:11:12 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-06-04 13:15:37 +0530
commitf2ce743a337f63c2a46ce456b548eaed1e26728c (patch)
tree2a725fee6f3e0ada8794d406b4ef89b0ffc8017b /dev-python
parentnet-libs/libsoup: Sync with tree (diff)
downloadgnome-live-f2ce743a337f63c2a46ce456b548eaed1e26728c.tar.gz
gnome-live-f2ce743a337f63c2a46ce456b548eaed1e26728c.tar.bz2
gnome-live-f2ce743a337f63c2a46ce456b548eaed1e26728c.zip
dev-python/pygtk: Sync with tree
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/Manifest2
-rw-r--r--dev-python/pygtk/pygtk-9999.ebuild25
2 files changed, 14 insertions, 13 deletions
diff --git a/dev-python/pygtk/Manifest b/dev-python/pygtk/Manifest
index 7061876..47aa637 100644
--- a/dev-python/pygtk/Manifest
+++ b/dev-python/pygtk/Manifest
@@ -1,2 +1,2 @@
AUX pygtk-2.13.0-fix-codegen-location.patch 507 RMD160 30b49791ac11da80efae1ef0f3c7ccbb72fc82f9 SHA1 dc7d975fe4ebd95afba79cac6276c73f55a9961b SHA256 f446a7b3e3ac76a9ab594738b1fbf9105c1ca17e8053b1a8712a966e9cfe54d0
-EBUILD pygtk-9999.ebuild 1698 RMD160 7ec1eac1f61cc09d75517cde45a5847014b01061 SHA1 99a26163a7c81cf1e4a4443447b9a69d73ea17e0 SHA256 4305e9b1a1863a5c3758c33478f48b07574eb9ad55619d7992efdc120647986f
+EBUILD pygtk-9999.ebuild 1944 RMD160 6236fd6a0efcc01194330b655590ead730dc46f1 SHA1 da36981b404a9d138a0d488b31ae03755fe4cfbe SHA256 30b8be210e254e4edff27804491fa4cda9662fea8ed4a8cd6a195f26c1a35fa9
diff --git a/dev-python/pygtk/pygtk-9999.ebuild b/dev-python/pygtk/pygtk-9999.ebuild
index b320485..97a64bf 100644
--- a/dev-python/pygtk/pygtk-9999.ebuild
+++ b/dev-python/pygtk/pygtk-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.14.1.ebuild,v 1.7 2009/05/04 14:05:59 jer Exp $
-inherit autotools flag-o-matic python virtualx gnome2 gnome2-live
+inherit eutils flag-o-matic gnome.org python virtualx gnome2-live
DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -10,7 +10,7 @@ SRC_URI=""
LICENSE="LGPL-2.1"
SLOT="2"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="doc examples"
RDEPEND=">=dev-libs/glib-2.8.0
@@ -20,25 +20,25 @@ RDEPEND=">=dev-libs/glib-2.8.0
>=gnome-base/libglade-2.5.0
>=dev-lang/python-2.4.4-r5
>=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.15.5
+ >=dev-python/pygobject-2.15.3
!arm? ( dev-python/numeric )"
DEPEND="${RDEPEND}
doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
>=dev-util/pkgconfig-0.9"
-DOCS="AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO"
-PATCHES="${PN}-2.13.0-fix-codegen-location.patch"
+PATCHES="${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
-pkg_setup() {
+src_compile() {
use hppa && append-flags -ffunction-sections
- G2CONF="${G2CONF}
- --enable-thread
- $(use_enable doc docs)"
+ econf $(use_enable doc docs) --enable-thread
+
+ emake || die "emake failed"
}
src_install() {
- gnome2_src_install
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
if use examples; then
rm examples/Makefile*
@@ -54,6 +54,7 @@ src_test() {
pkg_postinst() {
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
gnome2-live_pkg_postinst