summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-09-16 00:01:13 +0000
committerMart Raudsepp <leio@gentoo.org>2006-09-16 00:01:13 +0000
commit27322e06fe0043e9723afbfb8893ee997a3d5063 (patch)
tree89b8950947a00c31688a7ac3addfb373ed60386c
downloadgnome-perf-27322e06fe0043e9723afbfb8893ee997a3d5063.tar.gz
gnome-perf-27322e06fe0043e9723afbfb8893ee997a3d5063.tar.bz2
gnome-perf-27322e06fe0043e9723afbfb8893ee997a3d5063.zip
Start a gnome-perf personal overlay.
This overlay will contain personal ebuilds with changes for improving performance, memory use, battery time and more - mostly in the GNOME stack (but hopefully also for some lower level depencendies). Use at your own risk, yada yada. Make the clock, fish, notification-area and wncklet applets built in-process for some memory savings.
-rw-r--r--gnome-base/gnome-panel/ChangeLog8
-rw-r--r--gnome-base/gnome-panel/Manifest12
-rw-r--r--gnome-base/gnome-panel/files/digest-gnome-panel-2.16.03
-rw-r--r--gnome-base/gnome-panel/gnome-panel-2.16.0.ebuild66
-rw-r--r--skel.ChangeLog67
5 files changed, 156 insertions, 0 deletions
diff --git a/gnome-base/gnome-panel/ChangeLog b/gnome-base/gnome-panel/ChangeLog
new file mode 100644
index 0000000..418346e
--- /dev/null
+++ b/gnome-base/gnome-panel/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for gnome-base/gnome-panel
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 15 Sep 2006; Mart Raudsepp <leio@gentoo.org> ChangeLog:
+ Make the clock, fish, notification-area and wncklet applets built in-process
+ for some memory savings.
+
diff --git a/gnome-base/gnome-panel/Manifest b/gnome-base/gnome-panel/Manifest
new file mode 100644
index 0000000..1b70ad9
--- /dev/null
+++ b/gnome-base/gnome-panel/Manifest
@@ -0,0 +1,12 @@
+DIST gnome-panel-2.16.0.tar.bz2 2664150 RMD160 fd761c133140a0999683748796d3b64982143a29 SHA1 32077d18d7255acb518a1795ce201b2a79017d97 SHA256 d13883bbf290ecf1a4fdb21c1afc39e62b68d2cc97701ca34f99654d891db7ef
+EBUILD gnome-panel-2.16.0.ebuild 1849 RMD160 07265684e1be12c0ce1143048180cfb875396803 SHA1 21760989c48c8ccb75a12b227aef0c6435b31686 SHA256 71a6ac79cd51a10e69ff2cef351604f4e4c86b4916387e0683270a2ba366443b
+MD5 237cd8185d28b5553c4a4adc32063372 gnome-panel-2.16.0.ebuild 1849
+RMD160 07265684e1be12c0ce1143048180cfb875396803 gnome-panel-2.16.0.ebuild 1849
+SHA256 71a6ac79cd51a10e69ff2cef351604f4e4c86b4916387e0683270a2ba366443b gnome-panel-2.16.0.ebuild 1849
+MISC ChangeLog 288 RMD160 9bedaa56d62ec073ca7f27f4f1cb86a3eefc6d99 SHA1 e7ad019a64fb17d8d819c3e44db28ec3c09378e9 SHA256 f2c0ff3b787c7a2bc4b06f0c9b125cb322612405638125a26affff0578683e5d
+MD5 84955ce1648e3b1e605fdc7756e6a755 ChangeLog 288
+RMD160 9bedaa56d62ec073ca7f27f4f1cb86a3eefc6d99 ChangeLog 288
+SHA256 f2c0ff3b787c7a2bc4b06f0c9b125cb322612405638125a26affff0578683e5d ChangeLog 288
+MD5 157eba34216c163b3abbee65f8d1a7b0 files/digest-gnome-panel-2.16.0 262
+RMD160 7d32a2699e1ad43fcb8b605b5039b582dda14e8f files/digest-gnome-panel-2.16.0 262
+SHA256 3bf2c9b7fab3a3d84d835676c269ba7ad539eef1d1f2e1335267f8179ca423af files/digest-gnome-panel-2.16.0 262
diff --git a/gnome-base/gnome-panel/files/digest-gnome-panel-2.16.0 b/gnome-base/gnome-panel/files/digest-gnome-panel-2.16.0
new file mode 100644
index 0000000..8dfc84e
--- /dev/null
+++ b/gnome-base/gnome-panel/files/digest-gnome-panel-2.16.0
@@ -0,0 +1,3 @@
+MD5 3ad554554e504ec7b1857cd4acbbd661 gnome-panel-2.16.0.tar.bz2 2664150
+RMD160 fd761c133140a0999683748796d3b64982143a29 gnome-panel-2.16.0.tar.bz2 2664150
+SHA256 d13883bbf290ecf1a4fdb21c1afc39e62b68d2cc97701ca34f99654d891db7ef gnome-panel-2.16.0.tar.bz2 2664150
diff --git a/gnome-base/gnome-panel/gnome-panel-2.16.0.ebuild b/gnome-base/gnome-panel/gnome-panel-2.16.0.ebuild
new file mode 100644
index 0000000..670d5ce
--- /dev/null
+++ b/gnome-base/gnome-panel/gnome-panel-2.16.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.16.0.ebuild,v 1.2 2006/09/12 15:21:36 dang Exp $
+
+inherit gnome2
+
+DESCRIPTION="The GNOME panel"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc eds"
+
+RDEPEND=">=gnome-base/gnome-desktop-2.11.92
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.13
+ >=gnome-base/libgnomeui-2.5.4
+ >=gnome-base/libbonoboui-2.1.1
+ >=gnome-base/orbit-2.4
+ >=gnome-base/gnome-vfs-2.14.2
+ >=x11-libs/libwnck-2.13.5
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/gnome-menus-2.11.1
+ >=gnome-base/libbonobo-2
+ >=sys-apps/dbus-0.60
+ >=x11-libs/cairo-1.0.0
+ media-libs/libpng
+ eds? ( >=gnome-extra/evolution-data-server-1.6 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper $(use_enable eds) \
+ --with-in-process-applets=all"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # FIXME : uh yeah, this is nice
+ # We should patch in a switch here and send it upstream
+ sed -i 's:--load:-v:' ${S}/gnome-panel/Makefile.in || die "sed failed"
+}
+
+pkg_postinst() {
+ local entries="/etc/gconf/schemas/panel-default-setup.entries"
+ if [ -e "$entries" ]; then
+ einfo "setting panel gconf defaults..."
+ GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+ ${ROOT}/usr/bin/gconftool-2 --direct --config-source \
+ ${GCONF_CONFIG_SOURCE} --load=${entries}
+ fi
+
+ # Calling this late so it doesn't process the GConf schemas file we already
+ # took care of.
+ gnome2_pkg_postinst
+}
diff --git a/skel.ChangeLog b/skel.ChangeLog
new file mode 100644
index 0000000..1f22d12
--- /dev/null
+++ b/skel.ChangeLog
@@ -0,0 +1,67 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*<PACKAGE_NAME>-<PACKAGE_VERSION>-<PACKAGE_RELEASE> (DD MMM YYYY)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2 :
+ Initial import. Ebuild submitted by submitter_name <submitter_email>.
+ Note that the "changed_file" listing is optional if you are simply bumping
+ the rev of the ebuild and are only making changes to the .ebuild file
+ itself. Also note that we now have a single unified paragraph rather than
+ having the first line separated from the rest by a newline. Everything
+ should be in one block like this. (note by drobbins, 16 Jul 2002)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2: this is
+ an earlier ChangeLog entry.
+
+-- Explanation of ChangeLog format:
+
+ ***************************************************************************
+ THIS IS IMPORTANT: The ChangeLog format is a *chronological* account of all
+ changes made to a set of ebuilds. That means that the most recent ChangeLog
+ entry *always* goes at the top of the file. More explanation below.
+ ***************************************************************************
+
+ ***************************************************************************
+ ANOTHER IMPORTANT NOTE: There are some ChangeLogs that don't follow this
+ format and organize all changes under the "correct" "*" entry. This is not
+ correct. However, rather than making a concerted effort to fix these
+ ChangeLogs, we should spend our energy defining a comprehensive and strict
+ XML-based ChangeLog format which we then migrate to. But for any entries to
+ any ChangeLog that *you* make, please make sure to always add entries to the
+ top of the file like a good boy/girl. Even do this if it's clear that you're
+ adding an entry to a b0rked ChangeLog.
+ ***************************************************************************
+
+ This changelog is targeted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package should be marked by a '*'
+ separator line as above to indicate where in the chronology it was first
+ added to our CVS tree. Any changes since the last revision, really _any
+ changes at all_ have to be added to the top of the file, underneath the
+ initial copyright and cvs header comments, in exactly the same format as this
+ comment. If you are modifying older ebuilds, simply note them as changed
+ files and add your entry to the top of the ChangeLog. Resist the temptation
+ to "organize" your ChangeLog entries by placing them under the "correct" "*"
+ entries -- this isn't the purpose of the "*" entries.
+
+ This means that you start with header line that has the following format,
+ indented two spaces:
+
+ DD MMM YYYY; your_name <your_email> changed_file1, changed_file2: Your
+ explanation should follow. It should be indented and wrapped at a line width
+ of 80 characters. The changed_files can be omitted if they are obvious; for
+ example, if you are only modifying the .ebuild file and committing a new rev
+ of a package. Any details about what exactly changed in the code should be
+ added as a message when the changes are committed to cvs, not in this file.
+
+-- A word regarding credit:
+
+ Please add credit information ("ebuild submitted by ...", "patch submitted
+ by ...") to the ChangeLog. Do not add this information to the ebuilds
+ themselves.
+
+ And remember: Give credit where credit is due. We're all doing this for
+ free, so the best we can hope (and expect!) to receive is credit.