summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-05-27 19:47:36 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-05-27 19:48:42 +0200
commit2fc4e079f282541d41fa4e19d8c6bd43cff0c7de (patch)
treee8b97079479c410fe6cfa97ddb231ed17339a96a
parentgnome-extra/gnome-clocks: raise minimum meson required (diff)
downloadgnome-2fc4e079.tar.gz
gnome-2fc4e079.tar.bz2
gnome-2fc4e079.zip
gnome-extra/gnome-color-manager: do not check for exiv in packagekit
Also cleanup vte related comments. Raise minimum dependency for gettext to meson required version and control tests via USE-flag since upstream is not bound to its understanding of autotools anymore. Drop unused libxslt dependency. Synchronize live ebuilds. Package-Manager: Portage-2.3.40, Repoman-2.3.9 Manifest-Sign-Key: 0x5A56C8CD0C13248A
-rw-r--r--gnome-extra/gnome-color-manager/files/3.26-remove-unwanted-check.patch24
-rw-r--r--gnome-extra/gnome-color-manager/files/9999-remove-unwanted-check.patch24
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.26.0.ebuild20
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild64
4 files changed, 83 insertions, 49 deletions
diff --git a/gnome-extra/gnome-color-manager/files/3.26-remove-unwanted-check.patch b/gnome-extra/gnome-color-manager/files/3.26-remove-unwanted-check.patch
new file mode 100644
index 00000000..30658f2e
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/files/3.26-remove-unwanted-check.patch
@@ -0,0 +1,24 @@
+From dd43972782c34fe4d8925d52ae82d69add00493a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 27 May 2018 19:27:51 +0200
+Subject: [PATCH] Fix unwanted exiv check in packagekit option handling
+
+---
+ meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index dd0be0b..0721028 100644
+--- a/meson.build
++++ b/meson.build
+@@ -101,7 +101,6 @@ if get_option('enable-exiv')
+ endif
+
+ if get_option('enable-packagekit')
+- libexiv = dependency('exiv2')
+ conf.set('HAVE_PACKAGEKIT', '1')
+ endif
+
+--
+2.17.0
+
diff --git a/gnome-extra/gnome-color-manager/files/9999-remove-unwanted-check.patch b/gnome-extra/gnome-color-manager/files/9999-remove-unwanted-check.patch
new file mode 100644
index 00000000..b3113474
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/files/9999-remove-unwanted-check.patch
@@ -0,0 +1,24 @@
+From 534eed4f8664c9f263d666ed78144c37dc05bf90 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 27 May 2018 19:27:51 +0200
+Subject: [PATCH] Fix unwanted exiv check in packagekit option handling
+
+---
+ meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 9e179fb..08a0f79 100644
+--- a/meson.build
++++ b/meson.build
+@@ -108,7 +108,6 @@ if get_option('exiv')
+ endif
+
+ if get_option('packagekit')
+- libexiv = dependency('exiv2')
+ conf.set('HAVE_PACKAGEKIT', '1')
+ endif
+
+--
+2.17.0
+
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.26.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.26.0.ebuild
index f317d6a3..9c49479f 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-3.26.0.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.26.0.ebuild
@@ -10,9 +10,10 @@ HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="packagekit raw"
-# FIXME: libvte atomagic
+IUSE="packagekit raw test"
+
# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331
+# vte could be made optional
RDEPEND="
>=dev-libs/glib-2.31.10:2
>=media-libs/lcms-2.2:2
@@ -25,8 +26,6 @@ RDEPEND="
>=x11-misc/colord-1.3.1:0=
>=x11-libs/colord-gtk-0.1.20
- x11-libs/vte:2.91
-
packagekit? ( app-admin/packagekit-base )
raw? ( media-gfx/exiv2:0= )
"
@@ -35,19 +34,22 @@ DEPEND="${RDEPEND}
app-text/docbook-sgml-dtd:4.1
app-text/docbook-sgml-utils
dev-libs/appstream-glib
- dev-libs/libxslt
dev-util/itstool
- >=sys-devel/gettext-0.19.7
+ >=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=796428
+ "${FILESDIR}"/3.26-remove-unwanted-check.patch
+)
+
src_configure() {
# Always enable tests since they are check_PROGRAMS anyway
- # appstream does not want to be relax by default !
gnome-meson_src_configure \
- -Denable-tests=true \
$(meson_use raw enable-exiv) \
- $(meson_use packagekit enable-packagekit)
+ $(meson_use packagekit enable-packagekit) \
+ $(meson_use test enable-tests)
}
src_test() {
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
index 632e7706..55635ddf 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-9999.ebuild
@@ -1,29 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit gnome2 virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
+EAPI=6
+inherit git-r3 gnome-meson virtualx
DESCRIPTION="Color profile manager for the GNOME desktop"
HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
+SRC_URI=""
+EGIT_MODULE="https://git.gnome.org/gnome-color-manager"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-fi
-IUSE="packagekit raw"
+KEYWORDS=""
+IUSE="packagekit raw test"
# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331
-COMMON_DEPEND="
+# vte could be made optional
+RDEPEND="
>=dev-libs/glib-2.31.10:2
>=media-libs/lcms-2.2:2
>=media-libs/libcanberra-0.10[gtk3]
@@ -32,50 +25,41 @@ COMMON_DEPEND="
>=x11-libs/gtk+-3.3.8:3
>=x11-libs/vte-0.25.1:2.91
- >=x11-misc/colord-0.1.34:0=
+ >=x11-misc/colord-1.3.1:0=
>=x11-libs/colord-gtk-0.1.20
packagekit? ( app-admin/packagekit-base )
- raw? ( media-gfx/exiv2 )
+ raw? ( media-gfx/exiv2:0= )
"
-RDEPEND="${COMMON_DEPEND}"
-
# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
app-text/docbook-sgml-dtd:4.1
app-text/docbook-sgml-utils
dev-libs/appstream-glib
- dev-libs/libxslt
- >=dev-util/intltool-0.35
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools"
-fi
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=796428
+ "${FILESDIR}"/9999-remove-unwanted-check.patch
+)
src_configure() {
- local myconf=""
- [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
-
# Always enable tests since they are check_PROGRAMS anyway
- # appstream does not want to be relax by default !
- gnome2_src_configure \
- --disable-static \
- --enable-tests \
- $(use_enable packagekit) \
- $(use_enable raw exiv) \
- APPSTREAM_UTIL=$(type -P true) \
- ${myconf}
+ gnome-meson_src_configure \
+ $(meson_use raw enable-exiv) \
+ $(meson_use packagekit enable-packagekit) \
+ $(meson_use test enable-tests)
}
src_test() {
- Xemake check
+ virtx meson_src_test
}
pkg_postinst() {
- gnome2_pkg_postinst
+ gnome-meson_pkg_postinst
if ! has_version media-gfx/argyllcms ; then
elog "If you want to do display or scanner calibration, you will need to"