summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-09-10 11:23:50 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-09-10 11:23:50 +0200
commit4b67a514ff784e683f0844600cb8932800b028e6 (patch)
tree9dc605210f58e4c2fcd9f2518518a3d0eb6f6c57
parentdev-libs/gobject-introspection: replace versionator by eapi7-ver (diff)
downloadgnome-4b67a514.tar.gz
gnome-4b67a514.tar.bz2
gnome-4b67a514.zip
dev-libs/gobject-introspection: synchronize live ebuild
Package-Manager: Portage-2.3.49, Repoman-2.3.10 Manifest-Sign-Key: 0x5A56C8CD0C13248A
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
index 89c799e8..731dcdb1 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
-PYTHON_COMPAT=( python2_7 )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
PYTHON_REQ_USE="xml"
-inherit gnome2 python-single-r1 toolchain-funcs versionator
+inherit eapi7-ver gnome2 python-single-r1 toolchain-funcs
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -25,15 +24,15 @@ if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
IUSE="${IUSE} doc"
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
# virtual/pkgconfig needed at runtime, bug #505408
-# We force glib and goi to be in sync by this way as explained in bug #518424
+# We force glib and g-i to be in sync by this way as explained in bug #518424
RDEPEND="
>=dev-libs/gobject-introspection-common-${PV}
>=dev-libs/glib-9999:2
- doctool? ( dev-python/mako )
+ doctool? ( dev-python/mako[${PYTHON_USEDEP}] )
virtual/libffi:=
virtual/pkgconfig
!<dev-lang/vala-0.20.0
@@ -76,7 +75,6 @@ src_configure() {
}
src_install() {
- DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
gnome2_src_install
# Prevent collision with gobject-introspection-common