summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2018-01-25 19:56:13 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2018-01-25 19:56:13 +0100
commit6b41f8bd0850151f8802bd2a030d31f0ca66be8d (patch)
tree388c0548b3f41a64eda3921bfc4b9e46bbc6027e
parentmedia-gfx/eog: version bump to 3.26.1 (diff)
downloadgnome-6b41f8bd0850151f8802bd2a030d31f0ca66be8d.tar.gz
gnome-6b41f8bd0850151f8802bd2a030d31f0ca66be8d.tar.bz2
gnome-6b41f8bd0850151f8802bd2a030d31f0ca66be8d.zip
dev-util/itstool: version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-util/itstool/Manifest1
-rw-r--r--dev-util/itstool/itstool-2.0.4.ebuild35
-rw-r--r--dev-util/itstool/itstool-9999.ebuild40
3 files changed, 55 insertions, 21 deletions
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
new file mode 100644
index 00000000..e1a9d61f
--- /dev/null
+++ b/dev-util/itstool/Manifest
@@ -0,0 +1 @@
+DIST 2.0.4.tar.gz 79430 SHA256 3221bba908eb3c19d3b6f8e195ad706afcfef9d2f552d44e45cd77f622fd6dbc SHA512 c4c12229419e376c378986c5e5e5de9d006e5a938d7935ae91ba1f5a70484ff519038ba6bba91329a54d96c7e53ea12fcf1122d63e891fd5c64813cebf5ad8fa WHIRLPOOL 31452d1a072521105fb9b155beef2f306e524262da45e8daa2e4e7691cbd9b6950ef484d33ad68d46c74244d8bdf4dd65c326a3febe87eefc6ee3e851e7e88cd
diff --git a/dev-util/itstool/itstool-2.0.4.ebuild b/dev-util/itstool/itstool-2.0.4.ebuild
new file mode 100644
index 00000000..b0bb4cf4
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="https://github.com/itstool/itstool/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_test() {
+ suite="${S}"/tests/run_tests.py
+ PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
+ unset suite
+}
diff --git a/dev-util/itstool/itstool-9999.ebuild b/dev-util/itstool/itstool-9999.ebuild
index e3ccb260..8e25b7ab 100644
--- a/dev-util/itstool/itstool-9999.ebuild
+++ b/dev-util/itstool/itstool-9999.ebuild
@@ -1,50 +1,48 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="xml"
-inherit python-single-r1
+inherit autotools python-single-r1
+
if [[ ${PV} = 9999 ]]; then
- inherit autotools git-2
+ inherit git-r3
fi
DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
HOMEPAGE="http://itstool.org/"
if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://gitorious.org/itstool/itstool.git"
+ EGIT_REPO_URI="https://github.com/itstool/itstool.git"
else
- SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+ SRC_URI="https://github.com/itstool/itstool/archive/${PV}.tar.gz"
fi
-# files in /usr/share/itstool/its are HPND/as-is || GPL-3
-LICENSE="GPL-3+ || ( HPND GPL-3+ )"
+LICENSE="GPL-3+"
SLOT="0"
+
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~arm-linux ~x86-linux"
fi
+
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-pkg_setup() {
- DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
- python-single-r1_pkg_setup
-}
-
src_prepare() {
- python_fix_shebang .
- [[ ${PV} = 9999 ]] && eautoreconf
+ eapply_user
+ eautoreconf
}
-src_compile() {
- default
- [[ ${PV} = 9999 ]] && emake ChangeLog
+src_test() {
+ suite="${S}"/tests/run_tests.py
+ PYTHONPATH="." "${PYTHON}" ${suite} || die "test suite '${suite}' failed"
+ unset suite
}