summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:03:44 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:03:44 +0200
commit6b5b458bc42791610fe3dbf9a4c7e1bee6a83f86 (patch)
treefc89805d721f4c45e66ae0db5649752a778b0dee
parentx11-themes/adwaita-icon-theme: sync with gentoo repository (diff)
downloadgnome-6b5b458b.tar.gz
gnome-6b5b458b.tar.bz2
gnome-6b5b458b.zip
x11-themes/gnome-themes-standard: sync with gentoo repository
-rw-r--r--x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.22.2-exclude-engine.patch63
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild53
2 files changed, 88 insertions, 28 deletions
diff --git a/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.22.2-exclude-engine.patch b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.22.2-exclude-engine.patch
new file mode 100644
index 00000000..7cdceff7
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.22.2-exclude-engine.patch
@@ -0,0 +1,63 @@
+From 58fd7206211e8e4d42ce6925718e56f84a1b4eb3 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 3 Oct 2016 00:38:57 +0200
+Subject: [PATCH] Control build of gtk+2 adwaita theme engine from configure
+
+Rather than whole gtk+-2 theme.
+
+This only makes sense in Gentoo as the theme engine has been split to
+a separate package to allow gtk+2 free systems.
+---
+ themes/Adwaita-dark/Makefile.am | 6 +-----
+ themes/Adwaita/Makefile.am | 6 +-----
+ themes/Adwaita/gtk-2.0/Makefile.am | 2 ++
+ 3 files changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/themes/Adwaita-dark/Makefile.am b/themes/Adwaita-dark/Makefile.am
+index 8a381b9..c5efcbf 100644
+--- a/themes/Adwaita-dark/Makefile.am
++++ b/themes/Adwaita-dark/Makefile.am
+@@ -1,8 +1,4 @@
+-SUBDIRS = gtk-3.0
+-
+-if GTK2_ENGINE
+-SUBDIRS += gtk-2.0
+-endif
++SUBDIRS = gtk-2.0 gtk-3.0
+
+ THEME_NAME=Adwaita-dark
+ THEME_IN_FILES=index.theme.in
+diff --git a/themes/Adwaita/Makefile.am b/themes/Adwaita/Makefile.am
+index 8583535..617b9a6 100644
+--- a/themes/Adwaita/Makefile.am
++++ b/themes/Adwaita/Makefile.am
+@@ -1,8 +1,4 @@
+-SUBDIRS = gtk-3.0
+-
+-if GTK2_ENGINE
+-SUBDIRS += gtk-2.0
+-endif
++SUBDIRS = gtk-2.0 gtk-3.0
+
+ THEME_NAME=Adwaita
+ THEME_IN_FILES=index.theme.in
+diff --git a/themes/Adwaita/gtk-2.0/Makefile.am b/themes/Adwaita/gtk-2.0/Makefile.am
+index 1e56f7f..9108cc4 100644
+--- a/themes/Adwaita/gtk-2.0/Makefile.am
++++ b/themes/Adwaita/gtk-2.0/Makefile.am
+@@ -1,3 +1,4 @@
++if GTK2_ENGINE
+ enginedir = $(libdir)/gtk-2.0/$(GTK2_VERSION)/engines
+ engine_LTLIBRARIES = libadwaita.la
+
+@@ -5,6 +6,7 @@ libadwaita_la_CFLAGS = $(GTK2_ENGINE_CFLAGS)
+ libadwaita_la_SOURCES = adwaita_engine.c
+ libadwaita_la_LDFLAGS = -module -avoid-version -no-undefined
+ libadwaita_la_LIBADD = $(GTK2_ENGINE_LIBS)
++endif
+
+ themedir = $(datadir)/themes/Adwaita/gtk-2.0
+ theme_DATA = gtkrc main.rc apps.rc hacks.rc
+--
+2.10.1
+
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
index ee196b5e..9a9e69ce 100644
--- a/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
@@ -1,12 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
+EAPI=6
-inherit gnome2
+inherit autotools gnome.org
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -16,40 +13,40 @@ HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
LICENSE="LGPL-2.1+"
SLOT="0"
-IUSE="+gtk"
+IUSE=""
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
fi
-COMMON_DEPEND="
- gnome-base/librsvg:2
- x11-libs/cairo
- >=x11-themes/gtk-engines-2.15.3:2
- gtk? (
- >=x11-libs/gtk+-2.24.15:2
- >=x11-libs/gtk+-3.12:3 )
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="
+ >=gnome-base/gsettings-desktop-schemas-3.4
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="
>=dev-util/intltool-0.40
sys-devel/gettext
virtual/pkgconfig
"
-# gnome-themes{,-extras} are OBSOLETE for GNOME 3
-# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
-# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
-# their default background image
-RDEPEND="${COMMON_DEPEND}
- >=gnome-base/gsettings-desktop-schemas-3.4
- !<x11-themes/gnome-themes-2.32.1-r1
-"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
+ # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
+ "${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- # The icon cache needs to be generated in pkg_postinst()
- gnome2_src_configure \
+ ECONF_SOURCE="${S}" econf \
--disable-static \
- $(use_enable gtk gtk2-engine) \
- $(use_enable gtk gtk3-engine) \
+ --disable-gtk2-engine \
+ --disable-gtk3-engine \
GTK_UPDATE_ICON_CACHE=$(type -P true)
}