summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2018-05-11 10:20:54 +0430
committerSobhan Mohammadpour <sobhan@gentoo.org>2018-05-11 10:20:54 +0430
commit836eb20048bb69aabac2b1d5a45519f134fab975 (patch)
tree3403689b1c80f08d33ca9181de225a376fe15ee4
parentgnome-extra/gnome-documents: fix useflag (diff)
downloadgnome-836eb200.tar.gz
gnome-836eb200.tar.bz2
gnome-836eb200.zip
gnome-extra/gnome-shell-extensions: bump
Package-Manager: Portage-2.3.36, Repoman-2.3.9 Manifest-Sign-Key: 0x7DF238CF0AA182E1
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest23
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2.ebuild76
2 files changed, 99 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
new file mode 100644
index 00000000..b58302d7
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -0,0 +1,23 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST gnome-shell-extensions-3.26.2.tar.xz 348720 BLAKE2B c276b95c7c80d732257396b3b04e273394adb5580709db3ba6ba5129ed9f6458cf2b2daee253fb2759169417364d4392e5734b5df3bdfd00266439c2bca2db9e SHA512 8eb417a947545832d180cf7e53e1c239aec3ba1c819375071f7f036617de4ccdea5f23e81349d53dbc3c5f12334b1f1f590def7b75130e1057c314db557166e6
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQKTBAEBCAB9FiEEhjiDzgE0H6m8d3Z/4FucaN0bWf0FAlr1Lz1fFIAAAAAALgAo
+aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDg2
+Mzg4M0NFMDEzNDFGQTlCQzc3NzY3RkUwNUI5QzY4REQxQjU5RkQACgkQ4FucaN0b
+Wf24QQ/7BxjeAKjZQpWsErSq+XfN3DHYTmNf+ACG5ifXVgm8IEjoQvAcOOb32EWJ
+ZksG+MX6CwFYVl5AzAcjMdKdnzMoY3AYdvXvPuRNamXo9+vP5o7mnwTjOElbcdyF
+Fso6acc0/jU6F+KaF61k8+wzvNmQugxFqKll//BvlxXN8usugkuJilTmByCCbqAK
+tiUYzuLagX8rTY73n2ZC1wNyRQKXi7/G6QyTq3WtPHGYmV7CZymB2Pv7dFh7w5ms
+WCjtq27zuDnguiqkQlVayDiDNeqfMn4c74pnAikAL+ly4Rafm9gZi9eyYuatc1r0
+B0BivmyyFolWV3SDc7CxV/KR3njUWjV9jb/MVDF4cqzNy9+TtxFDx95CcxQBNIxW
+bxZACYmUDBDAmK/HPpaW+oubLNGP2uOPKVKMiwjLAjD4qr5lG8sMnZpjZP0Qk93t
+8IIxbNsXIzo1YONRDahfA0Hx02kPzOGKMeEAUK5XS1Mx7f4A7HPZmJkBXN5jFGNC
+BGz0pyEmY5t5D0gesxsK+mia64Pm7AqRMp0IGlLbOewneCzTJVY7yFBAeCSltArb
+5ePa0v8m73QNqF+OhAfXGxVnJhrdI/uoVYFSLQYp5MH96m+0MNu1bd55gNRnggt5
+3dUOwCgtrfxekGVxKEm+qDznXsh3HQOEhRuembnf/xZ4WBCLFG0=
+=YcN0
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2.ebuild
new file mode 100644
index 00000000..e8fdd259
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.26.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ dev-libs/atk[introspection]
+ gnome-base/gnome-menus:3[introspection]
+ >=gnome-base/gnome-shell-3.14.2
+ media-libs/clutter:1.0[introspection]
+ net-libs/telepathy-glib[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ x11-wm/mutter[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+# eautoreconf needs gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweak-tool GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+ gnome2_src_configure --enable-extensions=all
+}
+
+src_install() {
+ gnome2_src_install
+
+ local example="example@gnome-shell-extensions.gcampax.github.com"
+ if use examples; then
+ mv "${ED}usr/share/gnome-shell/extensions/${example}" \
+ "${ED}usr/share/doc/${PF}/" || die
+ else
+ rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}