summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-05 11:34:30 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-05 11:34:30 +0300
commit88e03c00aba960ab4b8d6abb32a336d34ae16a91 (patch)
tree7e1ab7bb21a5a8f6c4776072350e251275f0c7ec
parentwww-client/epiphany-3.26.7: remove, available with fixes in ::gentoo (diff)
downloadgnome-88e03c00.tar.gz
gnome-88e03c00.tar.bz2
gnome-88e03c00.zip
www-client/epiphany-9999: sync in fixes from main tree
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild29
-rw-r--r--www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch45
2 files changed, 14 insertions, 60 deletions
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 4ee03e5d..0cfc5875 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-GNOME2_LA_PUNT="yes"
inherit gnome-meson virtualx
if [[ ${PV} = 9999 ]]; then
@@ -24,54 +23,54 @@ else
fi
COMMON_DEPEND="
- >=dev-libs/glib-2.52.0:2[dbus]
- >=dev-libs/json-glib-1.2.4
+ >=dev-libs/glib-2.52.0:2
>=x11-libs/gtk+-3.22.13:3
+ >=dev-libs/nettle-3.2:=
>=net-libs/webkit-gtk-2.17.4:4=
>=x11-libs/cairo-1.2
>=app-crypt/gcr-3.5.5:=[gtk]
>=x11-libs/gdk-pixbuf-2.36.5:2
>=gnome-base/gnome-desktop-2.91.2:3=
dev-libs/icu:=
- >=x11-libs/libnotify-0.5.1:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=x11-libs/libnotify-0.5.1
>=app-crypt/libsecret-0.14
>=net-libs/libsoup-2.48:2.4
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
- >=dev-libs/nettle-3.2
dev-db/sqlite:3
- dev-libs/gmp:0
- >=app-text/iso-codes-0.35
+ dev-libs/gmp:0=
>=gnome-base/gsettings-desktop-schemas-0.0.1
"
-# epiphany-extensions support was removed in 3.7; let's not pretend it still works
RDEPEND="${COMMON_DEPEND}
x11-themes/adwaita-icon-theme
- !www-client/epiphany-extensions
"
# paxctl needed for bug #407085
DEPEND="${COMMON_DEPEND}
app-text/yelp-tools
- dev-libs/appstream-glib
+ dev-util/gdbus-codegen
sys-apps/paxctl
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
PATCHES=(
- # https://bugzilla.gnome.org/show_bug.cgi?id=751593
- "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ # ephy-file-helpers tests are currently disabled due to https://gitlab.gnome.org/GNOME/epiphany/issues/419
+ # So this patch is currently without effect. Retest with PORTAGE_TMPDIR=/var/tmp once re-enabled upstream.
+ #"${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
)
-# FIXME: it seems it can't use newer libhttpseverywhere
src_configure() {
+ # https_everywhere removed in 3.28
gnome-meson_src_configure \
+ -Ddeveloper_mode=false \
-Ddistributor_name=Gentoo \
-Dhttps_everywhere=false \
$(meson_use test unit_tests)
}
src_test() {
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
- GSETTINGS_SCHEMA_DIR="${S}/data" virtx meson_src_test
+ virtx meson_src_test
}
diff --git a/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch b/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch
deleted file mode 100644
index 36dcb30c..00000000
--- a/www-client/epiphany/files/epiphany-3.14.0-unittest-2.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 3d2ca8dfb33f9dd658293d14d6b75983d1d2f57d Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Sun, 19 Oct 2014 23:06:29 +0200
-Subject: [PATCH 3/3] Disable broken tests
-
-Not the first time these are failing even though issue was reported
-upstream.
----
- tests/ephy-file-helpers-test.c | 4 ++--
- tests/ephy-migration-test.c | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
-index bdf7455..718fa29 100644
---- a/tests/ephy-file-helpers-test.c
-+++ b/tests/ephy-file-helpers-test.c
-@@ -341,8 +341,8 @@ main (int argc, char *argv[])
- g_test_add_func ("/lib/ephy-file-helpers/get_downloads_dir",
- test_ephy_file_get_downloads_dir);
-
-- g_test_add_func ("/lib/ephy-file-helpers/create_delete_dir",
-- test_ephy_file_create_delete_dir);
-+ /*g_test_add_func ("/lib/ephy-file-helpers/create_delete_dir",
-+ test_ephy_file_create_delete_dir);*/
-
- g_test_add_func ("/lib/ephy-file-helpers/desktop_dir",
- test_ephy_file_desktop_dir);
-diff --git a/tests/ephy-migration-test.c b/tests/ephy-migration-test.c
-index fab9ee7..64cdd65 100644
---- a/tests/ephy-migration-test.c
-+++ b/tests/ephy-migration-test.c
-@@ -65,8 +65,8 @@ main (int argc, char *argv[])
-
- g_test_add_func ("/lib/ephy-profile-utils/do_migration_simple",
- test_do_migration_simple);
-- g_test_add_func ("/lib/ephy-profile-utils/do_migration_invalid",
-- test_do_migration_invalid);
-+ /*g_test_add_func ("/lib/ephy-profile-utils/do_migration_invalid",
-+ test_do_migration_invalid);*/
-
- return g_test_run ();
- }
---
-2.1.2
-