summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2016-03-27 15:37:19 +0200
committerOle Reifschneider <tranquility@gentoo.org>2016-03-27 23:05:57 +0200
commitacea60ebe355992d0f1ca18121cea0dfef74a956 (patch)
tree24732bb081ddb1838ac1a384ef4a65ed373ed2da
parentgnome-extra/yelp: Bump version to 3.20.0 (diff)
downloadgnome-acea60eb.tar.gz
gnome-acea60eb.tar.bz2
gnome-acea60eb.zip
media-plugins/grilo-plugins: Bump version to 0.3.0
Package-Manager: portage-2.2.28 Manifest-Sign-Key: 0xE9E568677E8B4D42
-rw-r--r--media-plugins/grilo-plugins/Manifest15
-rw-r--r--media-plugins/grilo-plugins/grilo-plugins-0.3.0.ebuild111
-rw-r--r--media-plugins/grilo-plugins/metadata.xml20
3 files changed, 146 insertions, 0 deletions
diff --git a/media-plugins/grilo-plugins/Manifest b/media-plugins/grilo-plugins/Manifest
new file mode 100644
index 00000000..4bfa06a9
--- /dev/null
+++ b/media-plugins/grilo-plugins/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST grilo-plugins-0.3.0.tar.xz 1032740 SHA256 8e7eafae50f7fdd7eec006ad6d5b9aee888270ff288e6d0bcb14d1c71f0d6fcc SHA512 2c754bd7a0c92648afbeea5a5b785736a17c554935882ada75bea896dae82d1852fbd5c116707d5c75a4e3c15335724af24ba15432a88c61bf80dc992c75b97c WHIRLPOOL 4f65d2ca99ae814a91fabe61bac877e90f8fa7579c7a728b7e7716281e73037a01ee115f9a942adce6fdb617d7b5ea235bd495fdf16f539e171a947dc3c48a5a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQEcBAEBCAAGBQJW9x5CAAoJEOnlaGd+i01C4H0H/03sneGHORNyxY35i1sHPj6y
+xdg8CRnKfM4HWaBH7v4UEwrS+IKC6CE83qxv5RRFCLFIN6tNWkDSnAFlESIZZ8tg
+UCDPx7qib/N6L1//S2TcJflkN8tkfqTXnca2dntnalqHjXFDA3brbdxQir/RKpwz
+C3wGFQ4ImUL9gDigneLyy23XbuhKlnSfCnwTT2TWubL+9WefabowarHs2ts3Hb9m
+1ycpwOiAMLUvMhI93atGRZFrLYM+W4X/wey88Y+qugF5U5OvYQV8QsgS6QDFk0cT
+zgmNT0yp2FNURLtORdYJZPxpJl6voWB8hTnUDs1AxL7TY3jdA9Ze/nHdXanJfPI=
+=qAWv
+-----END PGP SIGNATURE-----
diff --git a/media-plugins/grilo-plugins/grilo-plugins-0.3.0.ebuild b/media-plugins/grilo-plugins/grilo-plugins-0.3.0.ebuild
new file mode 100644
index 00000000..5ff3b3f9
--- /dev/null
+++ b/media-plugins/grilo-plugins/grilo-plugins-0.3.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daap +dvd examples flickr freebox gnome-online-accounts lua subtitles thetvdb tracker upnp-av +vimeo +youtube"
+
+# Bump gom requirement to avoid segfaults
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=media-libs/grilo-0.3.0:${SLOT}[network,playlist]
+ media-libs/libmediaart:2.0
+ >=dev-libs/gom-0.3.1
+
+ dev-libs/gmime:2.6
+ dev-libs/json-glib
+ dev-libs/libxml2:2
+ dev-db/sqlite:3
+
+ daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
+ dvd? ( >=dev-libs/totem-pl-parser-3.4.1 )
+ flickr? ( net-libs/liboauth )
+ freebox? ( net-dns/avahi )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91 )
+ lua? (
+ >=dev-lang/lua-5.3
+ app-arch/libarchive
+ dev-libs/libxml2:2
+ >=dev-libs/totem-pl-parser-3.4.1 )
+ subtitles? ( net-libs/libsoup:2.4 )
+ thetvdb? (
+ app-arch/libarchive
+ dev-libs/libxml2 )
+ tracker? ( >=app-misc/tracker-0.10.5:= )
+ youtube? (
+ >=dev-libs/libgdata-0.9.1:=
+ >=dev-libs/totem-pl-parser-3.4.1 )
+ upnp-av? (
+ net-libs/libsoup:2.4
+ net-libs/dleyna-connector-dbus )
+ vimeo? (
+ >=dev-libs/totem-pl-parser-3.4.1 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_prepare () {
+ sed -e "s:GETTEXT_PACKAGE=grilo-plugins$:GETTEXT_PACKAGE=grilo-plugins-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+}
+
+# FIXME: some unittests required python-dbusmock
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ # Plugins
+ # shoutcast seems to be broken
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ --disable-uninstalled \
+ --enable-bookmarks \
+ --enable-filesystem \
+ --enable-gravatar \
+ --enable-jamendo \
+ --enable-localmetadata \
+ --enable-magnatune \
+ --enable-metadata-store \
+ --enable-podcasts \
+ --enable-raitv \
+ --disable-shoutcast \
+ --enable-tmdb \
+ $(use_enable daap dmap) \
+ $(use_enable dvd optical-media) \
+ $(use_enable flickr) \
+ $(use_enable freebox) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable lua lua-factory) \
+ $(use_enable subtitles opensubtitles) \
+ $(use_enable thetvdb) \
+ $(use_enable tracker) \
+ $(use_enable upnp-av dleyna) \
+ $(use_enable vimeo) \
+ $(use_enable youtube)
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins help/examples/*.c
+ fi
+
+ gnome2_src_install \
+ DOC_MODULE_VERSION=${SLOT%/*} \
+ HELP_ID="grilo-plugins-${SLOT%/*}" \
+ HELP_MEDIA=""
+}
diff --git a/media-plugins/grilo-plugins/metadata.xml b/media-plugins/grilo-plugins/metadata.xml
new file mode 100644
index 00000000..a6af364a
--- /dev/null
+++ b/media-plugins/grilo-plugins/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="daap">Enable dmap support through <pkg>net-libs/libdmapsharing</pkg></flag>
+ <flag name="flickr">Enable Flickr support</flag>
+ <flag name="freebox">Build support for viewing TV channels using Freebox</flag>
+ <flag name="gnome-online-accounts">Enable <pkg>net-libs/gnome-online-accounts</pkg> support</flag>
+ <flag name="pocket">Support for showing content from Pocket</flag>
+ <flag name="subtitles">Enables support for subtitle from OpenSubtitles</flag>
+ <flag name="thetvdb">Build support for thetvdb.com</flag>
+ <flag name="tracker">Build support for content discovery using the <pkg>app-misc/tracker</pkg> indexer</flag>
+ <flag name="vimeo">Build support for Vimeo content discovery using <pkg>net-libs/libsoup</pkg> and <pkg>dev-libs/libgcrypt</pkg></flag>
+ <flag name="youtube">Build support for YouTube content discovery using <pkg>dev-libs/libgdata</pkg></flag>
+</use>
+</pkgmetadata>