summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2016-03-30 20:38:19 +0200
committerOle Reifschneider <tranquility@gentoo.org>2016-03-30 20:38:19 +0200
commitc2ae3ba714ab3e8cb99261db28c9d6d80a440f11 (patch)
tree0943d0e0662cde637758be3c2c52769c802efa02
parentapp-dicts/gnome-dictionary: Bump version to 3.20.0 (diff)
downloadgnome-c2ae3ba7.tar.gz
gnome-c2ae3ba7.tar.bz2
gnome-c2ae3ba7.zip
gnome-extra/gnome-power-manager: Bump version to 3.20.0
Package-Manager: portage-2.2.28 Manifest-Sign-Key: 0xE9E568677E8B4D42
-rw-r--r--gnome-extra/gnome-power-manager/Manifest15
-rw-r--r--gnome-extra/gnome-power-manager/gnome-power-manager-3.20.0.ebuild59
-rw-r--r--gnome-extra/gnome-power-manager/gnome-power-manager-9999.ebuild4
3 files changed, 76 insertions, 2 deletions
diff --git a/gnome-extra/gnome-power-manager/Manifest b/gnome-extra/gnome-power-manager/Manifest
new file mode 100644
index 00000000..b3a2a2c8
--- /dev/null
+++ b/gnome-extra/gnome-power-manager/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST gnome-power-manager-3.20.0.tar.xz 436464 SHA256 159c23a6ed5ffd54324947adb2a32caff6d6e2210f96bdf3961edfcad8058a47 SHA512 4b0a735b64e0c8834fe5ef5d5fbe1feb00dbe0d46b6efb97d6ca8fe394f8436cdd26fc4d655e0b983ac85110404ed46657b357ee6ec733a7c821a51b05419c19 WHIRLPOOL d23db7b0ad7567e380c979d74d3f6feda96bc3e12c256d9c4d2f88a888d7f722ad5b879912e45c68b03f58ce4cc239c7b604d191813697f96d4d202dc9b911ed
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQEcBAEBCAAGBQJW/B0bAAoJEOnlaGd+i01C6aEIAJSjaX57hHoBzmk3UEvXYYNU
+zQgLN4rIXX6vTv26KOyb2f8TUNRR6DjZ+BCrNSRq7Vy6fLzzDCfhAGR18IBp0Zal
+joPSbuHCQd59TPAuvOnkwALPK5Og7pewmnOwLldm7wT5Kaz2+XtGTnXjKpISavGs
+vmhhTpq4uAotqi+41jQEu6PGnYP5IyJ4Ff40kE0nUxMbNEzzlNVAcir4nGvPrmHa
+R4jLVpyktl2oKXLR3Qni0e0iZWn/wG4iwCG3voGzAc6GpBrU150Kwls7pjS86TRu
+5c0MgfL4P5tEAeoTF0gq+7UHGSq3s0OdxS8LzmnRxEqNvgLBG0rgrUaqTQaOjZ8=
+=Tj0B
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-power-manager/gnome-power-manager-3.20.0.ebuild b/gnome-extra/gnome-power-manager/gnome-power-manager-3.20.0.ebuild
new file mode 100644
index 00000000..b1599823
--- /dev/null
+++ b/gnome-extra/gnome-power-manager/gnome-power-manager-3.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="GNOME power management service"
+HOMEPAGE="https://projects.gnome.org/gnome-power-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.45.8:2
+ >=x11-libs/gtk+-3.3.8:3
+ >=x11-libs/cairo-1
+ >=sys-power/upower-0.99:=
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ x11-proto/randrproto
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+# docbook-sgml-utils and docbook-sgml-dtd-4.1 used for creating man pages
+# (files under ${S}/man).
+# docbook-xml-dtd-4.4 and -4.1.2 are used by the xml files under ${S}/docs.
+
+src_prepare() {
+ # Drop debugger CFLAGS from configure
+ # Touch configure.ac only if running eautoreconf, otherwise
+ # maintainer mode gets triggered -- even if the order is correct
+ sed -e 's:^CPPFLAGS="$CPPFLAGS -g"$::g' \
+ -i configure || die "debugger sed failed"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
diff --git a/gnome-extra/gnome-power-manager/gnome-power-manager-9999.ebuild b/gnome-extra/gnome-power-manager/gnome-power-manager-9999.ebuild
index 4463f923..69adee7c 100644
--- a/gnome-extra/gnome-power-manager/gnome-power-manager-9999.ebuild
+++ b/gnome-extra/gnome-power-manager/gnome-power-manager-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,7 +23,7 @@ else
fi
COMMON_DEPEND="
- >=dev-libs/glib-2.36:2
+ >=dev-libs/glib-2.45.8:2
>=x11-libs/gtk+-3.3.8:3
>=x11-libs/cairo-1
>=sys-power/upower-0.99:=