summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-25 15:42:18 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-25 15:42:18 +0100
commitf15a11a81963166b85224a77685ed5ba6d391639 (patch)
treef20cc895aa86067e8af8c1aecc51b6d21b7218b0
parentFix typo that triggered a command not found error (diff)
downloadgnome-f15a11a8.tar.gz
gnome-f15a11a8.tar.bz2
gnome-f15a11a8.zip
games-board/aisleriot: version bump to 3.18.2
Package-Manager: portage-2.2.25 RepoMan-Options: --force Manifest-Sign-Key: C6085806
-rw-r--r--games-board/aisleriot/Manifest9
-rw-r--r--games-board/aisleriot/aisleriot-3.18.2.ebuild89
2 files changed, 94 insertions, 4 deletions
diff --git a/games-board/aisleriot/Manifest b/games-board/aisleriot/Manifest
index 33a28d17..ab716c28 100644
--- a/games-board/aisleriot/Manifest
+++ b/games-board/aisleriot/Manifest
@@ -1,11 +1,12 @@
-----BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
+Hash: SHA256
DIST aisleriot-3.16.2.tar.xz 6253372 SHA256 f483fd743734575dc5ab053702d78c3521ccd5c2e5701f4e9af1681fc46bcc66 SHA512 36c82f83b2edd3c877d1d5b4d2a3cb7b4a0c9bed7e449940df45b66dbede8add8a83f058e628bf5d10c20b81082596aca6aa170797de89149077284d45299ee3 WHIRLPOOL 7e96fec6ed18509adddfe668446c6bc10396695abfb45dc42141f4ba9bf156db899e346f61903654226a7ad0072b2fb6af13bb57904da9c25c63772277b2204c
+DIST aisleriot-3.18.2.tar.xz 6322512 SHA256 0bac8ba11ce37e4e7beddcd173f55ac1630a425399cfabb57e0e500886642fe3 SHA512 28623883e3e11a206b8be52a8b52376ebd3af5bf288cd2bac13d0bee25f4df68cca09667bc4e2f366048d6d7e88f65fa2637f4534a1f45b4ea5d45a98cb7ab50 WHIRLPOOL 25f90e5840c828b496c67f39e607ff1c798a0dbdb9983dac87f9f83c8dbf3b354571d4515182151e47f374e1d29aed68a460279d9e6fb8f20478e569214e1c9b
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
-iEYEAREKAAYFAlVP2yoACgkQ1fmVwcYIWAa6fgCg39GiuqADAv56b6vPEJyupPJO
-lUMAn0zPjCHM4DgXqrzUjS2QZLssO8lX
-=ulQT
+iEYEAREIAAYFAlZVyMoACgkQ1fmVwcYIWAYK+wCgxpd2NAbTAB8cNqUqb9wb5eUT
+0ZEAn0n/jKPaz3cJRKL8WLKIy09Xbyt1
+=riF4
-----END PGP SIGNATURE-----
diff --git a/games-board/aisleriot/aisleriot-3.18.2.ebuild b/games-board/aisleriot/aisleriot-3.18.2.ebuild
new file mode 100644
index 00000000..e7535d47
--- /dev/null
+++ b/games-board/aisleriot/aisleriot-3.18.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome-games
+
+DESCRIPTION="A collection of solitaire card games for GNOME"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Aisleriot"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome qt4"
+
+# FIXME: quartz support?
+# Does not build with guile-2.0.0 or 2.0.1
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-scheme/guile-2.0.5:2[deprecated,regex]
+ >=gnome-base/librsvg-2.32:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/cairo-1.10
+ >=x11-libs/gtk+-3.4:3
+ gnome? ( >=gnome-base/gconf-2.0:2 )
+ qt4? ( >=dev-qt/qtsvg-4.4:4 )
+"
+DEPEND="${COMMON_DEPEND}
+ app-arch/gzip
+ dev-libs/libxml2
+ >=dev-util/intltool-0.40.4
+ dev-util/itstool
+ sys-apps/lsb-release
+ >=sys-devel/gettext-0.12
+ virtual/pkgconfig
+ gnome? ( app-text/docbook-xml-dtd:4.3 )
+"
+# dev-util/itstool really needed for help file generation
+# >=app-text/yelp-tools-3.1.1
+
+src_prepare() {
+ # Fix SVG detection and usage
+ epatch "${FILESDIR}"/${PN}-3.16.2-detect-svg.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=()
+
+ if use gnome; then
+ myconf+=(
+ --with-platform=gnome
+ --with-help-method=ghelp
+ )
+ else
+ myconf+=(
+ --with-platform=gtk-only
+ --with-help-method=library
+ )
+ fi
+
+ if use qt4 ; then
+ myconf+=(
+ --with-card-theme-formats=all
+ --with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
+ )
+ else
+ myconf+=( --with-card-theme-formats=svg,fixed,pysol )
+ fi
+
+ gnome2_src_configure \
+ --with-gtk=3.0 \
+ --with-guile=2.0 \
+ --enable-sound \
+ --with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc \
+ GUILE=$(type -P guile-2.0) \
+ ${myconf[@]}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Aisleriot can use additional card themes from games-board/pysolfc"
+ elog "and kde-base/libkdegames."
+}