summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-11-02 18:27:15 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2014-11-02 18:27:15 +0100
commitfac1a238edb6e28d484a3d55c0f59dc973e0f262 (patch)
tree8c26146b013f58e36a534b33551286e6d9f1bd25
parentnet-libs/webkit-gtk: tune pax-marking (diff)
downloadgnome-fac1a238edb6e28d484a3d55c0f59dc973e0f262.tar.gz
gnome-fac1a238edb6e28d484a3d55c0f59dc973e0f262.tar.bz2
gnome-fac1a238edb6e28d484a3d55c0f59dc973e0f262.zip
net-libs/webkit-gtk: 2.6.1 → 2.6.2
Do some ebuild cleanup as suggested by Pacho.
-rw-r--r--net-libs/webkit-gtk/Manifest7
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.6.2.ebuild (renamed from net-libs/webkit-gtk/webkit-gtk-2.6.1.ebuild)38
2 files changed, 5 insertions, 40 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index 441b2ad4..33d324f3 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -2,10 +2,11 @@
Hash: SHA512
DIST webkitgtk-2.6.1.tar.xz 9990248 SHA256 c846a662762dd79c26e77fa36348e706d217d1385bb2dbdcfc28a5a1476c6d54 SHA512 cc5d0f8d46387769d4313f434a3dffb098769b762d0bf33cda2db1bbcf17776ecfe009b43fd5cf696e9f7903326ef4488d9f227e6cb889b2642bb0bc2662aaba WHIRLPOOL 6e71ff8e62337b2c962dc453519c39ea0306a56f3f39bb104bb675003f3b808744d2ce924146b69a10ef5e29b55dd7f3c4435d8c0d028b733c3f79435bb4a26d
+DIST webkitgtk-2.6.2.tar.xz 9992484 SHA256 5172e9b6b65b3de3cc25bffbe109249ac79b9256d57f6a331455ae1a5ea938b9 SHA512 54872feea7786634c50e3f771bd9b42ee3360012babc9d3ae25a8db95533c5acf708c9bb9a3145140d7345363b6899588aec3fe8224a562a2fabbb974d3a16dd WHIRLPOOL 2b9bad47e5b7b29da5899369465b589765aeda47e4ced5613fe83f8c0d7f60ad31190c4c3d78a769aff1a3b0297178f8d12cc7702d4d33de3c5bcd7b582f0314
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
-iEYEAREKAAYFAlRD+rMACgkQ1fmVwcYIWAZq0gCeL+jMjsToGV09gXngEZM3+r1A
-VWQAn2Oti4h9Cm7wAX8dblgwWHPLqosw
-=nnt8
+iEYEAREKAAYFAlRWaXQACgkQ1fmVwcYIWAZLygCfa+qXr80TH4tBFkBVlGTk1qaa
+0u8AoNvKxzbm9rcNr8bNPH3TdZxW9x8u
+=XUW+
-----END PGP SIGNATURE-----
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.6.1.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.6.2.ebuild
index f5096257..7ecc3972 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.6.1.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.6.2.ebuild
@@ -103,8 +103,6 @@ S="${WORKDIR}/${MY_P}"
CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
pkg_pretend() {
- nvidia_check || die #463960
-
if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
check-reqs_pkg_pretend
@@ -116,24 +114,7 @@ pkg_pretend() {
}
pkg_setup() {
- nvidia_check || die #463960
-
- # Check whether any of the debugging flags is enabled
- if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
- if is-flagq "-ggdb" && [[ ${WEBKIT_GTK_GGDB} != "yes" ]]; then
- replace-flags -ggdb -g
- ewarn "Replacing \"-ggdb\" with \"-g\" in your CFLAGS."
- ewarn "Building ${PN} with \"-ggdb\" produces binaries which are too"
- ewarn "large for current binutils releases (bug #432784) and has very"
- ewarn "high temporary build space and memory requirements."
- ewarn "If you really want to build ${PN} with \"-ggdb\", add"
- ewarn "WEBKIT_GTK_GGDB=yes"
- ewarn "to your make.conf file."
- fi
- einfo "You need to have at least 18GB of temporary build space available"
- einfo "to build ${PN} with debugging CFLAGS. Note that it might still"
- einfo "not be enough, as the total space requirements depend on the flags"
- einfo "(-ggdb vs -g1) and enabled features."
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
check-reqs_pkg_setup
fi
@@ -234,20 +215,3 @@ src_install() {
use jit && pax-mark m "${ED}usr/bin/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"{,2}
}
-
-nvidia_check() {
- if [[ ${MERGE_TYPE} != "binary" ]] &&
- use introspection &&
- has_version '=x11-drivers/nvidia-drivers-325*' &&
- [[ $(eselect opengl show 2> /dev/null) = "nvidia" ]]
- then
- eerror "${PN} freezes while compiling if x11-drivers/nvidia-drivers-325.* is"
- eerror "used as the system OpenGL library."
- eerror "You can either update to >=nvidia-drivers-331.13, or temporarily select"
- eerror "Mesa as the system OpenGL library:"
- eerror " # eselect opengl set xorg-x11"
- eerror "See https://bugs.gentoo.org/463960 for more details."
- eerror
- return 1
- fi
-}