summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-03 19:44:24 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-03 20:11:33 +0200
commit03c0abf5948a4db374baf80543625308aaebda3a (patch)
tree43e9eb8fdaf2238e40c79819889be264ac4839e8 /app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
parentgames-puzzle/swell-foop: 3.14.0 → 3.16.1 (diff)
downloadgnome-03c0abf5948a4db374baf80543625308aaebda3a.tar.gz
gnome-03c0abf5948a4db374baf80543625308aaebda3a.tar.bz2
gnome-03c0abf5948a4db374baf80543625308aaebda3a.zip
app-dicts/gnome-dictionary: 3.14.2 → 3.16.1
Diffstat (limited to 'app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild')
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
index 0f959819..29f239d7 100644
--- a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
inherit gnome2
if [[ ${PV} = 9999 ]]; then
@@ -15,8 +14,8 @@ DESCRIPTION="Dictionary utility for GNOME"
HOMEPAGE="https://live.gnome.org/GnomeUtils"
LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
-SLOT="0/6" # subslot = suffix of libgdict-1.0.so
-IUSE="ipv6"
+SLOT="0/8" # subslot = suffix of libgdict-1.0.so
+IUSE="+introspection ipv6"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
KEYWORDS=""
@@ -27,8 +26,9 @@ fi
COMMON_DEPEND="
>=dev-libs/glib-2.39:2
x11-libs/cairo:=
- >=x11-libs/gtk+-3:3
+ >=x11-libs/gtk+-3.14:3
x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
"
RDEPEND="${COMMON_DEPEND}
gnome-base/gsettings-desktop-schemas
@@ -52,6 +52,7 @@ src_configure() {
local myconf=""
[[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
gnome2_src_configure \
+ $(use_enable introspection) \
$(use_enable ipv6) \
${myconf}
}