summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-28 18:00:54 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-28 18:28:57 +0100
commit30aec2778140623149d851937e0a15423d150b01 (patch)
treec91078886bbef21a09df072cba8a5228f12158a6 /app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
parentgnome-base/gnome-desktop: 3.6.0.1 → 3.6.1 (diff)
downloadgnome-30aec2778140623149d851937e0a15423d150b01.tar.gz
gnome-30aec2778140623149d851937e0a15423d150b01.tar.bz2
gnome-30aec2778140623149d851937e0a15423d150b01.zip
app-dicts/gnome-dictionary: 3.4.0 → 3.6.0
Diffstat (limited to 'app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild')
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
index a8956e21..462ea905 100644
--- a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -3,6 +3,7 @@
# $Header: $
EAPI="4"
+GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
inherit gnome2
@@ -15,31 +16,42 @@ HOMEPAGE="https://live.gnome.org/GnomeUtils"
LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
SLOT="0"
-IUSE="doc ipv6"
+IUSE="ipv6"
if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
KEYWORDS=""
else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
fi
-COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28.0:2
x11-libs/cairo
>=x11-libs/gtk+-3.0.0:3
- x11-libs/pango"
+ x11-libs/pango
+"
RDEPEND="${COMMON_DEPEND}
gnome-base/gsettings-desktop-schemas
- !<gnome-extra/gnome-utils-3.4"
+ !<gnome-extra/gnome-utils-3.4
+"
# ${PN} was part of gnome-utils before 3.4
DEPEND="${COMMON_DEPEND}
- app-text/gnome-doc-utils
+ app-text/yelp-tools
+ >=dev-util/gtk-doc-am-1.15
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.15 )"
+"
-pkg_setup() {
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+fi
+
+src_configure() {
DOCS="AUTHORS NEWS README TODO"
G2CONF="${G2CONF}
--disable-schemas-compile
$(use_enable ipv6)"
+ gnome2_src_configure
}