summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-04-20 06:12:56 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-04-20 06:12:56 +0530
commit42ab97ce1842e469a0588c0b2e45a24f32429418 (patch)
tree7dcdc3210739ea207cbae73f635ad0a20a817093 /app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
parentdev-libs/gobject-introspection: moved to gx86 + sync 9999 with gx86 (diff)
downloadgnome-42ab97ce1842e469a0588c0b2e45a24f32429418.tar.gz
gnome-42ab97ce1842e469a0588c0b2e45a24f32429418.tar.bz2
gnome-42ab97ce1842e469a0588c0b2e45a24f32429418.zip
gnome-extra/gnome-utils: add all the new split packages as new ebuilds
Diffstat (limited to 'app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild')
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
new file mode 100644
index 00000000..cb23e8db
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-utils/gnome-utils-2.32.0-r1.ebuild,v 1.1 2010/12/04 18:08:10 pacho Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Dictionary utility for GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+SLOT="0"
+IUSE="doc ipv6"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.22
+ >=sys-devel/gettext-0.17
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README TODO"
+ G2CONF="--disable-schemas-compile
+ $(use_enable ipv6)"
+}