summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 11:43:28 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-10-13 12:03:58 +0200
commit59ee6d012e2ef13ee9062e47b628541ecc7559a0 (patch)
treed9a434408a2caa30de7c5c0c43390990898a56f9 /app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
parentnet-misc/rygel: 0.18.4 → 0.20.0 (diff)
downloadgnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.tar.gz
gnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.tar.bz2
gnome-59ee6d012e2ef13ee9062e47b628541ecc7559a0.zip
app-dicts/gnome-dictionary: 3.8.0 → 3.10.0
Diffstat (limited to 'app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild')
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
index f56df823..3bf42a3e 100644
--- a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
@@ -11,11 +11,11 @@ if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
-DESCRIPTION="Dictionary utility for GNOME 3"
+DESCRIPTION="Dictionary utility for GNOME"
HOMEPAGE="https://live.gnome.org/GnomeUtils"
-LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
-SLOT="0"
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/6" # subslot = suffix of libgdict-1.0.so
IUSE="ipv6"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
@@ -26,7 +26,7 @@ fi
COMMON_DEPEND="
>=dev-libs/glib-2.28:2
- x11-libs/cairo
+ x11-libs/cairo:=
>=x11-libs/gtk+-3:3
x11-libs/pango
"
@@ -49,8 +49,9 @@ if [[ ${PV} = 9999 ]]; then
fi
src_configure() {
- DOCS="AUTHORS NEWS README TODO"
- G2CONF="${G2CONF} $(use_enable ipv6)"
- [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
- gnome2_src_configure
+ local myconf=""
+ [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
+ gnome2_src_configure \
+ $(use_enable ipv6) \
+ ${myconf}
}