summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-09 01:07:09 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-10 17:15:17 +0200
commit16933bf82a1251c0946dfcfb5466935df7017b51 (patch)
treeceab0322278500a5d819277a719266a27541c6a4 /app-misc/gnote
parentapp-misc/bijiben: 3.14.2 → 3.16.1 (diff)
downloadgnome-16933bf82a1251c0946dfcfb5466935df7017b51.tar.gz
gnome-16933bf82a1251c0946dfcfb5466935df7017b51.tar.bz2
gnome-16933bf82a1251c0946dfcfb5466935df7017b51.zip
app-misc/gnote: 3.14.2 → 3.16.0
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest11
-rw-r--r--app-misc/gnote/gnote-3.16.0.ebuild73
-rw-r--r--app-misc/gnote/gnote-9999.ebuild2
3 files changed, 85 insertions, 1 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
new file mode 100644
index 00000000..1d729844
--- /dev/null
+++ b/app-misc/gnote/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnote-3.16.0.tar.xz 3058228 SHA256 acad6b711a0aa41397aa35f4eda2d44dcecd57d6a17adcb8d1d7db4018c5e2fb SHA512 f52ac2e56b73881f7809654762fdb90a3a4b5935e07430ca60a4a84a4e9c78174b4ba411bae2a9379719be0505454e27d6bea938a2f53b07fdfd98685838da99 WHIRLPOOL d2e50e1809cfd115bbce497d9e1fe06c78c715dfc9b98a4e093157958b545be0e5b3f6ebae79b61d44378e53ece6dab8f9eb9ba930bbe4ce6bd8e4d328e954f7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVNQZ4ACgkQ1fmVwcYIWAbicgCfZjpPHIh28YLi2MOWuD+5hYfo
+hkcAoLORVpWfcmYJWenZ3S+/x0QAhFzy
+=bK1x
+-----END PGP SIGNATURE-----
diff --git a/app-misc/gnote/gnote-3.16.0.ebuild b/app-misc/gnote/gnote-3.16.0.ebuild
new file mode 100644
index 00000000..3646dea2
--- /dev/null
+++ b/app-misc/gnote/gnote-3.16.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug X"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.10:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.10:3
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with X x11-support) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-misc/gnote/gnote-9999.ebuild b/app-misc/gnote/gnote-9999.ebuild
index dcce87e3..05640a18 100644
--- a/app-misc/gnote/gnote-9999.ebuild
+++ b/app-misc/gnote/gnote-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $