summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gmail.com>2011-09-27 04:08:58 -0400
committerAlexandre Rostovtsev <tetromino@gmail.com>2011-09-28 03:03:17 -0400
commit17a0f8dbbe46db716620c4ba3d1959cd015d6af0 (patch)
treef07e8d8a1fc0624519696efec3ab16badae6a852 /app-misc/gnote
parentgnome2-live.eclass: use GNOME_ORG_MODULE for git URI, port to use eclass doc (diff)
downloadgnome-17a0f8dbbe46db716620c4ba3d1959cd015d6af0.tar.gz
gnome-17a0f8dbbe46db716620c4ba3d1959cd015d6af0.tar.bz2
gnome-17a0f8dbbe46db716620c4ba3d1959cd015d6af0.zip
app-misc/gnote: add 0.8.0
Add the gnome-3.2, gtk3-based version of gnote.
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest3
-rw-r--r--app-misc/gnote/gnote-0.8.0.ebuild55
-rw-r--r--app-misc/gnote/gnote-9999.ebuild55
3 files changed, 113 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
new file mode 100644
index 00000000..3f681c5a
--- /dev/null
+++ b/app-misc/gnote/Manifest
@@ -0,0 +1,3 @@
+DIST gnote-0.8.0.tar.xz 1500008 RMD160 1da915ad525e62dccd5f6c25d04ce934b4bcfc7f SHA1 ab838a97120a9761f8d52dde0c1017bc973cd58b SHA256 f009852b264fb8754575524ef2937147c4d2c25eff97ecca507624ca8730c213
+EBUILD gnote-0.8.0.ebuild 1248 RMD160 ff768a37f2cba256a092b151b84f097d74437742 SHA1 362319264a6d0a662c9135694d0923981e9a8a2e SHA256 7dd35e8ea961f7a9e98ea56d676bf4e98e39f6c67266e5b20a6f6a1deb22767f
+EBUILD gnote-9999.ebuild 1248 RMD160 ff768a37f2cba256a092b151b84f097d74437742 SHA1 362319264a6d0a662c9135694d0923981e9a8a2e SHA256 7dd35e8ea961f7a9e98ea56d676bf4e98e39f6c67266e5b20a6f6a1deb22767f
diff --git a/app-misc/gnote/gnote-0.8.0.ebuild b/app-misc/gnote/gnote-0.8.0.ebuild
new file mode 100644
index 00000000..aaffb3ee
--- /dev/null
+++ b/app-misc/gnote/gnote-0.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.4.ebuild,v 1.1 2011/05/02 21:02:38 eva Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="applet debug"
+
+RDEPEND=">=x11-libs/gtk+-3.0:3
+ >=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=dev-libs/libpcre-7.8:3[cxx]
+ >=dev-libs/boost-1.34
+ >=sys-apps/util-linux-2.16
+ applet? ( >=gnome-base/gnome-panel-3 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable applet)
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not set idiotic defines in a released tarball, bug #311979
+ sed 's/-DG.*_DISABLE_DEPRECATED//g' -i libtomboy/Makefile.* ||
+ die "sed failed"
+}
diff --git a/app-misc/gnote/gnote-9999.ebuild b/app-misc/gnote/gnote-9999.ebuild
new file mode 100644
index 00000000..aaffb3ee
--- /dev/null
+++ b/app-misc/gnote/gnote-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.4.ebuild,v 1.1 2011/05/02 21:02:38 eva Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="applet debug"
+
+RDEPEND=">=x11-libs/gtk+-3.0:3
+ >=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=dev-libs/libpcre-7.8:3[cxx]
+ >=dev-libs/boost-1.34
+ >=sys-apps/util-linux-2.16
+ applet? ( >=gnome-base/gnome-panel-3 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable applet)
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not set idiotic defines in a released tarball, bug #311979
+ sed 's/-DG.*_DISABLE_DEPRECATED//g' -i libtomboy/Makefile.* ||
+ die "sed failed"
+}