summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 19:46:24 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-06 19:51:54 +0200
commit47acbc8cf1c708867b5123dfb85572f1af198f42 (patch)
tree66ccf8f2522c723de6d27c4143999ff35d6933ba /app-misc/gnote
parentmedia-sound/sound-juicer: 3.5.1_pre20130826 → 3.11.90 (diff)
downloadgnome-47acbc8cf1c708867b5123dfb85572f1af198f42.tar.gz
gnome-47acbc8cf1c708867b5123dfb85572f1af198f42.tar.bz2
gnome-47acbc8cf1c708867b5123dfb85572f1af198f42.zip
app-misc/gnote: 3.10.3 → 3.12.0
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest11
-rw-r--r--app-misc/gnote/gnote-3.12.0.ebuild73
-rw-r--r--app-misc/gnote/gnote-9999.ebuild6
3 files changed, 87 insertions, 3 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
new file mode 100644
index 00000000..f6a60832
--- /dev/null
+++ b/app-misc/gnote/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnote-3.12.0.tar.xz 3078416 SHA256 b76e13e6793d3e73adafaca20063ba9fea23dae67022597c69c81c1f61842d6c SHA512 558aedcaab4874208ee7aca0fa01124b1bb4bbdb43cb0e39e9b434381441a0c38c909fb7a186805ee98c2f59c107c709d6dea34e02e7493c069f9c29e733168e WHIRLPOOL ae22f3e29f975073b5a03abf7b94928df6c971423a8b0269d6c76e2c1507b9f4259ea73e2ae3be9830e86ca1e5583ef5a42f667606693fedfd6c10bcc186325b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNBkvAACgkQ1fmVwcYIWAbjBACeKgT8bwFPeVC4FQhUVTtc/7YZ
+6/MAn3NbAPX2fH/unadC/9XGnBDywzhA
+=iXSs
+-----END PGP SIGNATURE-----
diff --git a/app-misc/gnote/gnote-3.12.0.ebuild b/app-misc/gnote/gnote-3.12.0.ebuild
new file mode 100644
index 00000000..255aab64
--- /dev/null
+++ b/app-misc/gnote/gnote-3.12.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +X"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.10:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.10:3
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with X x11-support) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-misc/gnote/gnote-9999.ebuild b/app-misc/gnote/gnote-9999.ebuild
index 23511a33..a30ffcf2 100644
--- a/app-misc/gnote/gnote-9999.ebuild
+++ b/app-misc/gnote/gnote-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999 ]]; then
fi
DESCRIPTION="Desktop note-taking application"
-HOMEPAGE="http://live.gnome.org/Gnote"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
LICENSE="GPL-3+ FDL-1.1"
SLOT="0"
@@ -27,13 +27,13 @@ COMMON_DEPEND="
>=app-crypt/libsecret-0.8
>=app-text/gtkspell-3.0:3
>=dev-cpp/glibmm-2.32:2
- >=dev-cpp/gtkmm-3.6:3.0
+ >=dev-cpp/gtkmm-3.10:3.0
>=dev-libs/boost-1.34
>=dev-libs/glib-2.32:2
>=dev-libs/libxml2-2:2
dev-libs/libxslt
>=sys-apps/util-linux-2.16:=
- >=x11-libs/gtk+-3.6:3
+ >=x11-libs/gtk+-3.10:3
X? ( x11-libs/libX11 )
"
RDEPEND="${COMMON_DEPEND}