summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-10 01:08:07 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-10 01:12:00 +0200
commit878f1870473a94c5cbe3f0bbf1acaf31b42aa549 (patch)
treeef06f35c7043377d0c86e6a8e523180ff17dff4d /app-misc/gnote
parentMerge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/gnome (diff)
downloadgnome-878f1870473a94c5cbe3f0bbf1acaf31b42aa549.tar.gz
gnome-878f1870473a94c5cbe3f0bbf1acaf31b42aa549.tar.bz2
gnome-878f1870473a94c5cbe3f0bbf1acaf31b42aa549.zip
app-misc/gnote: initial ebuild
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-0.1.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
new file mode 100644
index 00000000..21e44d47
--- /dev/null
+++ b/app-misc/gnote/Manifest
@@ -0,0 +1,2 @@
+DIST gnote-0.1.1.tar.bz2 471549 RMD160 9b462a97efc0548b47a0884701ecdd5cb9b122ed SHA1 1624322ae3d07e0b6db3c09e4309927dedc3fe5b SHA256 bd723b3ab1c025b054f8944a91ebdd1c9da9dce7f4715389fb2679a90bf2644f
+EBUILD gnote-0.1.1.ebuild 839 RMD160 5e8f7cb5a641898b65ad6d1a4e9c9eae998798e5 SHA1 a3e582f4e2b2826d48fec9f1dbd2ef5f5803225d SHA256 253fc2c0a3c0cc60b250bf1747d7b92cfcf224c63c7c6fa650412cccd1f58b20
diff --git a/app-misc/gnote/gnote-0.1.1.ebuild b/app-misc/gnote/gnote-0.1.1.ebuild
new file mode 100644
index 00000000..a97cd2d6
--- /dev/null
+++ b/app-misc/gnote/gnote-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug" # dbus
+
+RDEPEND=">=dev-cpp/glibmm-2
+ >=dev-cpp/gtkmm-2.12
+ >=dev-cpp/libxmlpp-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=app-text/gtkspell-2.0.9
+ >=dev-libs/boost-1.34
+ sys-libs/e2fsprogs-libs
+ >=gnome-base/gnome-panel-2"
+# Build with dbus is currently broken
+# dbus? ( >=dev-libs/dbus-glib-0.70 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dbus
+ $(use_enable debug)"
+
+ # Because boost macros sucks
+ filter-ldflags -Wl,--as-needed
+}