summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 01:16:57 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-10-13 01:39:02 +0200
commita10aefcad5bdfa77aab2c49048e21c04791b24b4 (patch)
treed3d377a4fefdf3b819ee4730b5a2e54e7d2b0e8c /app-misc/gnote
parentmedia-gfx/gnome-screenshot: 3.8.3 → 3.10.0 (diff)
downloadgnome-a10aefcad5bdfa77aab2c49048e21c04791b24b4.tar.gz
gnome-a10aefcad5bdfa77aab2c49048e21c04791b24b4.tar.bz2
gnome-a10aefcad5bdfa77aab2c49048e21c04791b24b4.zip
app-misc/gnote: 3.9.2 → 3.10.0
Enable X use flag by default, disabling it only makes sens for wayland setups but X11 is the most common setup.
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest12
-rw-r--r--app-misc/gnote/gnote-3.10.0.ebuild (renamed from app-misc/gnote/gnote-3.9.2.ebuild)18
-rw-r--r--app-misc/gnote/gnote-9999.ebuild7
3 files changed, 18 insertions, 19 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index c4a356f4..998e04af 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,11 @@
-DIST gnote-3.9.2.tar.xz 2711840 SHA256 6eebb2b9ab81a360d41ff400630685bdf2330f1b2f228ca860613b81a3d5eb75 SHA512 738028f2a342a97b9ab47fbf5dbfae72c99d5e4681aa2bd7d85d0f0431e5fde764c36341cd279d7b1e31465a7da87f90f66f83839a83b55a0344697cd6a29eb4 WHIRLPOOL 3fa81201de7513ec830e50b30fd471af69da3b4c654d1e8dd141609ee725f00718d6b437051ebd200883a83161098f5c196565020521f35633cabfe29b7a25ff
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnote-3.10.0.tar.xz 3037640 SHA256 10dedfde2f7748f67eda4f334505c7e8ff2b86286d2c9feb3c43e7261684b71b SHA512 342abd72f392b47600891d0908d5e8a62e7aace623fa33863fab0b670b08678e25e801475253ec16f14eb939ee8dead3cfe322f02ac1692d2447612edb0ef1f7 WHIRLPOOL 5bea372a5c42068279105367abcdba3c99ca633098d02f4fb1b1c5ef385735fbcaa11c0a1e8d42f9f7ad71783f5cbee346c66d5b4ce9748c1b318bf2e5e25655
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlJZ2GkACgkQ1fmVwcYIWAZEkwCg8CziS8V6M0x3JmOtFiuLhcW2
+gZ8AoM5UL3jk5Ima2l8YLFQTq+LUedFb
+=EaH6
+-----END PGP SIGNATURE-----
diff --git a/app-misc/gnote/gnote-3.9.2.ebuild b/app-misc/gnote/gnote-3.10.0.ebuild
index a2abc5a8..28a5e5ce 100644
--- a/app-misc/gnote/gnote-3.9.2.ebuild
+++ b/app-misc/gnote/gnote-3.10.0.ebuild
@@ -6,21 +6,14 @@ EAPI="5"
GCONF_DEBUG="no"
inherit gnome2 readme.gentoo
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
DESCRIPTION="Desktop note-taking application"
HOMEPAGE="http://live.gnome.org/Gnote"
LICENSE="GPL-3+ FDL-1.1"
SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="debug X"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +X"
# Automagic glib-2.32 dep
COMMON_DEPEND="
@@ -45,10 +38,6 @@ DEPEND="${DEPEND}
>=dev-util/intltool-0.35.0
virtual/pkgconfig
"
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools"
-fi
src_prepare() {
# Do not alter CFLAGS
@@ -66,12 +55,11 @@ src_prepare() {
}
src_configure() {
- [[ ${PV} != 9999 ]] && G2CONF="ITSTOOL=$(type -P true)"
gnome2_src_configure \
--disable-static \
$(use_enable debug) \
$(use_with X x11-support) \
- $G2CONF
+ ITSTOOL=$(type -P true)
}
src_install() {
diff --git a/app-misc/gnote/gnote-9999.ebuild b/app-misc/gnote/gnote-9999.ebuild
index a2abc5a8..23511a33 100644
--- a/app-misc/gnote/gnote-9999.ebuild
+++ b/app-misc/gnote/gnote-9999.ebuild
@@ -20,7 +20,7 @@ if [[ ${PV} = 9999 ]]; then
else
KEYWORDS="~amd64 ~x86"
fi
-IUSE="debug X"
+IUSE="debug +X"
# Automagic glib-2.32 dep
COMMON_DEPEND="
@@ -66,12 +66,13 @@ src_prepare() {
}
src_configure() {
- [[ ${PV} != 9999 ]] && G2CONF="ITSTOOL=$(type -P true)"
+ local myconf=""
+ [[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
gnome2_src_configure \
--disable-static \
$(use_enable debug) \
$(use_with X x11-support) \
- $G2CONF
+ ${myconf}
}
src_install() {