summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-18 23:14:11 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-18 23:49:06 +0100
commit599ae83bd7270aa58624c2cff9c20997b99dbe14 (patch)
tree95791d67ec812739845de88eb4c34e47a9b44497 /app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild
parentx11-libs/gtk+: Fix build with USE="wayland" (diff)
downloadgnome-599ae83bd7270aa58624c2cff9c20997b99dbe14.tar.gz
gnome-599ae83bd7270aa58624c2cff9c20997b99dbe14.tar.bz2
gnome-599ae83bd7270aa58624c2cff9c20997b99dbe14.zip
app-mobilephone/gnome-phone-manager: sync with gentoo-x86
Diffstat (limited to 'app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild')
-rw-r--r--app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild35
1 files changed, 16 insertions, 19 deletions
diff --git a/app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild
index 338f1290..693c7121 100644
--- a/app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild
+++ b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -12,33 +12,31 @@ if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
-DESCRIPTION="A program created to allow you to control aspects of your mobile phone from your GNOME 2 desktop"
+DESCRIPTION="A program created to allow you to control aspects of your mobile phone from your GNOME desktop"
HOMEPAGE="http://live.gnome.org/PhoneManager"
LICENSE="GPL-2"
SLOT="0"
-# XXX: telepathy support is considered experimental
-IUSE="telepathy"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~ppc ~x86"
fi
+IUSE="gnome"
+# telepathy support is considered experimental
RDEPEND="
>=app-mobilephone/gnokii-0.6.28[bluetooth]
- >=dev-libs/glib-2.25:2
- >=gnome-base/gconf-2:2
- >=gnome-base/orbit-2
- >=gnome-extra/evolution-data-server-3.6
- >=net-wireless/gnome-bluetooth-3:2
- >=x11-libs/gtk+-3:3
- >=x11-themes/gnome-icon-theme-2.19.1
dev-libs/dbus-glib
+ >=dev-libs/glib-2.31:2
dev-libs/openobex
+ >=gnome-base/gconf-2:2
+ >=gnome-extra/evolution-data-server-3.6
media-libs/libcanberra[gtk3]
net-wireless/bluez
- telepathy? ( net-libs/telepathy-glib )
+ >=net-wireless/gnome-bluetooth-3.3:2
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-libs/gtk+-3:3
"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35.5
@@ -48,7 +46,7 @@ DEPEND="${RDEPEND}
# gnome-common needed for eautoreconf
src_prepare() {
- # Fix build with eds-3.6
+ # Fix eds-3.6 building, upstream bug #680927
epatch "${FILESDIR}"/0001-Adapt-to-Evolution-Data-Server-API-changes.patch
[[ ${PV} != 9999 ]] && eautoreconf
@@ -56,9 +54,8 @@ src_prepare() {
}
src_configure() {
- G2CONF="${G2CONF}
- $(use_enable telepathy)
- --enable-bluetooth-plugin
- --disable-static"
- gnome2_src_configure
+ gnome2_src_configure \
+ $(use_enable gnome bluetooth-plugin) \
+ --disable-telepathy \
+ --disable-static
}