summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-11-04 00:07:36 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2014-11-04 00:07:36 +0100
commit3506e079c6d3da91ea7a0b501a1d13616eff0c34 (patch)
tree5255bfd520afa3a0dcebc49e12f1342ecd9335bc /eclass/gnome2-live.eclass
parenteclass/gnome2-live.eclass: enable epatch_user (diff)
downloadgnome-3506e079c6d3da91ea7a0b501a1d13616eff0c34.tar.gz
gnome-3506e079c6d3da91ea7a0b501a1d13616eff0c34.tar.bz2
gnome-3506e079c6d3da91ea7a0b501a1d13616eff0c34.zip
eclass/gnome2-live.eclass: use eautoreconf power
Someone (I think flameeyes) made eautoreconf do this for us a few months ago. Let us just use it and be happy.
Diffstat (limited to 'eclass/gnome2-live.eclass')
-rw-r--r--eclass/gnome2-live.eclass55
1 files changed, 2 insertions, 53 deletions
diff --git a/eclass/gnome2-live.eclass b/eclass/gnome2-live.eclass
index 627f93e3..1a32b2ab 100644
--- a/eclass/gnome2-live.eclass
+++ b/eclass/gnome2-live.eclass
@@ -100,59 +100,8 @@ gnome2-live_src_prepare() {
echo > ChangeLog
fi
- # Find and create macro dirs
- local macro_dirs=($(gnome2-live_get_var AC_CONFIG_MACRO_DIR configure.*))
- for i in "${macro_dirs[@]}"; do
- mkdir -p "$i"
- done
-
- # We don't run gettextize because that does too much stuff
- if grep -qe 'GETTEXT' configure.*; then
- # Generate po/Makefile.in.in if it doesn't exist for packages that use
- # AM_GNU_GETTEXT and AM_GNU_GETTEXT_VERSION (e.g. media-libs/cogl).
- # Logic is inspired by gnome-autogen.sh
- if ! grep -qe '^AM_GLIB_GNU_GETTEXT' configure.* &&
- grep -qe '^AM_GNU_GETTEXT_VERSION' configure.* &&
- [[ -d po && ! -e po/Makefile.in.in && ! -e po/Makefile.am ]]; then
- eautopoint --force
- fi
- local aux_dir=${S}/$(gnome2-live_get_var AC_CONFIG_AUX_DIR configure.*)
- mkdir -p "${aux_dir}"
- test -e "${aux_dir}/config.rpath" || :> "${aux_dir}/config.rpath"
- test -e "${aux_dir}/ABOUT-NLS" || cp "${ROOT}/usr/share/gettext/ABOUT-NLS" "${aux_dir}"
- fi
-
- if grep -qe 'GTK_DOC' configure.*; then
- ebegin "Running gtkdocize"
- gtkdocize
- eend $?
- fi
- if grep -qe 'GNOME_DOC_INIT' configure.*; then
- ebegin "Running gnome-doc-common"
- gnome-doc-common
- eend $?
- ebegin "Running gnome-doc-prepare --automake"
- gnome-doc-prepare --automake
- eend $?
- fi
- if grep -qe "IT_PROG_INTLTOOL" -e "AC_PROG_INTLTOOL" configure.*; then
- if grep -qe "AC_PROG_INTLTOOL" configure.*; then
- eqawarn "This package is using deprecated AC_PROG_INTLTOOL macro."
- eqawarn "Please fill a bug to the upstream of this package."
- fi
- ebegin "Running intltoolize --force"
- intltoolize --force
- eend $?
- fi
- if test -e m4; then
- AT_M4DIR=m4 eautoreconf
- else
- eautoreconf
- fi
-
- # Disable pyc compiling. Doesn't harm if DNE
- echo > py-compile
- chmod +x py-compile
+ # eautoreconf is smart enough to run all necessary commands
+ eautoreconf
### Keep this in-sync with gnome2.eclass!