summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>2012-10-28 19:57:24 +0330
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-28 18:28:57 +0100
commit076d4beb76e46e1648c98cbf5bda3a4569f2cc18 (patch)
treee735b9806cd6f93671ac2dcd4f23a3832ada6048 /gnome-base/gnome-shell
parentgnome-extra/gnome-power-manager: 3.5.90 → 3.6.0 (diff)
downloadgnome-076d4beb76e46e1648c98cbf5bda3a4569f2cc18.tar.gz
gnome-076d4beb76e46e1648c98cbf5bda3a4569f2cc18.tar.bz2
gnome-076d4beb76e46e1648c98cbf5bda3a4569f2cc18.zip
gnome-base/gnome-shell: 3.6.0 → 3.6.1
[GD] Drop sed, it is handled by eclass. Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-base/gnome-shell')
-rw-r--r--gnome-base/gnome-shell/Manifest12
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.6.1.ebuild (renamed from gnome-base/gnome-shell/gnome-shell-3.6.0.ebuild)14
-rw-r--r--gnome-base/gnome-shell/gnome-shell-9999.ebuild14
3 files changed, 21 insertions, 19 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 2fa6650f..43514f61 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1 +1,11 @@
-DIST gnome-shell-3.6.0.tar.xz 1398568 SHA256 032ad32a4fa6c1f92010635e3076031323ac690f78c610184438c085c355e07b SHA512 65fc6c60903780aaf66882ae6ff60929be5018fd570e17404a715334c6b5ae6e17055d6269c51fee63ee3eb458a5cf06cb0bbed3554be108ded89e5b7af75dc3 WHIRLPOOL 7aa6761f6267aaa6aa6310b4ea3122a7925ae411fb3723dc58b00b7fa1bf0e60c2689d53585a35bd88593797151d82d9a61d40aa6c22442781c087c709b8ea15
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-shell-3.6.1.tar.xz 1398784 SHA256 566a9d902f85a89c23dc29f1789f859aa2c5a0de7dffa5235bf5a1885c76a3a7 SHA512 80968025ca36e05fb761730b1ad4d97cd37d259949f73409c6d81df482ce73700e371a8310a2a0537c289f25ec922a3bfb63a418473c8b1125bafa74000dca8c WHIRLPOOL 4716a55af449971875a52f130ccd1b67890c955971db2bd8b59663d12c3150209718cad39a6b11e262a65c053d6ac8439e24e36a13acaf1ed9df0162a332f94c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEAREKAAYFAlCNansACgkQ1fmVwcYIWAZkpQCfbL90+wArkf5hU0q9Y8At4kfB
+0icAn07iXkbzRPxdfoq9kweEGhcoMa8x
+=onXf
+-----END PGP SIGNATURE-----
diff --git a/gnome-base/gnome-shell/gnome-shell-3.6.0.ebuild b/gnome-base/gnome-shell/gnome-shell-3.6.1.ebuild
index 60c1640c..a8612d28 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.6.0.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.6.1.ebuild
@@ -116,6 +116,11 @@ DEPEND="${COMMON_DEPEND}
# https://bugs.gentoo.org/show_bug.cgi?id=360413
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
DOCS="AUTHORS NEWS README"
# Don't error out on warnings
G2CONF="${G2CONF}
@@ -126,11 +131,7 @@ pkg_setup() {
$(use_enable networkmanager)
$(use_with systemd)
BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
- python_set_active_version 2
- python_pkg_setup
-}
-src_prepare() {
# Fix automagic gnome-bluetooth dep, bug #398145
epatch "${FILESDIR}/${PN}-3.5.x-bluetooth-flag.patch"
@@ -139,11 +140,6 @@ src_prepare() {
[[ ${PV} != 9999 ]] && eautoreconf
gnome2_src_prepare
-
- # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
- # Note: sed Makefile.in because it is generated from several Makefile.ams
- sed -e 's/-DG_DISABLE_DEPRECATED//g' \
- -i src/Makefile.in browser-plugin/Makefile.in || die "sed failed"
}
src_install() {
diff --git a/gnome-base/gnome-shell/gnome-shell-9999.ebuild b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
index 60c1640c..a8612d28 100644
--- a/gnome-base/gnome-shell/gnome-shell-9999.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
@@ -116,6 +116,11 @@ DEPEND="${COMMON_DEPEND}
# https://bugs.gentoo.org/show_bug.cgi?id=360413
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
DOCS="AUTHORS NEWS README"
# Don't error out on warnings
G2CONF="${G2CONF}
@@ -126,11 +131,7 @@ pkg_setup() {
$(use_enable networkmanager)
$(use_with systemd)
BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
- python_set_active_version 2
- python_pkg_setup
-}
-src_prepare() {
# Fix automagic gnome-bluetooth dep, bug #398145
epatch "${FILESDIR}/${PN}-3.5.x-bluetooth-flag.patch"
@@ -139,11 +140,6 @@ src_prepare() {
[[ ${PV} != 9999 ]] && eautoreconf
gnome2_src_prepare
-
- # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
- # Note: sed Makefile.in because it is generated from several Makefile.ams
- sed -e 's/-DG_DISABLE_DEPRECATED//g' \
- -i src/Makefile.in browser-plugin/Makefile.in || die "sed failed"
}
src_install() {