summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gmail.com>2011-07-07 03:14:47 -0400
committerAlexandre Rostovtsev <tetromino@gmail.com>2011-07-07 03:14:47 -0400
commitf1c102a60dfc1648e0749ef2e80121fe98b2424a (patch)
treeca465f4f0cea0cc427b87f7ec880f3df68c1cff6 /gnome-base/libgnome-keyring
parentgnome-base/gnome-keyring: 3.0.2 → 3.1.1 (diff)
downloadgnome-f1c102a60dfc1648e0749ef2e80121fe98b2424a.tar.gz
gnome-f1c102a60dfc1648e0749ef2e80121fe98b2424a.tar.bz2
gnome-f1c102a60dfc1648e0749ef2e80121fe98b2424a.zip
gnome-base/libgnome-keyring: 3.0.3 → 3.1.1
Bump to gnome-3.1.x version, add patches to fix memory leaks, punt .la files, change sed to use configure.ac instead of configure.in.
Diffstat (limited to 'gnome-base/libgnome-keyring')
-rw-r--r--gnome-base/libgnome-keyring/Manifest16
-rw-r--r--gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks-crash.patch35
-rw-r--r--gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks.patch58
-rw-r--r--gnome-base/libgnome-keyring/libgnome-keyring-3.1.1.ebuild (renamed from gnome-base/libgnome-keyring/libgnome-keyring-3.0.3.ebuild)11
4 files changed, 105 insertions, 15 deletions
diff --git a/gnome-base/libgnome-keyring/Manifest b/gnome-base/libgnome-keyring/Manifest
index a81d34ff..8f1310e1 100644
--- a/gnome-base/libgnome-keyring/Manifest
+++ b/gnome-base/libgnome-keyring/Manifest
@@ -1,12 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-DIST libgnome-keyring-3.0.3.tar.bz2 423918 RMD160 c3c5ced166e1402e1a7a27b9bf7aa97f80406c34 SHA1 2191dcf06f3fa5412853106f20a95c33a499235e SHA256 a0cc08bcd431070d3f01c2741903c2bd8b0231ee73de709d28e722e28575fdf8
-EBUILD libgnome-keyring-3.0.3.ebuild 1331 RMD160 4afd6fb4289b3a05612e3e0f9c8c44631349ff19 SHA1 e2a373d3fbf9e1c4139a2c2251fe1cdd0b33cee5 SHA256 d393313b6b5633a1bcabced15076273f2c92461ba18516c28243a6ddc29a1a09
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.17 (GNU/Linux)
-
-iEYEARECAAYFAk3gZ5wACgkQ1fmVwcYIWAaHHACg7K6yYVwArmhiLfrV+uGpPa+a
-iDUAnjBGIKHvxASPW3ySqPshDtnjuYin
-=3o0x
------END PGP SIGNATURE-----
+AUX libgnome-keyring-3.1.1-memory-leaks-crash.patch 1195 RMD160 3f9cb3a8238c218fa0b918db875898d6ec914483 SHA1 7087a102101a6ea51211fcca05e5e26713df7217 SHA256 4b8c3d9cbc72d171b274e9ad38b01ff9f7ce92beaf1d1e89c54db70d6c4e8a6a
+AUX libgnome-keyring-3.1.1-memory-leaks.patch 1827 RMD160 4415ad69a330c609b14155530fe6160dae6793dc SHA1 c3082bba392834f65cd13bf69a5968252ee9281a SHA256 4d301a3112d4d17968cc83b633ca0417d25b3cfbc632637a7a6050725981c80a
+DIST libgnome-keyring-3.1.1.tar.bz2 424084 RMD160 ca8a409c5d070f6a6338c706230f348d0ba0de46 SHA1 550323a4fc1c35a1a538c7429d51ef7040ba8a94 SHA256 2c68efe9ecf02cc89580ff59915df5cb5af6c38c186303ead0a79dc7bcd3d5aa
+EBUILD libgnome-keyring-3.1.1.ebuild 1504 RMD160 301a531234ef2f146504e3c1d903e34d6c4a4f46 SHA1 ed89c1e71a1bc8a1eae863d772275d069a6ed4a8 SHA256 e931deba151ae6e1777e09310b0faffb102453f1a57a0dd93a8d3f610c2c3ce8
diff --git a/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks-crash.patch b/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks-crash.patch
new file mode 100644
index 00000000..1e28cdb7
--- /dev/null
+++ b/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks-crash.patch
@@ -0,0 +1,35 @@
+From 9bcac748b54e00836715b0f70be26b7cbdc8c888 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martin.pitt@ubuntu.com>
+Date: Mon, 23 May 2011 08:58:49 +0000
+Subject: Fix crash from recent memleak fix (b49e32b)
+
+make_attribute_list_va() statically copies the caller's method arguments into
+the GnomeKeyringAttributeList, so we must only free the array itself, not the
+GnomeKeyringAttribute strings.
+
+Bug: https://bugzilla.gnome.org/show_bug.cgi?id=650840
+---
+diff --git a/library/gnome-keyring.c b/library/gnome-keyring.c
+index dc271dd..4febf47 100644
+--- a/library/gnome-keyring.c
++++ b/library/gnome-keyring.c
+@@ -2443,7 +2443,7 @@ gnome_keyring_find_itemsv (GnomeKeyringItemType type,
+ va_end (args);
+
+ ret = gnome_keyring_find_items (type, attributes, callback, data, destroy_data);
+- gnome_keyring_attribute_list_free (attributes);
++ g_array_free (attributes, TRUE);
+ return ret;
+ }
+
+@@ -2520,7 +2520,7 @@ gnome_keyring_find_itemsv_sync (GnomeKeyringItemType type,
+ va_end (args);
+
+ ret = gnome_keyring_find_items_sync (type, attributes, found);
+- gnome_keyring_attribute_list_free (attributes);
++ g_array_free (attributes, TRUE);
+ return ret;
+ }
+
+--
+cgit v0.9
diff --git a/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks.patch b/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks.patch
new file mode 100644
index 00000000..5644dd88
--- /dev/null
+++ b/gnome-base/libgnome-keyring/files/libgnome-keyring-3.1.1-memory-leaks.patch
@@ -0,0 +1,58 @@
+From b49e32b32d4d7c326c3bd7dd44ca1c35944a94c4 Mon Sep 17 00:00:00 2001
+From: landijk <landijk-user@yahoo.com>
+Date: Sun, 22 May 2011 11:27:10 +0000
+Subject: Fix memory leaks.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=650606
+---
+diff --git a/library/gnome-keyring.c b/library/gnome-keyring.c
+index d25ad0c..dc271dd 100644
+--- a/library/gnome-keyring.c
++++ b/library/gnome-keyring.c
+@@ -2279,6 +2279,8 @@ find_items_1_reply (GkrOperation *op, DBusMessage *reply, gpointer data)
+ /* Did we find anything? */
+ if (!n_unlocked && !n_locked) {
+ gkr_operation_complete (op, GNOME_KEYRING_RESULT_NO_MATCH);
++ dbus_free_string_array (locked);
++ dbus_free_string_array (unlocked);
+ return;
+ }
+
+@@ -2434,12 +2436,15 @@ gnome_keyring_find_itemsv (GnomeKeyringItemType type,
+ {
+ GnomeKeyringAttributeList *attributes;
+ va_list args;
++ gpointer ret;
+
+ va_start (args, destroy_data);
+ attributes = make_attribute_list_va (args);
+ va_end (args);
+
+- return gnome_keyring_find_items (type, attributes, callback, data, destroy_data);
++ ret = gnome_keyring_find_items (type, attributes, callback, data, destroy_data);
++ gnome_keyring_attribute_list_free (attributes);
++ return ret;
+ }
+
+ /**
+@@ -2506,6 +2511,7 @@ gnome_keyring_find_itemsv_sync (GnomeKeyringItemType type,
+ {
+ GnomeKeyringAttributeList *attributes;
+ va_list args;
++ GnomeKeyringResult ret;
+
+ g_return_val_if_fail (found, GNOME_KEYRING_RESULT_BAD_ARGUMENTS);
+
+@@ -2513,7 +2519,9 @@ gnome_keyring_find_itemsv_sync (GnomeKeyringItemType type,
+ attributes = make_attribute_list_va (args);
+ va_end (args);
+
+- return gnome_keyring_find_items_sync (type, attributes, found);
++ ret = gnome_keyring_find_items_sync (type, attributes, found);
++ gnome_keyring_attribute_list_free (attributes);
++ return ret;
+ }
+
+ /**
+--
+cgit v0.9
diff --git a/gnome-base/libgnome-keyring/libgnome-keyring-3.0.3.ebuild b/gnome-base/libgnome-keyring/libgnome-keyring-3.1.1.ebuild
index b44c6801..46040f07 100644
--- a/gnome-base/libgnome-keyring/libgnome-keyring-3.0.3.ebuild
+++ b/gnome-base/libgnome-keyring/libgnome-keyring-3.1.1.ebuild
@@ -4,8 +4,9 @@
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Compatibility library for accessing secrets"
HOMEPAGE="http://live.gnome.org/GnomeKeyring"
@@ -34,14 +35,18 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
+ # Memory leak fixes, will be in next release
+ epatch "${FILESDIR}/${P}-memory-leaks.patch"
+ epatch "${FILESDIR}/${P}-memory-leaks-crash.patch"
+
# FIXME: Remove silly CFLAGS
sed -e 's:CFLAGS="$CFLAGS -Werror:CFLAGS="$CFLAGS:' \
-e 's:CFLAGS="$CFLAGS -g -O0:CFLAGS="$CFLAGS:' \
- -i configure.in configure || die "sed failed"
+ -i configure.ac configure || die "sed failed"
# FIXME: Remove DISABLE_DEPRECATED flags
sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' \
- -i configure.in configure || die "sed 2 failed"
+ -i configure.ac configure || die "sed 2 failed"
}
src_test() {