summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-10-13 23:41:39 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2013-10-13 23:50:34 +0200
commit98c96376aaec25a6e5abec6e38822609818b2003 (patch)
treee3e05ac5787bc7c82d766e706d5f77b5b75cc732 /gnome-base
parentnet-misc/vino: 3.8.1-r1 → 3.10.0 (diff)
downloadgnome-98c96376aaec25a6e5abec6e38822609818b2003.tar.gz
gnome-98c96376aaec25a6e5abec6e38822609818b2003.tar.bz2
gnome-98c96376aaec25a6e5abec6e38822609818b2003.zip
gnome-base/gnome-keyring: 3.8.2 → 3.10.0
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-keyring/Manifest11
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.10.0.ebuild81
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-9999.ebuild80
3 files changed, 110 insertions, 62 deletions
diff --git a/gnome-base/gnome-keyring/Manifest b/gnome-base/gnome-keyring/Manifest
new file mode 100644
index 00000000..3f092e90
--- /dev/null
+++ b/gnome-base/gnome-keyring/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-keyring-3.10.0.tar.xz 1140272 SHA256 1cc87260fa17b8e39071fdae0418cd9ca5f913d50e23d8f456f3e2c6d6d22213 SHA512 1f63e5fa1c0a79943e1d20d9d7f1fa6c252ebefecba2d404d3584036c43832a3c4f88ef3a99a369199a37ad75302022c89f60147c42252ea3b4896c9a4c320ce WHIRLPOOL e2dd7647c9c22d9beb430e11a1ff980b3e9bb20681073d977afa4e3450a7e80faeef1bf927e00604cfdbeb52e2a954779fe8942acb63d4beb9809240879db624
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlJbE5QACgkQ1fmVwcYIWAZ/cQCghhJjqbOIvMWrSEzNggtkATJD
+xkwAn39MM74D/amyuRMYI2/bGkLGQ78B
+=9LxO
+-----END PGP SIGNATURE-----
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.10.0.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.10.0.ebuild
new file mode 100644
index 00000000..38dc4f62
--- /dev/null
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.10.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes" # Not gnome macro but similar
+GNOME2_LA_PUNT="yes"
+
+inherit fcaps gnome2 pam versionator virtualx
+
+DESCRIPTION="Password and keyring managing daemon"
+HOMEPAGE="http://live.gnome.org/GnomeKeyring"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+caps debug pam selinux"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=app-crypt/gcr-3.5.3:=[gtk]
+ >=dev-libs/glib-2.32.0:2
+ app-misc/ca-certificates
+ >=dev-libs/libgcrypt-1.2.2:=
+ >=sys-apps/dbus-1.1.1
+ caps? ( sys-libs/libcap-ng )
+ pam? ( virtual/pam )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+PDEPEND=">=gnome-base/libgnome-keyring-3.1.92"
+# eautoreconf needs:
+# >=dev-util/gtk-doc-am-1.9
+# gtk-doc-am is not needed otherwise (no gtk-docs are installed)
+
+src_prepare() {
+ # Disable stupid CFLAGS
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ # FIXME: some tests write to /tmp (instead of TMPDIR)
+ # Disable failing tests
+ sed -e '/g_test_add.*test_remove_file_abort/d' \
+ -e '/g_test_add.*test_write_file/d' \
+ -e '/g_test_add.*write_large_file/,+2 c\ {}; \ ' \
+ -e '/g_test_add.*test_write_file_abort_.*/d' \
+ -e '/g_test_add.*test_unique_file_conflict.*/d' \
+ -i pkcs11/gkm/tests/test-transaction.c || die
+ sed -e '/g_test_add.*test_create_assertion_complete_on_token/d' \
+ -i pkcs11/xdg-store/tests/test-xdg-trust.c || die
+ sed -e '/g_test_add.*gnome2-store.import.pkcs12/,+1 d' \
+ -i pkcs11/gnome2-store/tests/test-import.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with caps libcap-ng) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ --enable-ssh-agent \
+ --enable-gpg-agent
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
+}
+
+pkg_postinst() {
+ fcaps cap_ipc_lock usr/bin/gnome-keyring-daemon
+ gnome2_pkg_postinst
+}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild b/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild
index e1b153df..7b76c052 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="yes" # Not gnome macro but similar
GNOME2_LA_PUNT="yes"
-inherit gnome2 pam versionator virtualx
+inherit fcaps gnome2 pam versionator virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -20,16 +20,15 @@ IUSE="+caps debug pam selinux"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
fi
RDEPEND="
- >=app-crypt/gcr-3.5.3:=
+ >=app-crypt/gcr-3.5.3:=[gtk]
>=dev-libs/glib-2.32.0:2
- >=x11-libs/gtk+-3.0:3
app-misc/ca-certificates
>=dev-libs/libgcrypt-1.2.2:=
- >=sys-apps/dbus-1.0
+ >=sys-apps/dbus-1.1.1
caps? ( sys-libs/libcap-ng )
pam? ( virtual/pam )
"
@@ -53,67 +52,24 @@ src_prepare() {
}
src_configure() {
- G2CONF="${G2CONF}
- $(use_with caps libcap-ng)
- $(use_enable pam)
- $(use_with pam pam-dir $(getpam_mod_dir))
- $(use_enable selinux)
- --with-root-certs=${EPREFIX}/etc/ssl/certs/
- --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
- --enable-ssh-agent
- --enable-gpg-agent"
- gnome2_src_configure
+ gnome2_src_configure \
+ $(use_with caps libcap-ng) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ --enable-ssh-agent \
+ --enable-gpg-agent
}
src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
}
pkg_postinst() {
- use caps && fcaps 0:0 755 cap_ipc_lock "${EROOT}"/usr/bin/gnome-keyring-daemon
-
+ fcaps cap_ipc_lock usr/bin/gnome-keyring-daemon
gnome2_pkg_postinst
}
-
-# borrowed from GSoC2010_Gentoo_Capabilities by constanze and Flameeyes
-# @FUNCTION: fcaps
-# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
-# @RETURN: 0 if all okay; non-zero if failure and fallback
-# @DESCRIPTION:
-# fcaps sets the specified capabilities in the effective and permitted set of
-# the given file. In case of failure fcaps sets the given file-mode.
-# Requires versionator.eclass
-fcaps() {
- local uid_gid=$1
- local perms=$2
- local capset=$3
- local path=$4
- local res
-
- chmod $perms $path && \
- chown $uid_gid $path
- res=$?
-
- use caps || return $res
-
- #set the capability
- setcap "$capset=ep" "$path" &> /dev/null
- #check if the capability got set correctly
- setcap -v "$capset=ep" "$path" &> /dev/null
- res=$?
-
- if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missing kernel support."
- ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
- ewarn "where <FS> is the filesystem to store ${path}"
- if ! version_is_at_least 2.6.33 "$(uname -r)"; then
- ewarn "For kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
- fi
- ewarn
- ewarn "Falling back to suid now..."
- chmod u+s ${path}
- fi
- return $res
-}