summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 20:09:20 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-06 20:18:11 +0200
commitc8f11f4bc2178188bdda14c7723dee09a0882d8a (patch)
tree50b53eccd8d6797c6c8eeb2b4f2a07cf7c1ad6f2 /gnome-extra/gnome-system-monitor
parentnet-misc/vinagre: 3.10.2 → 3.12.0 (diff)
downloadgnome-c8f11f4bc2178188bdda14c7723dee09a0882d8a.tar.gz
gnome-c8f11f4bc2178188bdda14c7723dee09a0882d8a.tar.bz2
gnome-c8f11f4bc2178188bdda14c7723dee09a0882d8a.zip
gnome-extra/gnome-system-monitor: 3.10.2 → 3.12.0
Diffstat (limited to 'gnome-extra/gnome-system-monitor')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest11
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.12.0.ebuild44
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild4
3 files changed, 57 insertions, 2 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
new file mode 100644
index 00000000..6d6d2e63
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-system-monitor-3.12.0.tar.xz 793388 SHA256 e2f10547f297002a02f667c4b399242fa82ed1753e0b80ee7c2bbf7034fe3097 SHA512 ba7270c8c7e814e97f47e5f57ec4c9709a40559d5191655114a3e23c5990d28e32049f837e74b2979d8d5d1d8930c2a92dc08a733381257c1899494633b5f6b2 WHIRLPOOL 0548bf5bcd8717508759896bdb6ff12dc0d59b732713d0cf05bcd48979f50b2623eefcbc74d23e68b548eac710a9b6175296ccea34f5ad4ed5a35ccc4c8d1542
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNBmFEACgkQ1fmVwcYIWAbDLQCg40ICt7omilP55+kkIS3n4Lvy
+xjkAoNDmE41ySSkZbxidUkMQRPwndFse
+=24Al
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.12.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.12.0.ebuild
new file mode 100644
index 00000000..abd3e2df
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.12.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd +X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2
+ >=x11-libs/gtk+-3.9.5:3[X(+)]
+ >=x11-themes/gnome-icon-theme-2.31
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+
+ systemd? ( >=sys-apps/systemd-38:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.41.0
+ virtual/pkgconfig
+
+ systemd? ( !=sys-apps/systemd-43* )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
index 6787a581..9514133e 100644
--- a/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -32,7 +32,7 @@ RDEPEND="
>=dev-libs/libxml2-2.0:2
>=gnome-base/librsvg-2.35:2
- systemd? ( >=sys-apps/systemd-38 )
+ systemd? ( >=sys-apps/systemd-38:0= )
X? ( >=x11-libs/libwnck-2.91.0:3 )
"
DEPEND="${RDEPEND}