summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2016-03-30 20:41:49 +0200
committerOle Reifschneider <tranquility@gentoo.org>2016-03-30 20:41:49 +0200
commitdfce7d26ecedd20a90a29080a041ea2eb24b71eb (patch)
tree7e77519c7e0677f3cc4a232e570fd33a6485d452 /gnome-extra/gnome-system-monitor
parentgnome-extra/gnome-power-manager: Bump version to 3.20.0 (diff)
downloadgnome-dfce7d26ecedd20a90a29080a041ea2eb24b71eb.tar.gz
gnome-dfce7d26ecedd20a90a29080a041ea2eb24b71eb.tar.bz2
gnome-dfce7d26ecedd20a90a29080a041ea2eb24b71eb.zip
gnome-extra/gnome-system-monitor: Bump version to 3.20.0
Package-Manager: portage-2.2.28 Manifest-Sign-Key: 0xE9E568677E8B4D42
Diffstat (limited to 'gnome-extra/gnome-system-monitor')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest15
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.20.0.ebuild41
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild8
3 files changed, 59 insertions, 5 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
new file mode 100644
index 00000000..45f94ce9
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST gnome-system-monitor-3.20.0.tar.xz 895368 SHA256 00981b6334ab35cfa186013f1ea0f815bc472c49da4b6764dd716f87e4b49033 SHA512 ff26fec86306c027b7b6f65c06fbcaf724ecfe76a8b4bf23798b64d1654e8a9a96fe797bfc87fda07c6e044574e767253f320110a85683f7940a5893c147fdda WHIRLPOOL 9382842266c03d050771132104b91192cf7c89b3ab874a3371e4fb0d2b02fe1f955c0283f623bdf062f668276fc4604fec711dc5b68d82a128eed11d0d27643d
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQEcBAEBCAAGBQJW/B3tAAoJEOnlaGd+i01CKBQH/Rc3T8kOfe+W6NdvdRgGca45
+FpP2lAR266yqxhgSrFyrCTBP9bcMIKOkbopgGg8Fe7+7p/SSDdWz8udkSwXpU2qO
+Fh09/b/akje4i4tmTAI1+gKBfNDqcgNPcN/UCgd2/q/RF/APFQQrBW8G7rj9E9+S
+AIWWzDPogQs9n7l/Jt3i+z9QVK036fpRCVjo5Z4zcV/FYG2id+VjOExjKBnyr+ES
+MZ88tsz3E6a/7o+A8Hy+g6sjwZE/Pwwxeh8+E18pd5pBkkTaDCJptv92Nf3FAV8s
+5nIO0CiQljuUV63wDq1JX6b/DcUqRoSSugEIZQeFGxHI6Q+uQX7RgsoTpdtps0o=
+=3CSb
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.20.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.20.0.ebuild
new file mode 100644
index 00000000..29da6de4
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.20.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2=
+ >=x11-libs/gtk+-3.12:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+ systemd? ( >=sys-apps/systemd-44:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck)
+}
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
index 2c82ba02..d75cf12b 100644
--- a/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -30,16 +30,14 @@ RDEPEND="
>=dev-cpp/glibmm-2.34:2
>=dev-libs/libxml2-2.0:2
>=gnome-base/librsvg-2.35:2
-
- systemd? ( >=sys-apps/systemd-38:0= )
+ systemd? ( >=sys-apps/systemd-44:0= )
X? ( >=x11-libs/libwnck-2.91.0:3 )
"
+# eautoreconf requires gnome-base/gnome-common
DEPEND="${RDEPEND}
>=app-text/gnome-doc-utils-0.20
>=dev-util/intltool-0.41.0
virtual/pkgconfig
-
- systemd? ( !=sys-apps/systemd-43* )
"
if [[ ${PV} = 9999 ]]; then