summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-02-07 23:33:36 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-02-07 23:46:49 +0530
commit276012a16110c9c2a4353c96cc7f02311c20940c (patch)
tree6503ec6a63914e8eab5eb652f78c37b0d552d77e /gnome-extra/gtkhtml
parentx11-libs/libnotify: all relevant changes moved to gentoo-x86 (diff)
downloadgnome-276012a16110c9c2a4353c96cc7f02311c20940c.tar.gz
gnome-276012a16110c9c2a4353c96cc7f02311c20940c.tar.bz2
gnome-276012a16110c9c2a4353c96cc7f02311c20940c.zip
Drop .la files from all GNOME 3 ebuilds
* Move gnome2-la.eclass functionality into gnome2.eclass - GNOME2_LA_PUNT will remove *all* .la files * Use posix-compatible find command * Some ebuilds don't use gnome2, so remove manually there
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/Manifest4
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.32.1-r200.ebuild4
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.91.6.ebuild7
3 files changed, 4 insertions, 11 deletions
diff --git a/gnome-extra/gtkhtml/Manifest b/gnome-extra/gtkhtml/Manifest
index cf3c88b7..b26c52b4 100644
--- a/gnome-extra/gtkhtml/Manifest
+++ b/gnome-extra/gtkhtml/Manifest
@@ -1,4 +1,4 @@
DIST gtkhtml-3.32.1.tar.bz2 1196875 RMD160 f90aaf1fa50a956221ee7420f86c871068dea5cc SHA1 8f89cfe44de2ef9fe6c25064ba03761292f525aa SHA256 78b6da6c1f4f61947f77de505a626a028ee3ecb6ad3c7c06cc4a6273e16d95c6
DIST gtkhtml-3.91.6.tar.bz2 1187460 RMD160 ca35b7de525363bf349b544c09370090aba9e19c SHA1 451b3ef552988df2c0b39c8dd1bf1731b33b9739 SHA256 c6b4e940d92c49fdb1d5c4966bc8a85e9a314e243cf24754212fcee9afc9ba52
-EBUILD gtkhtml-3.32.1-r200.ebuild 1393 RMD160 7b3a838ffb803dd7e200614caf06aa1553989126 SHA1 6bb41d2caaa2692761c38861e8e103ce85352023 SHA256 741a883fa7b2ba5def965037c618bfabae822ac2be40a2b9e93bbdf64524ccad
-EBUILD gtkhtml-3.91.6.ebuild 1257 RMD160 f40af38b9240eb3604ddb9d224fb19920adbde2a SHA1 5bde6ce82199f44b4e0ce7ce6c466cdb3214479d SHA256 147bcb9aafaeecae6fa921dd63620b6a5b7b64ba8c5326b834f31165834570c1
+EBUILD gtkhtml-3.32.1-r200.ebuild 1275 RMD160 92b7b26bf1d3d18c42ec2a88e0dd444b227e6007 SHA1 f6582626f1f0e926a4bda16887b108539f4809cb SHA256 39eda8d9192ef2b7f144b13ff5fa1a7eb53b379c8cd5a4a5a9cb15b0bbea6814
+EBUILD gtkhtml-3.91.6.ebuild 1101 RMD160 27c9fa967f1fa5b2adef05d9a1661cdd821621a0 SHA1 cdf3e90b36b6e530f236c2b8a9a83f5580bc3131 SHA256 73bf65182b8f9df018c0de8b30d837975c0598898af6280fe52ee34aa098403d
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.32.1-r200.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.32.1-r200.ebuild
index 81e819ef..b82b3fc2 100644
--- a/gnome-extra/gtkhtml/gtkhtml-3.32.1-r200.ebuild
+++ b/gnome-extra/gtkhtml/gtkhtml-3.32.1-r200.ebuild
@@ -4,6 +4,7 @@
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
inherit gnome2 eutils
@@ -44,7 +45,4 @@ src_install() {
# Don't clash with gtkhtml:4.0
rm -vf "${ED}/usr/bin/gtkhtml-editor-test" || die
-
- # Remove .la files since old will be removed anyway while updating
- find "${ED}" -name "*.la" -delete || die "remove of la files failed"
}
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.91.6.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.91.6.ebuild
index 9ac48773..00d0f2f5 100644
--- a/gnome-extra/gtkhtml/gtkhtml-3.91.6.ebuild
+++ b/gnome-extra/gtkhtml/gtkhtml-3.91.6.ebuild
@@ -4,6 +4,7 @@
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
inherit gnome2 eutils
@@ -38,9 +39,3 @@ pkg_setup() {
--disable-deprecated-warning-flags"
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
}
-
-src_install() {
- gnome2_src_install
- # Remove .la files since old will be removed anyway while updating
- find "${ED}" -name "*.la" -delete || die "remove of la files failed"
-}