summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-15 02:41:53 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-15 02:41:53 -0400
commitad2ffd3109f9ba4d95cf374a87b269db47c810f1 (patch)
treed3547a6a3e6e33a12deadc72026e0d705eb0a28d /media-libs
parentgnome-extra/gnome-shell-extensions: add 3.5.91 (diff)
downloadgnome-ad2ffd3109f9ba4d95cf374a87b269db47c810f1.tar.gz
gnome-ad2ffd3109f9ba4d95cf374a87b269db47c810f1.tar.bz2
gnome-ad2ffd3109f9ba4d95cf374a87b269db47c810f1.zip
media-libs/cogl: add 1.11.4
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/Manifest4
-rw-r--r--media-libs/cogl/cogl-9999.ebuild47
2 files changed, 36 insertions, 15 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
index 39b333e2..732b1337 100644
--- a/media-libs/cogl/Manifest
+++ b/media-libs/cogl/Manifest
@@ -1 +1,3 @@
-EBUILD cogl-9999.ebuild 1743 RMD160 f1f505650a67365a74cbd81132c64dae9d6bd9ca SHA1 2973724295f7bf258758ddf1222dca19324cedf1 SHA256 e2fa576901624ec5909663126cc86a90f6290d8e64016409e238b1fc0f87bdf6
+DIST cogl-1.11.4.tar.xz 1290688 SHA256 bd66ccd12a607c7b2cdc2b3be1f0b8afc7ed1f1c62f22f5e4e31e36ebe1b0f8b SHA512 90d9328e02200e449b6bf6027a4fd84f9c77abc2980a4bb60216cbd7a646dbd6258611c0e439a737eea73ba76659282b80de5742b166fa8d8184a655f2215b9c WHIRLPOOL e1b6c70bc513f50f8ad914160357b1586b4698e5e03311d707882bb67b2ea6db89c0204e63156273938da25e00fe01f742594a199b97ea52b7fa238558e5b23f
+EBUILD cogl-1.11.4.ebuild 2593 SHA256 f2a187f182ed8cbcc7e5935dfaf0cf22b30a956eaea3e7a29719bb6d185c5ba8 SHA512 f1f6d34d6d9ada3a78dc8c8f1f9df3bfdf7a726bd6a7277ab264d16c16276e1aa3558501da26025a2a225b0f4264fd7e5c24c879c07b20e416bc6046f550e2e3 WHIRLPOOL 94cfaa2cab37d4f325833a0b34f71228e646ea11481ea8f514d11aa890c5836480365f9893dc65d6148346a16293af7122bcea0609db83ba09b85d2a35603ce3
+EBUILD cogl-9999.ebuild 2593 SHA256 f2a187f182ed8cbcc7e5935dfaf0cf22b30a956eaea3e7a29719bb6d185c5ba8 SHA512 f1f6d34d6d9ada3a78dc8c8f1f9df3bfdf7a726bd6a7277ab264d16c16276e1aa3558501da26025a2a225b0f4264fd7e5c24c879c07b20e416bc6046f550e2e3 WHIRLPOOL 94cfaa2cab37d4f325833a0b34f71228e646ea11481ea8f514d11aa890c5836480365f9893dc65d6148346a16293af7122bcea0609db83ba09b85d2a35603ce3
diff --git a/media-libs/cogl/cogl-9999.ebuild b/media-libs/cogl/cogl-9999.ebuild
index 694082fc..c5243a5a 100644
--- a/media-libs/cogl/cogl-9999.ebuild
+++ b/media-libs/cogl/cogl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI="4"
CLUTTER_LA_PUNT="yes"
# Inherit gnome2 after clutter to download sources from gnome.org
-inherit clutter gnome2 virtualx
+inherit clutter gnome2 multilib virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -16,15 +16,15 @@ HOMEPAGE="http://www.clutter-project.org/"
LICENSE="LGPL-2.1"
SLOT="1.0"
-IUSE="doc examples +introspection +pango"
+IUSE="doc examples +introspection +opengl gles2 +pango"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~x86"
fi
# XXX: need uprof for optional profiling support
-COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
x11-libs/cairo
>=x11-libs/gdk-pixbuf-2:2
x11-libs/libdrm
@@ -33,7 +33,9 @@ COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
x11-libs/libXdamage
x11-libs/libXext
>=x11-libs/libXfixes-3
+ virtual/glu
virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
@@ -44,31 +46,48 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
virtual/pkgconfig
doc? ( app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.13 )"
-
-# XXX: at least when using nvidia-drivers, tests fail under Xemake/Xvfb, no
-# matter whether "eselect opengl" is set to nvidia or xorg-x11.
-RESTRICT="test"
+ >=dev-util/gtk-doc-1.13 )
+ test? ( app-admin/eselect-opengl
+ media-libs/mesa[classic] )"
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
pkg_setup() {
DOCS="NEWS README"
EXAMPLES="examples/{*.c,*.jpg}"
- # XXX: think about gles, quartz, wayland
+ # XXX: think about kms-egl, gles, quartz, sdl, wayland
G2CONF="${G2CONF}
+ --disable-examples-install
--disable-profile
--disable-maintainer-flags
--enable-cairo
--enable-gdk-pixbuf
- --enable-gl
- --enable-glx
+ $(use_enable opengl glx)
+ $(use_enable opengl gl)
+ $(use_enable gles2)
+ $(use_enable gles2 cogl-gles2)
+ $(use_enable gles2 xlib-egl-platform)
+ --enable-glib
+ --enable-deprecated
$(use_enable introspection)
$(use_enable pango cogl-pango)"
+ use gles2 && G2CONF="${G2CONF} --with-default-driver=gles2"
}
src_test() {
- Xemake check
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
}
src_install() {
clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
}