summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-28 10:55:14 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-28 10:55:47 +0100
commitc24bacacd8be07d7ab6bf06e4f7dd54be061038a (patch)
tree80fe46d31b931761e2041da78b6c5be7d2a642b3 /media-libs
parentnet-libs/webkit-gtk: Update ruby reqs and add space checks (diff)
downloadgnome-c24bacacd8be07d7ab6bf06e4f7dd54be061038a.tar.gz
gnome-c24bacacd8be07d7ab6bf06e4f7dd54be061038a.tar.bz2
gnome-c24bacacd8be07d7ab6bf06e4f7dd54be061038a.zip
media-libs/gstreamer: do not use versionator anymore
Relic of the 0.10 slot ebuild but not needed anymore. Use ${SLOT} where possible.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gstreamer/Manifest10
-rw-r--r--media-libs/gstreamer/gstreamer-1.0.2.ebuild11
2 files changed, 14 insertions, 7 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index fe01ea88..be2d223d 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
DIST gstreamer-1.0.2.tar.xz 3118740 SHA256 10c59112bb01a274eb33950300da13d25fd23a7494781bf1b2328372fdb6ee06 SHA512 2cd7cc1ee52368097af0dd27a540b3e05e6200ef198575ba9900899326cdc6fffdd02c51e993dd62cce3160bf1769e4a9b489b0d8718ac37777f39e25387d19d WHIRLPOOL 23a2898fdb346b570dd28fc80731496ecaa0eb918fc9729645e8960fab91ec940a0d8d0e29639c9573e486a09c8fd8abc5cc230473ecb3d55835ffdba69fbed3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEAREKAAYFAlCNAQIACgkQ1fmVwcYIWAY5hQCgtAZB9qByqhGED4LSGB/v59ld
+C2UAoK8cNeG2Ft8bCffUAHrcsUpr1i1c
+=RQQW
+-----END PGP SIGNATURE-----
diff --git a/media-libs/gstreamer/gstreamer-1.0.2.ebuild b/media-libs/gstreamer/gstreamer-1.0.2.ebuild
index 99d99c4d..c0ea0244 100644
--- a/media-libs/gstreamer/gstreamer-1.0.2.ebuild
+++ b/media-libs/gstreamer/gstreamer-1.0.2.ebuild
@@ -4,17 +4,14 @@
EAPI=4
-inherit eutils multilib pax-utils versionator
-
-# Create a major/minor combo for our SLOT and executables suffix
-PV_MAJ_MIN=$(get_version_component_range '1-2')
+inherit eutils multilib pax-utils
DESCRIPTION="Streaming media framework"
HOMEPAGE="http://gstreamer.freedesktop.org/"
SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
LICENSE="LGPL-2+"
-SLOT=${PV_MAJ_MIN}
+SLOT="1.0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+introspection nls +orc test"
@@ -67,6 +64,6 @@ src_install() {
prune_libtool_files --modules
# Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
- use orc && pax-mark -m "${ED}usr/bin/gst-launch-1.0" \
- "${ED}usr/libexec/gstreamer-1.0/gst-plugin-scanner"
+ use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}" \
+ "${ED}usr/libexec/gstreamer-${SLOT}/gst-plugin-scanner"
}