summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2013-12-05 13:05:33 +0200
committerPriit Laes <plaes@plaes.org>2013-12-05 13:05:33 +0200
commit8180d774d725ea18c44a8864b4ffac4fbe805bed (patch)
treec2fdac1041bb00393f19dc680b75ee277ebe2fbc /media-sound/rhythmbox
parentdev-libs/totem-pl-parser: Fix sed command (diff)
downloadgnome-8180d774d725ea18c44a8864b4ffac4fbe805bed.tar.gz
gnome-8180d774d725ea18c44a8864b4ffac4fbe805bed.tar.bz2
gnome-8180d774d725ea18c44a8864b4ffac4fbe805bed.zip
media-sound/rhythmbox: Fix live version and sync with portage
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/rhythmbox-9999.ebuild139
1 files changed, 62 insertions, 77 deletions
diff --git a/media-sound/rhythmbox/rhythmbox-9999.ebuild b/media-sound/rhythmbox/rhythmbox-9999.ebuild
index 629e7fe9..9a0c350d 100644
--- a/media-sound/rhythmbox/rhythmbox-9999.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.5"
-PYTHON_USE_WITH="xml"
-PYTHON_USE_WITH_OPT="python"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python3_{2,3} )
+PYTHON_REQ_USE="xml"
-inherit eutils gnome2 python multilib virtualx
+inherit eutils gnome2 python-single-r1 multilib virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -18,35 +18,40 @@ HOMEPAGE="http://www.rhythmbox.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="cdr daap dbus doc +keyring html ipod libnotify lirc mtp nsplugin +python
+IUSE="cdr daap dbus +libsecret html ipod libnotify lirc mtp nsplugin +python
test +udev upnp-av visualizer webkit zeitgeist"
+
+IUSE+=" python_single_target_python3_2 +python_single_target_python3_3"
+
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
REQUIRED_USE="
ipod? ( udev )
mtp? ( udev )
dbus? ( python )
- webkit? ( python )"
+ webkit? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
# FIXME: double check what to do with fm-radio plugin
# webkit-gtk-1.10 is needed because it uses gstreamer-1.0
-COMMON_DEPEND=">=dev-libs/glib-2.34.0:2
- dev-libs/json-glib
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34.0:2
>=dev-libs/libxml2-2.7.8:2
>=x11-libs/gtk+-3.6:3[introspection]
>=x11-libs/gdk-pixbuf-2.18.0:2
>=dev-libs/gobject-introspection-0.10.0
>=dev-libs/libpeas-0.7.3[gtk,python?]
>=dev-libs/totem-pl-parser-3.2.0
- >=net-libs/libsoup-2.26:2.4
- >=net-libs/libsoup-gnome-2.26:2.4
- >=media-libs/gst-plugins-base-0.11.92:1.0[introspection]
- >=media-libs/gstreamer-0.11.92:1.0[introspection]
+ >=net-libs/libsoup-2.34:2.4
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gstreamer:1.0[introspection]
>=sys-libs/tdb-1.2.6
+ dev-libs/json-glib
visualizer? (
>=media-libs/clutter-1.8:1.0
@@ -56,13 +61,13 @@ COMMON_DEPEND=">=dev-libs/glib-2.34.0:2
media-plugins/gst-plugins-libvisual:1.0 )
cdr? ( >=app-cdr/brasero-2.91.90 )
daap? (
- >=net-libs/libdmapsharing-2.9.16:3.0
+ >=net-libs/libdmapsharing-2.9.19:3.0
media-plugins/gst-plugins-soup:1.0 )
- keyring? ( >=app-crypt/libsecret-0.14 )
+ libsecret? ( >=app-crypt/libsecret-0.14 )
html? ( >=net-libs/webkit-gtk-1.10:3 )
libnotify? ( >=x11-libs/libnotify-0.7.0 )
lirc? ( app-misc/lirc )
- python? ( >=dev-python/pygobject-3.0:3 )
+ python? ( >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}] )
udev? (
virtual/udev[gudev]
ipod? ( >=media-libs/libgpod-0.7.92[udev] )
@@ -87,61 +92,59 @@ RDEPEND="${COMMON_DEPEND}
x11-libs/pango[introspection]
dbus? ( sys-apps/dbus )
- keyring? ( >=app-crypt/libsecret-0.14[introspection] )
+ libsecret? ( >=app-crypt/libsecret-0.14[introspection] )
webkit? (
- dev-python/mako
+ dev-python/mako[${PYTHON_USEDEP}]
>=net-libs/webkit-gtk-1.10:3[introspection] ) )
"
-# gtk-doc-am needed for eautoreconf
-# dev-util/gtk-doc-am
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
app-text/yelp-tools
+ dev-util/gtk-doc-am
>=dev-util/intltool-0.35
>=app-text/gnome-doc-utils-0.9.1
- doc? ( >=dev-util/gtk-doc-1.4 )
- test? ( dev-libs/check )"
-DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
- MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+ test? ( dev-libs/check )
+"
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- G2CONF="${G2CONF} PYTHON=$(PYTHON -2)"
- fi
-
- # --enable-vala just installs the sample vala plugin, and the configure
- # checks are broken, so don't enable it
- G2CONF="${G2CONF}
- MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins
- --enable-mmkeys
- --disable-more-warnings
- --disable-schemas-compile
- --disable-static
- --disable-vala
- --without-hal
- $(use_enable visualizer)
- $(use_enable daap)
- $(use_enable libnotify)
- $(use_enable lirc)
- $(use_enable nsplugin browser-plugin)
- $(use_enable python)
- $(use_enable upnp-av grilo)
- $(use_with cdr brasero)
- $(use_with daap)
- $(use_with keyring libsecret)
- $(use_with html webkit)
- $(use_with ipod)
- $(use_with mtp)
- $(use_with udev gudev)"
-
- export GST_INSPECT=/bin/true
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
+ DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+
+ rm -v lib/rb-marshal.{c,h} || die
gnome2_src_prepare
- echo > py-compile
+}
+
+src_configure() {
+ # FIXME: bug???
+ export GST_INSPECT=/bin/true
+
+ # --enable-vala just installs the sample vala plugin, and the configure
+ # checks are broken, so don't enable it
+ gnome2_src_configure \
+ MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins \
+ VALAC=$(type -P valac-0.14) \
+ --enable-mmkeys \
+ --disable-more-warnings \
+ --disable-static \
+ --disable-vala \
+ --without-hal \
+ $(use_enable visualizer) \
+ $(use_enable daap) \
+ $(use_enable libnotify) \
+ $(use_enable lirc) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable python) \
+ $(use_enable upnp-av grilo) \
+ $(use_with cdr brasero) \
+ $(use_with html webkit) \
+ $(use_with ipod) \
+ $(use_with libsecret) \
+ $(use_with mtp) \
+ $(use_with udev gudev)
}
src_test() {
@@ -149,21 +152,3 @@ src_test() {
unset DBUS_SESSION_BUS_ADDRESS
Xemake check || die "test failed"
}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if use python; then
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
- fi
-
- ewarn
- ewarn "If ${PN} doesn't play some music format, please check your"
- ewarn "USE flags on media-plugins/gst-plugins-meta:1.0"
- ewarn
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
-}